× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Meteo.txt ogni volta mi fa impazzire

Di più
4 Settimane 1 Giorno fa #8695 da asy961
Guarda non ho capito cosa hai fatto.....
sei partito da una installazione completa di Raspbian??

le operazioni da fare sono

1 scaricare il file immagine da qui
drive.google.com/file/d/1SJhLsSXBbB2nonZ...fki/view?usp=sharing
2 installare il file immagine direttamente sulla SD
3 inserire la SD nel raspberry accenderlo e configurare la rete
4 eseguire l'aggiornamento all'ultima versione con swpi-update
5 configurare swpi in base ai propri sensori meteo e credenziali ftp


riavviare il tutto e vedere il corretto funzionamento


se hai fatto questo posta il file log.txt


Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 1 Giorno fa #8697 da pierpis
:( :( :(
Niente da fare.... aspetto l'arrivo della nuova SD, ho installato la versione swpi che mi hai mandato, si era fatto un suo numero Ip che poi ho modificato come quello che mi da il router, ho assegnato l'IP del router e dal mio dominio mi son fatto dare la certezza del loro IP.... tutto sostituito.
Vado a mettere l'IP del Raspberry (quello del router) e nulla, il server non trova la pagina :( :(
dal log del programma noto che è ancora in SIMULATE e produce dati, leggo un errore di collegamento al server e quindi da accertarmi bene del numero IP che mi hanno dato.

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 1 Giorno fa #8698 da asy961
Piero.....mi sa che stai facendo un pò di confusione....

ripartiamo dal primo passo...

dopo che hai installato swpi sulla scheda SD inseriscila nel raspberry e accendilo....
senza fare altre cose dovresti riuscire a vedere la pagina di configurazione digitando l'indirizzo IP del raspberry su un qualsiasi browser web.......

se non riesci in questo fammi sapere

Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 1 Giorno fa #8699 da asy961
In ogni caso qualcosa si era mosso....il 31/08 alle 10:47 il file meteo.txt sul sito si è aggiornato.....

Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 16 Ore fa - 4 Settimane 16 Ore fa #8700 da pierpis
Ripartito da zero, installato nuovamente la versione del swpi che mi hai dato.
1- ho segnato da parte l'IP che si è fatto il Rasp 198.168.0.147
2- Ho notato che è diverso da quello del router 198.168.178.48
3- ho provato ad inserire nel browser l'IP del Rasp (192.168.0.147) Non trova la pagina
4- dal rasp ho digitato sudo nano /etc/dhcpcd.conf
interface eth0
static ip_address= 192.168.178.48
static routers= 198.168.xxx.xxx. (IP del router)
static domain_name_servers= 198.49.xxx.xxx (IP server)
5- reset del Rasp e riparte, noto che è cambiato l'IP del Rasp
6- Riprovo a mettere nel browser il nuovo IP del Rasp (che è quello assegnato al swpi) NULLA
7- reietto nuovamente e mi accorgo che il Rasp ha assegnato un nuovo IP.... mi incazzo e spengo tutto e vado a mangiare una pizza :)
8-Rientro e faccio ripartire il Raspberry... miracolo, si ha ripreso l'IP del router (?????)
9- Rimetto l'IP nel browser e finalmente si apre la configurazione, setto tutto da come avevo salvato (fiducioso) quindi reietto per la nuova configurazione..... e mi accorgo che il Rasp HA MESSO UN ALTRO IP !!!! Ma vaff..... spengo tutto. Ho comprato una nuova SD e domani riparto.

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Ultima Modifica 4 Settimane 16 Ore fa da pierpis.

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 7 Ore fa #8701 da asy961

pierpis ha scritto: Ripartito da zero.............

4- dal rasp ho digitato sudo nano /etc/dhcpcd.conf
interface eth0
static ip_address= 192.168.178.48
static routers= 198.168.xxx.xxx. (IP del router)
static domain_name_servers= 198.49.xxx.xxx (IP server)
................



penso che cosi non vada bene....

devi editare il file /etc/network/interfaces

come ti ho già indicato nel post precedente QUI



se ancora non risolvi scrivimi in pvt a Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.


Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 6 Ore fa #8702 da pierpis
Ciao, ti mando questa risposta veloce, ho fatto i comandi sopra perché con /etc/network/interfaces mi risponde :accesso negato.
Stamattina ho acceso il Raspberry e mi da l'IP del router (quindi giusto) invece ieri sera quando l'ho spento era quello che si è dato da solo.... comunque, nel forum stiamo dilungando (per colpa mia) e ti contatterò all'indirizzo che mi hai fornito..... se tutto non va

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi a partecipare alla conversazione.

Di più
4 Settimane 5 Ore fa #8704 da asy961
Guarda Piero facciamo un ultimo tentativo...

leggi bene questa piccolissma guida che ti allego per editare il file interfaces direttamente dal raspberry


basta avere un monitor e una tastiera collegati al raspberry



altrimenti aspetto una tua mail



Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:
Ringraziano per il messaggio: pierpis

Si prega Accedi a partecipare alla conversazione.

Di più
2 Settimane 5 Giorni fa #8705 da pierpis
Riapro il topic per dirvi com'è andata a finire.
Con il buon Asy961 (Valerio) siamo riusciti a far partire la stazione e devo dare tutti i meriti a lui (grazie Valerio) in quest'ultima settimana mi ha gentilmente offerto il suo tempo per farmi fare prove e contro prove.
In pratica e probabilmente il server in cui appoggio il mio sito, aveva cambiato un po di logiche nel ricevere i comandi (o percorsi) per potervi accedere, quindi il setting con cui per anni è andato tutto bene, di colpo non lo era più.
La password l'hanno cambiata e sicuramente l'hanno anche trasmessa alla mia email e io, purtroppo, non sono andato a vederla.
Ho cambiato anche il trasmettitore della mia PCE.... ragazzi, quando cambiate il trasmettitore guardate che tipo ve lo inviano, nel senso di verificare in che frequenza trasmette..... sono cose elementari che (povero me) avevo tralasciato e Valerio mi ha aperto gli occhi.
Valerio mi ha pure fornito una versione di SWPI con già il setting per far dialogare la chiavetta DVB col trasmettitore.
In conclusione..... io già mi sarei mandato a quel paese, Valerio è stato di grande pazienza e di grande aiuto per cui lo ringrazio tantissimo..... e, la cena in Sardegna, quando vieni... è assicurata!!!
Buon forum a tutti

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi a partecipare alla conversazione.

Tempo creazione pagina: 0.443 secondi