× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Interruzione Upload Wunderground

More
10 months 2 hours ago #8523 by amonphi
Ciao ragazzi,

sto impazzendo da giorni senza trovare soluzione purtroppo.
Tutto ad un tratto non vengono più caricati i dati su Wunderground, ho controllato l'ID della stazione e la psw nella configurazione e sono ok, al sito web accedo tranquillamente con le credenziali. Premetto che la stazione comunica perfettamente con la consolle (ho una PCE FWS-20), carica perfettamente i dati sul database in Altervista e li visualizzo tranquillamente da dashboard del sintwindpi meteopaparano.altervista.org/index.php

Qualcuno sa districarmi da questa cosa strana per favore?

Metto anche un log dove l'unica cosa che stona è "Log to Wunderground : unauthorized"

[27/11/2019-21:14:44] Starting SINT WIND PI ...
************************************************************************
* Sint Wind PI 01.26.75 *
* *
* 2012-2018 by Tonino Tarsi <This email address is being protected from spambots. You need JavaScript enabled to view it.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[27/11/2019-21:14:54] System revision (0010) : Raspberry Model B+ PCB 1.0
[27/11/2019-21:15:14] loading plugins
[27/11/2019-21:15:14] Starting sensor reading - Sensor type is : WH1080_RTL-SDR
[27/11/2019-21:15:14] Starting plugin : <module 'wunderground' from './plugins/wunderground.pyc'>
[27/11/2019-21:15:14] Starting plugin : <module 'IPCamLogger' from './plugins/IPCamLogger.pyc'>
[27/11/2019-21:15:14] Config Server running on port 80
[27/11/2019-21:15:14] Checking internet connection ...
[27/11/2019-21:15:15] Internet ok
[27/11/2019-21:15:15] Checking internet connection ...
[27/11/2019-21:15:15] Internet ok
Wed Nov 27 21:15:15 CET 2019
[27/11/2019-21:15:15] System time adjusted from NTP server : pool.ntp.org
[27/11/2019-21:15:15] Connected with IP : MIO
[27/11/2019-21:15:15] Local IP : MIO Public IP : MIO
[27/11/2019-21:15:15] Starting General WatchDog
Wed Nov 27 21:15:16 CET 2019
[27/11/2019-21:15:16] System time adjusted from NTP server : pool.ntp.org
[27/11/2019-21:15:16] RTL-SDR-compatible USB DVB-T dongle detected.
[27/11/2019-21:15:18] Mail sent to : MIA
[27/11/2019-21:15:21] Starting RF listening
[27/11/2019-21:15:31] First data received from WH1080_RTL-SDR, station 0042. Processing...
[27/11/2019-21:15:31] BME280 - Temperature: 24.1 C Pressure: 963.2 humidity 53
[27/11/2019-21:15:31] Calculating Meteo data and statistics
[27/11/2019-21:15:34] No digital cameras found
[27/11/2019-21:15:34] Checking internet connection ...
[27/11/2019-21:15:34] Internet ok
[27/11/2019-21:15:34] Rereading config file ..
[27/11/2019-21:15:34] Disk space left = 3678 Mb
[27/11/2019-21:15:34] Sleeping 598 seconds
Wed Nov 27 21:15:35 CET 2019
[27/11/2019-21:15:35] System time adjusted from NTP server : pool.ntp.org
[27/11/2019-21:16:01] Log to Wunderground : unauthorized
[27/11/2019-21:16:02] Deleted file : /dev/shm/meteo.txt
[27/11/2019-21:16:02] Sending file to server : meteo.txt OK Deleted
[27/11/2019-21:16:02] Data sent to server : OK
[27/11/2019-21:16:22] Logging data to Database
[27/11/2019-21:16:22] Dir: SE - Spd: 0.0 - Gst: 1.22 - Tout: 15.8 - Tin: 24.1 - Hout: 92.0 - Hin: 52.7 - P: 1007 - Rtot: 413.1 - RDay: 35.4 - R1h: 0.6 - R24h: 35.4 - CB: 533
[27/11/2019-21:16:22] Logging data ...
[27/11/2019-21:16:23] Data sent to server : OK
[27/11/2019-21:16:23] Logging data to Wunderground ...
[27/11/2019-21:16:23] Log to Wunderground : unauthorized
[27/11/2019-21:16:23] Uploading data ...
[27/11/2019-21:16:24] Deleted file : /dev/shm/meteo.txt
[27/11/2019-21:16:24] Sending file to server : meteo.txt OK Deleted
[27/11/2019-21:17:00] Data sent to server : OK
[27/11/2019-21:17:00] Posizione IPcam SE
[27/11/2019-21:17:01] Log to Wunderground : unauthorized
[27/11/2019-21:17:02] Deleted file : /dev/shm/meteo.txt
[27/11/2019-21:17:02] Sending file to server : meteo.txt OK Deleted
[27/11/2019-21:17:14] New data received from WH1080_RTL-SDR station 0042. Processing...
[27/11/2019-21:17:14] BME280 - Temperature: 24.1 C Pressure: 963.2 humidity 53
[27/11/2019-21:17:14] Calculating Meteo data and statistics
[27/11/2019-21:18:01] Log to Wunderground : unauthorized
[27/11/2019-21:18:01] Deleted file : /dev/shm/meteo.txt
[27/11/2019-21:18:01] Sending file to server : meteo.txt OK Deleted
[27/11/2019-21:18:04] Logging data to Database
[27/11/2019-21:18:04] Dir: S - Spd: 1.22 - Gst: 4.9 - Tout: 15.8 - Tin: 24.1 - Hout: 92.0 - Hin: 52.7 - P: 1007 - Rtot: 413.1 - RDay: 35.4 - R1h: 0.6 - R24h: 35.4 - CB: 533
[27/11/2019-21:18:04] Logging data ...
[27/11/2019-21:18:04] Data sent to server : OK
[27/11/2019-21:18:04] Logging data to Wunderground ...
[27/11/2019-21:18:05] Log to Wunderground : unauthorized
[27/11/2019-21:18:05] Uploading data ...
[27/11/2019-21:18:06] Deleted file : /dev/shm/meteo.txt
[27/11/2019-21:18:06] Sending file to server : meteo.txt OK Deleted

Please Log in to join the conversation.

More
9 months 4 weeks ago #8525 by Bendinelli
Buonasera,
ti suggerisco di cancellare e riscrivere l'ID e la password nella scheda Weather Underground; è successo una volta anche a me!!!!

Claudio

Claudio

PCE-FSW 20
Raspberry Pi 2 Modello B
swpi - Raspbian GNU/Linux 8.0 (jessie) #1341 5.4.65-v7+
Sint Wind PI 01.27.21

Please Log in to join the conversation.

More
9 months 3 weeks ago #8526 by amonphi

Bendinelli wrote: Buonasera,
ti suggerisco di cancellare e riscrivere l'ID e la password nella scheda Weather Underground; è successo una volta anche a me!!!!

Claudio


Ciao, guarda dopo vari giorni sono riuscito a venirne a capo ed il discorso è legato al discorso della nuova politica delle API col passaggio del sito a IBM, la cosa strana è che già avevo accettato le nuove condizioni e fatto quanto richiesto, e che ha continuato a funzionare per molto.

Detto questo contattando direttamente i loro tecnici, attraverso la loro community, mi hanno detto che al posto della password, dove richiesta, va inserita la Key di 8 cifre generata in Wunderground, a fianco dell'id stazione in mydevice.

Fatto questo tutto per magia è tornato a funzionare.

Io non so se gli altri né sono a conoscenza, o se ne sia parlato ma, ho passato giorni a leggere tutti i post senza leggere nulla a riguardo.

Possibile sia successo solo a me?

Please Log in to join the conversation.

More
3 weeks 3 days ago #8584 by pierpis
Buongiorno a tutti,
anche a me si è inceppato il collegamento con WUnderground, ho rifatto nuovamente l'account e mi è stato dato un nuovo ID della stazione con la chiave a 8 cifre.
Ho nuovamente aggiornato la configurazione del SWIP (schermata rosa) ma purtroppo non è successo nulla.
Vorrei chiedere ad Amonphi se le le 8 cifre da sostituire alla password sono da mettere dove? nel login con WU oppure nelle configurazioni del SWPI?
Scusate ma non ne vengo proprio a capo :((

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
3 weeks 3 days ago #8585 by amonphi
Ciao, l'ho scritto dove va inserita.... ovunque venga richiesta la password Wunderground metti quella nuova di 8 cifre. In swpi_config.py la metti al Tab Weather nell'apposita voce sotto l'ID stazione.

Please Log in to join the conversation.

More
3 weeks 3 days ago - 3 weeks 3 days ago #8586 by pierpis
Ho iniziato col login e siccome mi ero iscritto con password personale, come mi hai consigliato, ho messo il codice a 8 cifre ma non mi riconosce, mentre con la pass di iscrizione mi fa entrare nel sito, ho anche sostituito la pass nella configurazioni Spwi con le 8 cifre.... ma non funge nulla

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Attachments:
Last edit: 3 weeks 3 days ago by pierpis. Reason: aggiunta file

Please Log in to join the conversation.

More
3 weeks 2 days ago #8587 by amonphi
Guarda io non sono uno dei creatori o sviluppatori ma un semplice utente. Comunque non ho capito di quale login parli e di quale password parli, se non mi specifichi login di cosa e password di cosa sinceramente non capisco, poi ancora password di iscrizione. Cerca di specificarmi di cosa parli altrimenti posso farti ben poco, ripeto sono un utente non uno degli sviluppatori. Dalla foto comunque ho visto che in pws hai messo lo stesso id di Wunderground ma, credo che lì sia riferito al sito pwsweather ma non ho la certezza. Sei iscritto anche lì e hai utilizzato stesso id e password per la stazione?

Please Log in to join the conversation.

More
3 weeks 2 days ago #8588 by pierpis
Ciao, il bello dei forum è questo... ci si aiuta (nei limiti del possibile) anche fra utenti normali. :)
Parto col dirti che ho sbagliato con Pwsweather e quindi non prenderlo in considerazione, in quanto a alla password ho ripreso il tuo post precedente dove hai scritto che hai immesso le 8 cifre alla richiesta di qualunque password che ti chiedeva WU.... a me la richiede al momento del login al sito, poi altro non saprei, e cosi ho fatto :)

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
3 weeks 2 days ago #8589 by amonphi
Guarda speriamo di capirci perché altrimenti mi fai diventare matto. Allora in WU entri tranquillamente? Se si perfetto ma, quella password utilizzala per quel sito. In web config di swpi, alla voce Weather underground password devi invece mettere la Key device, cioè la nuova chiave generata delle famose 8 cifre. Poi ricorda di riavviare il tutto una volta fatte le modifiche. Di più non so che dirti purtroppo

Please Log in to join the conversation.

More
3 weeks 2 days ago - 3 weeks 2 days ago #8590 by pierpis
Accedo tranquillamente a WU con mail e password privata, posso vedere la configurazione della mia stazione e accedere al profilo in caso debba cambiare pass.... ecc.. ecc... nella configurazione di WU vedo assegnata la chiave a 8 cifre e l'ID della stazione.... ma non la mia stazione che trasmette.
Sulla configurazione di SWPI hai visto che ho messo l'ID e la chiave a 8 cifre..... poi il buio :(
E da parte di WU mai ricevuta conferma d'iscrizione

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Last edit: 3 weeks 2 days ago by pierpis.

Please Log in to join the conversation.

More
3 weeks 1 day ago #8591 by amonphi
Prova a scaricare un log file da web config e vedi se hai qualche errore e postalo qui oscurando le password naturalmente, magari qualcuno altro può venire in aiuto

Please Log in to join the conversation.

More
3 weeks 1 day ago #8592 by pierpis
Grazie a tutti ragazzi per la vostra attenzione, Underground è ripartito, non so come ma lo ha fatto, forse era solo aver un po di pazienza :)

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

Time to create page: 0.742 seconds