× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file immagine per trasmettitori 87 bit

Di più
2 Settimane 2 Giorni fa #8367 da supergigi73
dopo vari smanettamenti , l'acquisto di due nuove centraline di trasmissione ( entrambe con bollino 14B , due chiavette rtl .... e ..rosari... ho capito che le mie centraline di trasmissione sono a 87 bit . quindi chiedo cortesemente se è possibile avere un 'immagine SWPI ver 3 con il file modificato per riceveere il segnale dalle stazioni 87bit oppure la procedura passo per passo delle righe di comando per modificare la versione originale per 88bit a 87 bit ... penso che sia cosa gradita da tanti utenti vecchi e nuovi dato che le nuove stazioni wh1080 , pce fws 20 e cloni vari oppure le trasmittenti di ricambio escono tutte con la trasmittente a 87 bit e frequenza 433 ( bollino sotto il vano batterie A 14B ) , le trasmittenti di ricambio 14C a 863.6 sono in esaurimento.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Settimane 2 Giorni fa #8368 da asy961
Ciao supergigi73,

leggi bene qua

www.vololiberomontecucco.it/vlmc/index.p...usb-rtl-sdr-per-swpi


avevamo già risolto il problema degli 87bit / 88bit


altrimenti segui le istruzioni che trovi per installare le librerie RTL-SDR

io non ho provato con rasp3 ma Seven si e dovrebbe funzionare

Valerio.


.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Settimane 13 Ore fa #8370 da supergigi73
grazie Valerio , la discussione l'ho trovata e anche il procedimento , ma non conoscendo bene i comandi di linux non sono in grado di eseguirlo se non con una guida passo passo ( le righe in sequenza da scrivere da terminale ) .

ovvero queste istruzioni come le scrivo sul putty o direttamente in swpi ? :

"
Quindi ricapitoliamo: scàricati i nuovi sorgenti di rtl_433 da qui (cosa che hai già fatto);

Con il sistema in rw scompattali in una cartella vuota;

Sovrascrivi il file
(rtl_433)/src/devices/fineoffset_wh1080.c
con quello allegato;

Nella cartella principale dei sorgenti crea la cartella
/build

"

la discussione del procedimento è qua :

www.vololiberomontecucco.it/vlmc/index.p...rtl433?start=30#7367

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Settimane 12 Ore fa #8371 da asy961
Ciao supergigi73,

se hai il raspberry collegato ad un monitor e tastiera lo puoi fare direttamente da terminale fermando prima swpi con crtl-c durante il conto alla rovescia, altrimenti da terminale putty va bene lo stesso.

premesso che tu abbia l'ultimo aggiornamento di swpi ti copio il post di Seven dove spiega benissimo cosa fare per installare correttamente RTL-SDR......



Seven ha scritto:

....forsenon hai installato le librerie rtl-sdr e rtl_433. Prova a dare il comando:

/usr/local/bin/rtl_eeprom


Se il sistema ti dice che il comando non esiste allora è così. Con la stessa chiavetta il mio sistema risponde:

root@swpi(ro):/usr/local/bin# ./rtl_eeprom
Found 1 device(s):
0: Generic RTL2832U OEM

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner

Current configuration:
__________________________________________
Vendor ID: 0x0bda
Product ID: 0x2838
Manufacturer: Realtek
Product: RTL2838UHIDIR
Serial number: 00000001
Serial number enabled: yes
IR endpoint enabled: yes
Remote wakeup enabled: no
__________________________________________
Reattached kernel driver


Installarle è molto semplice e richiede pochi minuti. Controlla se la tua attuale cartella /swpi contiene le due directory:

rtl-sdr

e

rtl_433

Se non le hai scaricale direttamente da Github (github.com/ToninoTarsi/swpi) e copiale nella cartella /swpi.

Poi installa i seguenti pacchetti:

sudo apt-get -y install libusb-1.0-0-dev cmake


Ora dai rw per mettere il sistema in lettura-scrittura e dai i seguenti comandi:

cd rtl-sdr
mkdir build
cd build

cmake ../ -DDETACH_KERNEL_DRIVER=ON -DINSTALL_UDEV_RULES=ON

make
sudo make install




Tocca ora a rtl_433. Torna in /swpi e dai i comandi seguenti:

cd rtl_433
mkdir build
cd build
cmake ../
make
sudo make install


infine

sudo ldconfig


A questo punto riprova a dare /usr/local/bin/rtl_eeprom e vedi se ti riconosce la chiavetta. Se si il gioco è fatto, se no ci risentiamo per di qua



Come dice Seven se funziona bene altrimenti scrivi ancora qua.


Valerio




.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Settimane 11 Ore fa #8372 da supergigi73
forse non ho descritto bene la mia situazione attuale: Raspberry ultima versione PI 3 modello B+ con montata SWPI versione 3 con tutti gli aggiornamenti disponibili sia di swpi ( swpi-update ) che upgrade e update del sistema operativo. Con questa configurazione anche impostando la ricezione a 433 non riesco ad ottenere i dati della mia stazione meteo perchè funziona a 87 bit e non a 88. Da quello che ho capito devo modificare il file fineoffset_wh1080.c all'interno della cartella rtl_433/src/devices/ seguendo la procedura in questa discussione dove alla terza pagina c'è proprio il mio caso : www.vololiberomontecucco.it/vlmc/index.p...rtl433?start=30#7367 . Quella che mi hai riportato qua sotto è relativa alla versione 2 del SWPi che ha il conto alla rovescia che non rileva la chiavetta ... anche se faccio quella procedura sulla versione 3 di swpi non mi ritrovo poi il file fineoffset_wh1080.c sovrascritto perchè prende quelli "standard" di github . Quindi torno a chiedere : quali sono i comandi per sovrascrivere il file fineoffset_wh1080.c con quello modificato e pubblicato in quella discussione ? o forse mi sfugge qualcosa di banale e quindi non capisco e mi stai dicendo la stessa cosa ? è corretto quello che mi serve ? devo modificare il file : fineoffset_wh1080.c per ottenere la ricezione corretta dalla mia stazione a 87 bit ... scusate se rompo ma nel forum purtroppo le informazioni si sono frammentate nelle varie discussioni e non riesco legare i frammenti per ottenere la soluzione al mio problema

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Settimane 9 Ore fa #8376 da seven
Ciao!
La cosa da fare è essenzialmente quella che ti suggeriva Valerio, ma se non ti trovi proviamo così.

Poichè hai già aggiornato SWPI all'ultima versione disponibile, al suo interno è presente la cartella rtl_433 che contiene già i sorgenti corretti pronti da compilare. E' necessario soltanto compilarli: da PuTTY metti il sistema in scrittura ed esegui in sequenza questi comandi:

cd /swpi
cd rtl_433
mkdir build
cd build
cmake ../
make
sudo make install

sudo ldconfig



Riavvia la Raspberry e dovresti essere a posto, altrimenti ci sentiamo qui.
Ciao!

Nik

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Settimane 5 Ore fa #8377 da asy961

supergigi73 ha scritto: .............. Da quello che ho capito devo modificare il file fineoffset_wh1080.c all'interno della cartella rtl_433/src/devices/ ..................................


NO
non devi modificare nulla se hai installato l'ultima versione di swpi......

quel file è stato sotituito da questo

fineoffset_wh1080_wh3080.c

all'interno della cartella rtl_433/src/devices/

devi solo controllare che queste righe

264 if ((bitbuffer->bits_per_row[0] != 88) && (bitbuffer->bits_per_row[0] != 87) &&
265 (bitbuffer->bits_per_row[0] != 64) && (bitbuffer->bits_per_row[0] != 63)){
266 return 0;
267 }

siano uguali nel tuo file


stasera mi sono fatto 'prestare' un raspi3 da un amico e ho provato a montare una sd con la versione 3 di swpi

dopo averlo configurato e aggiornato all'ultima versione (01.26.88) posso dirti che la chiavetta RTL funziona......io però in questo momento ho solo un trasmettitore PCE a 88bit e 868Mhz......non ho potuto fare prove con altri sensori.....



Valerio.




.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Settimana 6 Giorni fa #8378 da supergigi73
Grazie a tutti e scusate se sono duro di comprendonio dopo la ricompilazione di rtl_433 funziona tutto anche con il trasmettitore a 87 bit .


scusate ancora se ho rotto le scatole

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Settimana 6 Giorni fa #8381 da seven
Ottima notizia e nessuna rottura di scatole, tranquillo supergigi, nessunissimo problema.
Siamo qui per aiutarci!

Ciaoo!

Nik

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.735 secondi