× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Librerie spidev

Di più
1 Anno 4 Mesi fa #8045 da asy961
Librerie spidev è stato creato da asy961
Ciao a tutti,
per informazione.....

ho dovuto reinstallare da capo una nuova SD su una delle nostre stazioni meteo
ma dopo aver aggiornato all'ultima versione 01.25.34 ho avuto dei problemi con le librerie spidev usando la configurazione PCE-SENSOR con il MCP3002 per il sensor_argent80422.py tanto che ho dovuto reinstallarle/aggiornarle

questi i comandi:

rw
git clone git://github.com/doceme/py-spidev
cd py-spidev/
sudo python setup.py install
ro
sudo reboot


Tony non so se è solo un caso isolato ma te lo segnalo lo stesso per eventuali prove e aggiornamenti nelle future versioni.

Ciao
Valerio.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 4 Mesi fa #8050 da tony
Risposta da tony al topic Librerie spidev
Grazie Valerio,
In effetti le ultime versioni hanno una modifica proprio in quella parte.
Ora uso sempre le Librerie spidev per m'MCP3002 indipendentemente dal modello.
Questo per compatibilità di un nuovo driver per il sistema di trasmissione radio LoRa sul quale stò lavorando.
Comunque: Che versione del firmware stavi usando ? Perché con la swpi_1056.img pensavo fosse tutto ok. Forse avevi una versione più vecchia ?
Fammi sapere perché se non è cosi ricontrollo la 1056
TT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 4 Mesi fa - 1 Anno 4 Mesi fa #8051 da asy961
Risposta da asy961 al topic Librerie spidev
Ciao Tony,
si ho usato certamente una versione più vecchia, di solito quando metto a punto una nuova SD prima di montarla definitivamente sulla stazione faccio un backup, mi creo un'immagine personalizzata in modo da ripartire da una base certa, non so dirti che immagine originale era ma nel backup era installata la versione di swpi 01.23.42 (mi pare) del 2016.....appena provata sul banco prima di fare l'aggiornamento con swpi-update funzionava ma dopo andava in blocco subito alla prima lettura dei sensori PCE ritornando un errore su quelle librerie....
peccato che sul log non ha registrato nulla di quell errore e io non ho fatto foto al video.....
cmq tutto si è risolto come ho detto nel post precedente
se hai occasione e ne hai voglia nelle prossime prove fai un test con l'MCP3002 anche te....

Ciao

Valerio.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 1 Anno 4 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.362 secondi