× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Stazione PCE e Versione 3

Di più
1 Anno 11 Mesi fa - 1 Anno 11 Mesi fa #7921 da kolombo
Stazione PCE e Versione 3 è stato creato da kolombo
Salve,
ho da anni ho installato sul tetto il vostro sistema con un raspberry pi 2.
in questi giorni è mancata la corrente e non ha voluto più accendersi, è ho così pensato di montare la nuova versione 3 dell'immagine da voi creata, ma mi fa delle cose strane appena cerco di configurare la stazione pce.
mi spiego meglio:
sul tetto ho una stazione pce collegata con un sensore RFM01, ma con la nuova versione sembra che non la vada a chiamare.Anche se forzo la connessione tramite promt,non ricevo risposta.

in allegato la configurazione della vecchia versione 1 funzionatene.

sapreste aiutarmi a settare la nuova versione?
Grazie
Nicola

File allegato:

Nome del file: swpi_14_01_17.zip
Dimensione del file:2 KB
Allegati:
Ultima Modifica 1 Anno 11 Mesi fa da kolombo.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7922 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Ciao Nik,
fermo restando che ti suggerisco il passaggio all'ormai celeberrima chiavetta DVB-T di cui si parla in vari altri post, se proprio vuoi rimanere agganciato al RFM01 credo che il primo problema a cui guardare sia la necessità di ricompilare i sorgenti di wh1080_rf, che trovi nell'omonima sottocartella di swpi.

Prima di ricompilarlo però devi metter mano al file bmp085.c ed eseguire una piccola modifica alla riga 19:

Da così:

#include "bcm2835.h"


va trasformata così:

#include "rf_bcm2835.h"


Salva il file e dai il comando make.
In pochi secondi l'eseguibile wh1080_rf verrà ricompilato, a quel punto prova di nuovo a ricevere il segnale e vediamo un po'.

Ciaoo

Nik

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7923 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
Ciao, e grazie del consiglio ma niente. la stazione non vuole più comunicare con nessun lna e rssi. solo ....
ho letto l'articolo della chiavetta DVB-T e della facilità d'uso, ma non ho trovato il modo di andarla a utilizzarla nell'attuale sintwindpi. esistono delle istruzioni su come implementarla?
Grazie Nicola

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7924 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Il buon caro, vecchio e capriccioso modulo RFM01 ha fatto sclerare anche me a suo tempo... E' come un mulo: può andare avanti a testa bassa per anni e poi magari un giorno ti pianta di punto in bianco, e giù di sclerate... :)

Invece uno dei vantaggi della chiavetta USB in SWPI (versione 3) è proprio la semplicità di configurazione: basta collegarle l'antennino in dotazione, connetterla ad una porta USB della Raspberry (meglio se a sistema spento), far partire la Raspberry e dal pannello di controllo di SWPI selezionare il driver WH1080_RTL-SDR (se hai la pce FWS-20) oppure WH3080_RTL-SDR (previo aggiornamento di SWPI) .
Infine dalla relativa sezione del pannello seleziona la banda di frequenza della tua stazione (433Mhz oppure 868Mhz).
Salva, riavvia la Raspberry ed è fatta.

Ti rammento che la chiavetta deve essere basata sul chip RTL2832U e sul tuner r820t o r820t2.
Fai una ricerca su ebay con i termini RTL2832U r820t2, la trovi attorno ai 10-15 euro. Stai alla larga da quelle che costano oltre i 20 euro, le pagheresti molto per nulla (sono tutte pressoché uguali tra loro). ;)
Quelle basate sul tuner r820t costano meno di quelle basate su tuner r820t2 perchè quest'ultimo è più recente e leggermente più sensibile (ma fidati vanno bene entrambi i modelli).

Ciao!

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7925 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
ciao,
chiavetta 820t2 arrivata e installata su una nuova installazione di swpi v3 e aggiornato all'ultima versione 01.24.03.

il mio problema è che non funziona.
ho impostato WH1080_RTL-SDR, impostato la frequenza a 868Mhz, ma dal log non vedo apparire nulla e mi scrive un errore: Warning could not delete wh1080-rtl_433.txt file
possibile che abbia problemi la pce?
Grazie
Nicola


************************************************************************
* Sint Wind PI 01.24.03 *
* *
* 2012-2017 by Tonino Tarsi <Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[29/05/2016-17:29:24][29/05/2016-17:29:24] loading plugins
Starting sensor reading - Sensor type is : WH1080_RTL-SDR
[29/05/2016-17:29:24] Starting plugin : <module 'wunderground' from './plugins/wunderground.pyc'>
[29/05/2016-17:29:24] Starting plugin : <module 'IPCamLogger' from './plugins/IPCamLogger.pyc'>
[29/05/2016-17:29:24] Config Server running on port 80
[29/05/2016-17:29:24] Checking internet connection ...
[29/05/2016-17:29:24] Internet ok
[29/05/2016-17:29:24] Checking internet connection ...
[29/05/2016-17:29:25] Internet ok
[29/05/2016-17:29:26] RTL-SDR-compatible USB DVB-T dongle detected.
Thu Jul 20 15:51:17 CEST 2017
[20/07/2017-15:51:17] System time adjusted from NTP server : time.windows.com
[20/07/2017-15:51:18] Warning could not delete wh1080-rtl_433.txt file
[20/07/2017-15:51:18] Starting RF listening
[20/07/2017-15:51:22] Connected with IP :188.188.188.6

[20/07/2017-15:51:22] Starting General WatchDog
Thu Jul 20 15:51:28 CEST 2017
[20/07/2017-15:51:28] System time adjusted from NTP server : time.windows.com
[20/07/2017-15:53:23] No digital cameras found
[20/07/2017-15:53:23] Disk space left = 4508 Mb
[20/07/2017-15:53:23] Sleeping 600 seconds
[20/07/2017-16:03:23] No digital cameras found
[20/07/2017-16:03:23] Disk space left = 4508 Mb
[20/07/2017-16:03:23] Sleeping 600 seconds

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7926 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Ciao Nik,
il messaggio di warning è normale appena avviato SWPI, poi non dovrebbe farlo più: swpi non riesce a cancellare il file che contiene i dati in arrivo dalla WH1080, in quanto non essendo ancora arrivati il file non esiste.

Per quanto riguarda la mancata ricezione: se sei sicuro che la frequenza della tua stazione sia a 868 Mhz, sei ad una ragionevole vicinanza ai sensori esterni della pce ed -ovviamente- hai collegato l'antennina alla chiavetta allora è possibile che sia la stazione ad avere una magagna.
Disponi della console LCD della stazione? Se si: riceve i dati correttamente?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7927 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
Ciao, la frequenza che usavo con rfm01 era 868 quindi ti direi di sì. L'antenna è a pochi metri dove il con il vecchio rfm01 funzionava quindi mi aspetto che funzioni meglio.
Niente console quindi non posso verificare.
Proverò a comprare una stazione nuova :(
Grazie

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7928 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Prima dell'acquisto fai questa prova: da console di swpi (stai usando la versione 3 giusto?) dai il comando swpi stop in modo da fermare swpi, poi dai il comando:

rtl_433 -f 868300000 -l 0

Lascialo lì almeno un quartino d'ora, se la stazione funziona vedrai che al massimo entro una decina di minuti riceverai i dati provenienti dal sensore esterno.
Se ancora non ricevi nulla non ti resta che provare ad "ascoltare" direttamente la frequenza di trasmissione della stazione con SdrSharp, ti basta un pc Windows e (sempre lei) la chiavetta USB che ben conosci. Ecco il link di uno dei siti a cui puoi far riferimento per l'installazione. Un altro è qui , ed un altro è qui .
Come dicevo potrai sintonizzarti direttamente sul canale di trasmissione della stazione e rimanere in attesa del segnale, se non altro per vedere se viene trasmesso o no. Mettendo l'antenna in prossimità del sensore lo dovresti ricevere bello forte.
In bocca al lupone!

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7929 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner
Exact sample rate is: 250000.000414 Hz
[R82XX] PLL not locked!
Sample rate set to 250000.
Bit detection level set to 0.
Tuner gain set to Auto.
Reading samples in async mode...
Tuned to 868300000 Hz.
2016-05-29 18:47:23 : Fine Offset WH1080 weather station
Msg type: 0
StationID: 00CD
Temperature: 27.5 C
Humidity: 48 %
Wind string: S
Wind degrees: 180
Wind avg speed: 2.45
Wind gust: 3.67
Total rainfall: 0.0
I dati in questo modo arrivano
Questo vuol dire che la pce comunica
Cosa devo modificare allora?
Grazie
Nicola

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa - 1 Anno 11 Mesi fa #7930 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Ottimo segno, il sensore da' segni di vita! Potrebbe essere un po' fuori frequenza, forse è il motivo per il quale l'RFM01 non lo agganciava più.

Ferma SWPI con il consueto swpi stop, poi modifica il file

/swpi/sensor_wh1080rtlsdr.py

alla riga 94: lì c'è l'esatta frequenza (per la banda 868Mhz) sulla quale si sintonizza la chiavetta. E' indicata in Hertz (un milione di Hertz = 1 Mhz). Prova a cambiarla di poco in su o in giù (da 868200000 a 868300000, 868400000 oppure a scendere). Gioca solo con la 4a cifra, altrimenti ti sposti di troppo. Ogni volta salva il file e poi dài swpi start e vedi se va. Attendi sempre una decina di minuti prima di modificare nuovamente: a cavallo delle ore pari infatti il sensore sta zitto anche per 5-7 minuti a seconda di come gli gira e non riceveresti nulla anche se fossi sulla corretta frequenza. E' il momento in cui si sincronizza via radio con il segnale orario DCF77. :)

EDIT: visto che con il comando "rtl_433 -f 868300000 -l 0" i dati li ricevi, direi che la frequenza da utilizzare è proprio quella. Se la ricezione fosse ancora instabile prova a spostarti un po' più in su di ulteriori 50 Khz (868350000).
Ultima Modifica 1 Anno 11 Mesi fa da seven.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 11 Mesi fa #7931 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
Non so perché è come ma durante la notte senza modificare nulla di nuovo ha iniziato a comunicare.
Grazie mille del supporto a tutti
Nicola

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 9 Mesi fa - 1 Anno 9 Mesi fa #7934 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
salve, sono ancora alla ricerca di un aiuto per la stessa problematica.
La stazione pce per come aveva cominciato a funzionare è di nuovo morta. Per questo motivo ho deciso di acquistarne una nuova su amazon ws1080 ( www.amazon.it/Forever-Speed-professional...=1-1&keywords=ws1080 ), apparentemente identica alla pce20 che avevo prima(non so quale Delle 2 sia l'originale).
Apparentemente perchè questa stazione non riesco a leggerla con la DVB-T.
sotto al display c'è scritto che la frequenza è 8683 quindi mi aspettavo di leggerla normalmente come la vecchia, invece...
ho provato a giocare con le frequenze 8682 ecc. ma niente
da display della stazione vedo tutto correttamente.

avete dei consigli da darmi?
Grazie
Nicola
Ultima Modifica 1 Anno 9 Mesi fa da kolombo.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa - 1 Anno 8 Mesi fa #7954 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
ciao,
sono ancora fermo con la mia stazione e non riesco a trovarne una quadra.
facendo un riepilogando:
- stazione nuova montata sul tetto wh1080 868 mhz
- raspberry pi 3 con antenna DVB-T
- installazione sint Wind PI v3 appena rifatta e aggiornata

l'antenna non rileva dati dalla stazione sul tetto.
L'antenna è posizionata a 5 mt dai sensori e il display della wh1080 legge tutti i dati provenienti dalla stazione

nel logo leggo solo questo
[01/10/2017-17:13:33] Starting SINT WIND PI ...
************************************************************************
* Sint Wind PI 01.24.06 *
* *
* 2012-2017 by Tonino Tarsi <Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[01/10/2017-17:13:44][01/10/2017-17:13:44] loading plugins
Starting sensor reading - Sensor type is : WH1080_RTL-SDR
[01/10/2017-17:13:44] Starting plugin : <module 'wunderground' from './plugins/wunderground.pyc'>
[01/10/2017-17:13:44] Starting plugin : <module 'IPCamLogger' from './plugins/IPCamLogger.pyc'>
[01/10/2017-17:13:44] Checking internet connection ...
[01/10/2017-17:13:44] Internet ok
[01/10/2017-17:13:44] Checking internet connection ...
[01/10/2017-17:13:44] Internet ok
[01/10/2017-17:13:45] RTL-SDR-compatible USB DVB-T dongle detected.
Sun Oct 1 17:13:50 CEST 2017
[01/10/2017-17:13:50] System time adjusted from NTP server : time.windows.com
[01/10/2017-17:13:51] Warning could not delete wh1080-rtl_433.txt file
[01/10/2017-17:13:51] Starting RF listening
[01/10/2017-17:13:55] Connected with IP :5.86.66.62

[01/10/2017-17:13:55] Local IP :10.0.2.20 Public IP : 5.86.66.62

[01/10/2017-17:13:55] Starting General WatchDog
Sun Oct 1 17:14:00 CEST 2017
[01/10/2017-17:14:00] System time adjusted from NTP server : time.windows.com
[01/10/2017-17:15:55] No digital cameras found
[01/10/2017-17:15:55] Disk space left = 4508 Mb
[01/10/2017-17:15:55] Sleeping 600 seconds
[01/10/2017-17:25:55] No digital cameras found
[01/10/2017-17:25:55] Disk space left = 4508 Mb
[01/10/2017-17:25:55] Sleeping 600 seconds




cos'altro posso provare a fare per far ritornare online la stazione?
Grazie dul supporto
Nicola
Ultima Modifica 1 Anno 8 Mesi fa da kolombo.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7955 da guzzi1000sp
Risposta da guzzi1000sp al topic Stazione PCE e Versione 3
Ciao Nicola, prova a modificare il file /swpi/sensor_wh1080rtlsdr.py come suggerito da Seven, anche io sono passato dal modulo RFM01 alla pennetta DVB-t a maggio e inizialmente, come a te, non andava proprio. Dopo aver verificato su che frequenza trasmetteva la stazione, sempre con il metodo indicato da Seven, ho dovuto modificare il frequenza di ricezione da 868200000 a 868300000. Da allora la raspberry non ha mai perso un colpo, anche aumentando di parecchio la distanza dalla stazione.

Paolo

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7956 da kolombo
Risposta da kolombo al topic Stazione PCE e Versione 3
Ciao e grazie della risposta.
Purtroppo come modifica questa la avevo già provata visto che sul retro del display c'è espressamente scritto che lavora a 868,3
ho provato anche con qualche frequenza in più e in meno, ma purtroppo niente.
Adesso ho ordinato un'altra chiavetta dvb-t per vedere se potesse essere lei ad essere impazzita, ma ho poca fiducia visto che se la imposto a 484 leggo dei sensori presenti nelle vicinanze.

Altri consigli ?
Grazie
Nicola

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7957 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Ciao,
la WS1080 utilizza purtroppo un protocollo dati diverso dalla WH1080, non sarai quindi in grado di decodificare nulla con la chiavetta (né tantomeno con l'RFM01).
Ho visto che poco tempo fa qualcuno ha iniziato a lavorare su questo protocollo in rtl_433, ma per ora non è stato ancora pubblicato il 'driver'. Se hai ancora la vecchia WH1080 puoi riprovare ad utilizzarla seguendo i consigli di qualche post più su, altrimenti non ti resta che attendere gli sviluppi di rtl_433.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 3 Mesi fa - 1 Anno 3 Mesi fa #8164 da ciapa85
Risposta da ciapa85 al topic Stazione PCE e Versione 3
Nessuna App eBay definita nella configurazione Kunena
https://www.ebay.it/itm/USB-2-0-Digital-DVB-T-SDR-DAB-FM-HDTV-TV-Tuner-Receiver-Stick-RTL2832U-R820T2-CN/173225275900?hash=item285507f1fc:g:rvYAAOSwlGVasBBG


questa chiavetta può andare bene?

anche io ho problemi con RFM01, ho provato sia swpi v2 che v3 ma non riesco a ricevere i dati, con la console della stazione leggo regolarmente i dati
Ultima Modifica 1 Anno 3 Mesi fa da ciapa85. Motivo: link

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 3 Mesi fa #8165 da seven
Risposta da seven al topic Stazione PCE e Versione 3
Ciao,
si, stando alla descrizione è quella giusta.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.627 secondi