× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file problema $ gpio -v $ gpio readall comandi non funzionanti

Di più
1 Anno 8 Mesi fa #7906 da MassimoArtuso
Salve, sto provando sint wind pi per realizzare delle stazioni da donare a dei rifugi.
Sto partendo con delle prove e per ora ho preso una raspberry 3 e un sensore dht11
al di la che non mi funziona nel senso che ho installato tutto sulla raspberry e anche sul lato server ftp ma mi arrivano sempre dati a casaccio.

Dunque mi sono letto un pò di aiuti su questo forum che parlavano propio del sensore in questione ed ho fatto la procedura consigliata ma in fine mi sono accorto che i comandi
$ gpio -v
$ gpio readall
a me non funzionano mi viene sempre fuori:
-bash: gpio: comando non trovato
mi potete dare un aiuto!

Massimo Artuso

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7907 da seven
Ciao Massimo,
quale immagine SWPI stai utilizzando? Per quanto riguarda le prime due disponibili al link Download (rispettivamente la versione 2 e la versione 3) ho appena provato e su entrambe il comando funziona alla perfezione...

Per quanto riguarda i dati a casaccio, sei sicuro che non sia attivo il sensore "Simulate" nel pannello di controllo di SWPI?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7908 da MassimoArtuso
Gentilissimo Seven,
Grazie della risposta effettivamente era inpostato su sensore "Simulate".
ma i comandi gpio non funzionavano pertanto ho deciso di rinstallare tutto da zero.
Comunque per lo meno con il "simulate" so che l'ftp funziona :)

Ho rinstallato l'immagine ora i comandi
$ gpio -v
$ gpio readall
FUNZIONANO
Ho riconfigurato ftp ed portato "use_wind_sensor" a False
"sensor_type" a None

per ora ho solo u n sensore DHT11
"dht_type" settato su DHT11 e "use_dht" messo su True ma i valori in FTP rimangono sempre a ZERO.

Massimo Artuso

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa - 1 Anno 8 Mesi fa #7909 da MassimoArtuso
Dimenticavo ho provato anche il sensore con "sudo python test.py"
e funziona.

Massimo Artuso
Ultima Modifica 1 Anno 8 Mesi fa da MassimoArtuso.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7910 da MassimoArtuso
Aggiornameti:

ftp rimane sempre a 0
ho provato a fare "Check for Update" e dopo l'aggiornamento
"sudo python test.py" non funziona.
____________________________________-
./DHT: error while loading shared libraries: libwiringPi.so.1: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File "test.py", line 33, in <module>
output = subprocess.check_output(["./DHT"]);
File "/usr/lib/python2.7/subprocess.py", line 573, in check_output
raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '' returned non-zero exit status 127
pi@swp
_____________________________________

Massimo Artuso

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7911 da MassimoArtuso
Ulteriori agiornamenti.

Siccome con upgrade non mi andava più la lettura del DHT11, alla fine ho installato il firmware 3 non ho fatto upgrade ed ho aggiornato a mano le librerie python.
Ora non so se è un caso ma il sensore viene letto e ho la pubblicazione sul sito.
Tutti i valori a 0 tranne del unico sensore vhe attualmente ho.

:)

Massimo Artuso

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7915 da seven
Ah, buon Max, quella del DHT è una vecchia magagna che ogni tanto si ripropone :cheer:

Prova ad entrare in /swpi/DHT e a dare il comando sudo make

al termine dovrebbe andare

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7916 da seven
(OVVIAMENTE: se adesso va, NON TOCCARE PIU' NIENTE ehehehehe) ;)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Anno 8 Mesi fa #7918 da MassimoArtuso
ESATTO :whistle: e già fatto copia dell'immagine funzionante.

Massimo Artuso

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.522 secondi