× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

map-pin sint- wind in APRS

Di più
3 Anni 4 Settimane fa #7174 da naliro
sint- wind in APRS è stato creato da naliro
Salve a tutti,
volevo sapere se qualcuno aveva sviluppato qualcosa per far funzionare un rasp con sintWind e "lanciere" i dati in APRS.

per chi non fosse a conoscenza del sistema APRS ecco un link it.wikipedia.org/wiki/APRS

Ciao

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 4 Settimane fa #7175 da tony
Risposta da tony al topic sint- wind in APRS
Non conoscevo la cosa ma mi sembra interessante. La si potrebbe usate per trasmettere i dati tra 2 posizioni remote.
TT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 4 Settimane fa #7179 da naliro
Risposta da naliro al topic sint- wind in APRS
più che tra due posizioni remote ... da delle posizioni remote ... infatti se vai a vedere su questo sito questo potrebbe essere il risultato

it.aprs.fi/

le icone con WX sono stazioni meteo .... ora il tutto deve essere gestito da un radioamatore :) infatti le sigle sulla mappa sono di radioamatori o stazioni da loro gestite....

La cosa si fa interessante dove non arriva GSM ....

googlando ho visto che ci sono vari progetti che utilizzano il rasp abbinato a una usb audio .... la radio non è il problema in quanto si potrebbe usare il sistema VOX della stessa....

si potrebbe iniziare da qui : www.mstewart.net/super8/aprs/RASP/index.htm


......

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 3 Settimane fa #7198 da tetox
Risposta da tetox al topic sint- wind in APRS
Salve... a tutti ..
se lo scopo e' quello di essere presenti in Aprs.fi , in swpi c'e' l'opzione
del CWOP ...una volta correttamente attivata ...siete su aprs.fi , sia con nominativo radioamatoriale oppure con sigla del CWOP.
Se non dovessi aver capito... me ne scuso !!
Stefano

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Giorni fa - 3 Anni 1 Giorno fa #7211 da linxis
Risposta da linxis al topic sint- wind in APRS
Ciao Tetox, sono un radioamatore IK3JLT Angelo...sarei interessato a mandare i dati della mia centralina meteo www.meteorsago.altervista.org in rete APRS-fi, per caso esiste un tutorial di come fare? oppure mi puoi dare qualche dritta?
Dove si trova l'opzione del CWOP?
Grazie
saluti
Ultima Modifica 3 Anni 1 Giorno fa da linxis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Giorni fa #7212 da naliro
Risposta da naliro al topic sint- wind in APRS
Ciao a tutti vedo solo ora...

a me piacerebbe sviluppare ( ma non penso di esserne in grado) un sistema che mandi i dati in aprs tramite radio....

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 1 Giorno fa #7213 da tetox
Risposta da tetox al topic sint- wind in APRS
Ciao Angelo...premettendo che tu stai utilizzando SWPI per la gestione della tua staz. meteo ..giusto ??
Se editi il file SWPI.cfg nella sezione " Weather Underground " qualche riga piu' in basso c'e' "CWOP station ID (CWOP_ID) " attivi questa opzione con " true" poi riempi con i tuoi dati radioamatoriali il resto ... e sei su CWOP.. buonfine estate
Stefano de i6wvq
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 1 Giorno fa #7214 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Quello che dice Stefano è in parte giusto.
Ovviamente devi prima registrati sul sito di CWOP.
Peccato che di dati che vengono inviati non sono giustamente formattati, di conseguenza non passi su aprs.fi.
Almeno con le stazioni che uso io.

73 de iw1pur
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 1 Giorno fa #7215 da linxis
Risposta da linxis al topic sint- wind in APRS
Bene ....Grazie per la risposta allora c'è qualcuno del forum che è riuscito a far funzionare SWPI con CWOP su aprs.fi?

73 de ik3jlt

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7216 da tetox
Risposta da tetox al topic sint- wind in APRS
Vedete che ci vuole a fare delle brutte figure !!! un attimo ...
Io NON utilizzando swpi per il CWOP , NON ero a conoscenza che pur essendoci l'opzione, l'SWPI NON formatta correttamente la stringa..eee..addio aprs.fi.
Senza impegno ...mi riprometto di ritrovare uno script.sh fatto un paio di anni fa' che processava il file meteo.txt e ne ricavava la giusta stringa per il cwop...funzionava !!
se me lo ritrovo lo spedisco in qualche modo a linxis alias ik3jlt.
Scusandomi per l'approssimazione della mia risposta ...saluti .
Stefano de i6wvq
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7217 da linxis
Risposta da linxis al topic sint- wind in APRS
Teox, nessun problema sbagliare è umano e ammetterlo non lo è da tutti.
Comunque come sta scritto sul banner "siamo volontari" e i volontari meritano rispetto.
Io rimango in attesa di questo script, se è possibile con una descrizione di come fare...non sono esperto di programmazione.
Ci possiamo anche sentire con skype visto che via radio immagino la distanza non sia possibile
Spero che questa opzione sia di interesse ad altri radioamatori
73 de ik3jlt

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7218 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Non è un'approssimazione, potrebbe essere anche un mio problema.
Sul sito americano vedi la stazione con anche i dati meteo, al momento li sto mandando con una versione di test e quindi non sono del tutto giusti.
Puoi cercare la mia stazione da qui:

www.wulfden.org/APRSQuery.shtml

il nome della stazione è :iw1pur

quando vai su aprs.fi non la trova, qui puoi vedere i pacchetti:

aprs.fi/?c=raw&call=iw1pur*&limit=50&view=normal

al callsign devi aggiungere un *

A sentirci on air

73 de Iw1pur
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7221 da tetox
Risposta da tetox al topic sint- wind in APRS
Buondi'...
Allora ..nel cercare lo script promesso a Giovanni , mi sono ricordato che tre anni fa' io installai per altri due amici l'swpi e relative staz. meteo...andando a ricontrollare ora che fine avessero fatto queste due staz. iw6ciq-3 e ik6fgx-3
, ho notato che sono presenti su aprs.fi ..una considerazione da fare e' che entrambe le staz. menzionate utilizzano una versione vecchia di swpi.
Roberto...se ti va' puoi "confrontare " la stringa di iw6ciq-3 con la tua stringa ...e cercare di capire perche' la tua staz.non viene visualizzata su aprs.fi.
Giovanni ..entro la prox settimana ti contattero' su skype (momentaneamente sono un po' impicciato) scusami.
Saluti a tutti
Stefano de i6wvq
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa - 2 Anni 11 Mesi fa #7222 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Ciao Stefano,
grazie per le info, mi hai fatto venire voglia di riprovarci.
Ho la possibilità di inviare i dati da 3 raspberry con swpi diversi. Uno è quello che sta funzionando dal marzo 2013 ed è una vecchia versione gli altri sono nuovi ma comunque sempre versioni diverse.
Ho scoperto dove è il problema, se guardi questa stringa :
  2016-08-27 21:22:27 CEST: iw1pur>APRS,TCPXX*,qAX,CWOP-3:/271922z4426.89N/009 5.31E_045/001g002t070r000p000P000h00b10199.Sint Wind PI - 01.23.84 [Invalid position ambiguity]
Vedrai che al punto relativo alla longitudine 009 5.31E c'è uno spazio invece dovrebbe esserci uno 0 (00905.31E)
Se modifico il mio file di configurazione mettendo un qualsiasi valore diverso da 0 funziona ma ovviamente la mia stazione risulta essere dove non deve.
Non credo sia un problema di SWPI, anche perchè su CWOP la posizione è giusta
Probabilmente se ik3jlt lo attiva a lui potrebbe funzionare

Ci giocherò un po'

73 de iw1pur
Ultima Modifica 2 Anni 11 Mesi fa da Roberto Vaccaro.
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa - 2 Anni 11 Mesi fa #7223 da linxis
Risposta da linxis al topic sint- wind in APRS
Buonasera, e grazie per le info, ho provato ad iscrivermi , fatto, ho gia il codice l'ho inserito nella casella di configurazione di swpi ho cambiato lo stato da false a true.
Ho visto che nella casella della password c'è un -1 lasciarlo così?
Domani vedo tutto il resto
Buona domenica
Cordialità de ik3jlt Angelo

PS: ho avuto troppo entusiasmo!!!! purtroppo mi rendo conto che altri dati trasmessi sono errati Per favore quando avete tempo passatemi una dritta.
Grazie
Ultima Modifica 2 Anni 11 Mesi fa da linxis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7224 da tetox
Risposta da tetox al topic sint- wind in APRS
Ciao Angelo...
per quel che mi ricordo ..nella pass. io ci misi il numero di convalida per ID radioamatoriale , in pratica e' quel "numeretto" che si utilizza anche per UI-VIEW
per ottenere questo "numeretto" ci sono anche dei siti con dei form che ti permettono di ricavare il famigerato " Validation Number"....momentaneamente non mi ritrovo nessun link.
Spero di non aver ulteriormente contribuito ad ingarbugliare la situazione !!!.
Stefano
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7225 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Stazione on line su aprs.fi !!

Non avevo voglia di sbattermi troppo, ho modificato il file TTlib.py.

Questo per quanto riguarda le coordinate:
    send += CWOP_ID
    send += ">APRS,TCPXX*:"
    
    d = (datetime.datetime.utcnow())
    aprs_time = d.strftime("%d%H%M")
    send += "/" + aprs_time + "z"

    location = "4426.89N/00905.31E"
 
#    lat = abs(location_latitude)
#    d = int(lat)
#    p = (lat-d)*60
#    location = "%2d%5.2f" % (d,p)
#    if (location_latitude) > 0:
#        location += "N"
#    else:
#        location += "S"
    
#    location += "/"
    
        
#    lon = abs(location_longitude)
#    d = int(lon)
#    p = (lon-d)*60
#    location += "%03d%5.2f" % (d,p)
#    if (location_longitude) > 0:
#        location += "E"
#    else:
#        location += "W"
    
    send += location

ho commentato le varie righe e ho forzato la giusta stringa alla variabile location, ovviamente con le mie coordinate.

C'era anche un errore relativo all'umidità, questa la modifica:
    # humidity
    if (globalvars.meteo_data.hum_out != None):
        rh = float(globalvars.meteo_data.hum_out / 100 )
        if rh >= 0.995:
            humid_str = "h00"
        else:
#            humid_str = "h" + "%02.0f" % (rh * 100.0)
            humid_str = "h" + "%02.0f" % (globalvars.meteo_data.hum_out)
        send += humid_str

Per quanto riguarda login e password io uso il mio call e la password che uso anche su aprs.fi
:) :)
Buon divertimento

73 de Iw1pur Roberto
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa - 2 Anni 11 Mesi fa #7226 da tetox
Risposta da tetox al topic sint- wind in APRS
Sempre grande Roberto !!!
Speriamo di aver aiutato Giovanni ..o meglio.. che tu abbia !! :P
Stefano de i6wvq
Ultima Modifica 2 Anni 11 Mesi fa da tetox.
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa - 2 Anni 11 Mesi fa #7227 da linxis
Risposta da linxis al topic sint- wind in APRS
Buonasera , vi rispondo adesso perchè dopo 3 settimane di ferie per fortuna si torna a lavorare ...(nel senso che c'è lavoro).
Comunque ho verificato i dati pubblicati su aprs.fi sembrano tutti corretti anche l'umidità sostituito in blocco il pezzo di codice mandato da Roberto che ringrazio ancora.
Vedremo come saranno i grafici nella giornata di domani per un ulteriore riscontro.
Ho sostituito anche il codice CWOP datomi con il mio nominativo che vedo sulla mappa aprs.fi

Grazie
Saluti 73 Angelo
Ultima Modifica 2 Anni 11 Mesi fa da linxis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7248 da linxis
Risposta da linxis al topic sint- wind in APRS
Buonasera...dopo molto tempo dalle modifiche del TTlib.py è piovuto a casa mia e purtroppo ho notato che il sistema in aprs.fi non fa vedere i mm della pioggia caduta nelle 3 visualizzazioni """Pioggia 0.0 mm/1h 0.0 mm/24h 0.0 mm/dalla mezzanotte"".
Era l' ultimo parametro da verificare.
C'è qualche altro errore nello script....per favore qualcuno mi può aiutare?
Saluti

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7249 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Solito discorso, hai ragione.
    # rain last hour -- each count is 0.0204" 
    if (globalvars.meteo_data.rain_rate_1h != None):
        rain_hr_hundredth_inches = float(globalvars.meteo_data.rain_rate_1h * 3.9370078)
        rain_hr_str = "r" + "%03d" % rain_hr_hundredth_inches
#        rain_hr_str = "r" + int(globalvars.meteo_data.rain_rate_1h)
        send += rain_hr_str

    # rain last 24 hours -- each count is 0.0204"
    # so the math accidentally scales perfect -- report in hundreths of inches
    if (globalvars.meteo_data.rain_rate_24h != None) :
        rain_24_hrs_hundredth_inches = float(globalvars.meteo_data.rain_rate_24h * 3.9370078)
        rain_24_hrs_str = "p" + "%03d" % rain_24_hrs_hundredth_inches
#        rain_24_hrs_str = "p" + int(globalvars.meteo_data.rain_rate_24h)
        send += rain_24_hrs_str


Qui vedi le modifiche, puoi sostituire la tua parte di codice con questo
Fammi sapere se ti funziona
A sentirci on air

73 de Iw1pur Roberto
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa - 2 Anni 11 Mesi fa #7252 da linxis
Risposta da linxis al topic sint- wind in APRS
Buonasera Roberto, ho fatto come mi hai detto, sostituito lo script e sembra funzionare.
Almeno i dati li leggo in aprs.fi
Questo il link dove puoi leggere i dati
aprs.fi/#!call=a%2FIK3JLT-13&timerange=21600&tail=21600
Questo il link del mio sito meteo.
www.meteorsago.altervista.org/swpi/index.php
Ci sono dei momenti che i dati non coincidono non tutti solo quelli della pioggia.
Domanda: i dati della mia stazione meteo SWPI li invia contemporaneamente al mio sito e ad aprs.fi o cosa altro succede?
Cordialità e grazie per avermi risposto subito
Angelo
Ultima Modifica 2 Anni 11 Mesi fa da linxis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa #7404 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Li invia contemporaneamente al tuo sito e al sito Americano che poi lo gira su aprs.fi. L'incoerenza che noti è dovuta alla conversione e approssimazione dei dati
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa #7407 da djpoldino
Risposta da djpoldino al topic sint- wind in APRS
c'è possibilità di inviare solo alcuni dati in APRS?
perchè purtroppo per ora non ho l'anemometro e non so se lo metterò.
Ma mi interessava inviare il resto dei dati su aprs.fi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa - 2 Anni 9 Mesi fa #7408 da linxis
Risposta da linxis al topic sint- wind in APRS
OK, come vedi Roberto, se confronti tra i dati di aprs.fi e quelli del mio sito sono differenti solo i dati pioggia e non so se il problema è sui dati mandati da SWPI o il problema o dipende dalla post elaborazione dei dati .
Se qualche persona del forum sa come risolvere il problema sono pronto a provare.
Ultima Modifica 2 Anni 9 Mesi fa da linxis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa #7409 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
X djpoldino
Dovrebbe funzionare ugualmente, se swpi non manda i dati del vento in aprs vedrai un valore a 0. Sei un radioamatore?

X linxis:
Non penso sia un problema di swpi.
Io penso sia dovuto a CWOP.
Se hai fatto caso, più la pioggia aumenta più il valore diventa vicino a quello di SWPI

73 de Iw1pur
Ringraziano per il messaggio: linxis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa #7410 da djpoldino
Risposta da djpoldino al topic sint- wind in APRS
Si.(Ciao da IU5FRT!)
Peró gia ora non ho niente attaccatp (perchè sto aspettando i sensori) e mi da comunque una misura molto casuale del vento sul mio sito... quindi non vorrei che me la mandasse anche via aprs

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa - 2 Anni 9 Mesi fa #7411 da Roberto Vaccaro
Risposta da Roberto Vaccaro al topic sint- wind in APRS
Devi disattivare i sensori che non ti servono sul file swpi.cfg

Questo è un esempio:
.......
[Sensors]
sensor_type = WH1080-RFM01
use_wind_sensor = True
number_of_measure_for_wind_dir_average = 10
windspeed_offset = 0.0
......
al posto di True devi mettere False
Puoi farlo anche da interfaccia web

P.S. Che ci fai con quel paiolo ... la polenta o lo usi per trasmettere in micronde?

A sentirci on air
Ultima Modifica 2 Anni 9 Mesi fa da Roberto Vaccaro.
Ringraziano per il messaggio: djpoldino

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 9 Mesi fa #7413 da djpoldino
Risposta da djpoldino al topic sint- wind in APRS
Grazie!
Speriamo di sentirci presto!
73 DE IU5FRT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 8 Mesi fa #7463 da IZ3ZOD
Risposta da IZ3ZOD al topic sint- wind in APRS
Ciao a tutti, sono nuovissimo del forum, però sto usando SWPI da circa due anni senza il minimo problema.
oggi ho provato a trasferire i dati della mia stazione meteo (PCE FWS20) in aprs... allora.. primo step ho richiesto un nuovo id di stazione a questo link.. www.findu.com/citizenweather/cw_form.html
succesivamente ho inserito l'id stazione che mi è arrivato via mail nella sezione "CWOP_ID" lasciando il campo password vuoto, successivamente salvato e riavviato il raspberry.. dopo due minuti (tempo di avvio del sistema) ho visto subito i dati meteo in aprs.fi

poi ho provato a cambiare il nominativo di stazione precedentemente assegnato (FW0128) con il mio call e suffisso WX, salvato e riavviato, nessun problema..



Allegati:

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.671 secondi