× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Versione 3 continui riavvii

Di più
2 Anni 11 Mesi fa #7070 da uolly78
ciao,
mi sono imbattuto in un altro problema. La mia stazione (che per fortuna è ancora in test a casa) ha iniziato a riavviarsi in continuazione.
Ora, posso scegliere due strade:

riformattare l'sd card, mettere la versione ex novo e non capirci nulla oppure tentare di risolvere la cosa elegantemente (anche per evitare che succeda quando la stazione sarà sul campo :side: )

ecco il log dei riavvii (fa così in continuazione)
************************************************************************
*                      Sint Wind PI 01.23.89                           *
*                                                                      *
*          2012-2016 by Tonino Tarsi  <tony.tarsi@gmail.com>           *
*                                                                      *
*     System will start in 10 seconds - Press Ctrl-C to cancel         *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[14/06/2016-19:21:51] loading plugins
[14/06/2016-19:21:51] Starting sensor reading - Sensor type is : PCE-SENSOR
[14/06/2016-19:21:51] Starting plugin : <module 'wunderground' from './plugins/wunderground.pyc'>
 [14/06/2016-19:21:51] Initializing libMCP
clk mmap error -1282404352
[14/06/2016-19:21:51] Error initializing mcp3002 library.Try to continue
[14/06/2016-19:21:51] Starting plugin : <module 'IPCamLogger' from './plugins/IPCamLogger.pyc'>
[14/06/2016-19:21:51] Config Server running on port 80
[14/06/2016-19:21:51] 3G Dongle not detected
[14/06/2016-19:21:51] Checking internet connetion ...
[14/06/2016-19:21:51] Internet ok
[14/06/2016-19:21:51] Checking internet connetion ...
[14/06/2016-19:21:52] Internet ok
Tue Jun 14 19:21:53 CEST 2016
[14/06/2016-19:21:53] System time adjusted from NPT server : time.windows.com
[14/06/2016-19:21:53] Connected with IP :94.32.217.244

Tue Jun 14 19:21:54 CEST 2016
[14/06/2016-19:21:54] System time adjusted from NPT server : time.windows.com
[14/06/2016-19:21:54] DNS Exit -:  HTTP/1.1 200 OK
4=IP not changed. To save our system resources, please don't post updates unless the IP got changed.
[14/06/2016-19:21:54] Starting General WatchDog
[14/06/2016-19:22:40] Starting SINT WIND PI  ...
************************************************************************
*                      Sint Wind PI 01.23.89                           *
*                                                                      *
*          2012-2016 by Tonino Tarsi  <tony.tarsi@gmail.com>           *
*                                                                      *
*     System will start in 10 seconds - Press Ctrl-C to cancel         *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[14/06/2016-19:22:53] loading plugins
[14/06/2016-19:22:53] Starting sensor reading - Sensor type is : PCE-SENSOR
[14/06/2016-19:22:53] Initializing libMCP
clk mmap error -1282404352
[14/06/2016-19:22:53] Starting plugin : <module 'wunderground' from './plugins/wunderground.pyc'>
[14/06/2016-19:22:53] Error initializing mcp3002 library.Try to continue
[14/06/2016-19:22:53] Starting plugin : <module 'IPCamLogger' from './plugins/IPCamLogger.pyc'>
[14/06/2016-19:22:53] Config Server running on port 80
[14/06/2016-19:22:53] 3G Dongle not detected
[14/06/2016-19:22:53] Checking internet connetion ...
[14/06/2016-19:22:53] Internet ok
[14/06/2016-19:22:53] Checking internet connetion ...
Tue Jun 14 19:22:53 CEST 2016
[14/06/2016-19:22:53] Internet ok
[14/06/2016-19:22:53] System time adjusted from NPT server : time.windows.com
[14/06/2016-19:22:53] Connected with IP :94.32.217.244

Tue Jun 14 19:22:54 CEST 2016
[14/06/2016-19:22:54] System time adjusted from NPT server : time.windows.com
[14/06/2016-19:22:54] DNS Exit -:  HTTP/1.1 200 OK
4=IP not changed. To save our system resources, please don't post updates unless the IP got changed.
[14/06/2016-19:22:54] Starting General WatchDog
e poi si riavvia di nuovo
(la stazione è ora collegata in lan)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7072 da SkizZO
Risposta da SkizZO al topic Versione 3 continui riavvii
hai per caso il watchdog hardware abilitato?
... o lo disabiliti, o provi a disabilitare l'aggiornamento dell'ora in swpi....

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7073 da uolly78
Risposta da uolly78 al topic Versione 3 continui riavvii
come si disattiva il cane da guardia?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7074 da SkizZO
Risposta da SkizZO al topic Versione 3 continui riavvii
sudo /etc/init.d/watchdog start
sudo /etc/init.d/watchdog stop
sudo /etc/init.d/watchdog status

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7075 da uolly78
Risposta da uolly78 al topic Versione 3 continui riavvii
il comando non esiste :-(

pi@swpi(rw):/$ sudo /etc/init.d/watchdog stop
sudo: /etc/init.d/watchdog: comando non trovato

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7076 da SkizZO
Risposta da SkizZO al topic Versione 3 continui riavvii
niente watchdog..
comincia a disabilitare qualcosa

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7077 da seven
Risposta da seven al topic Versione 3 continui riavvii
Guarda:
[14/06/2016-19:21:51] Initializing libMCP
clk mmap error -1282404352
[14/06/2016-19:21:51] Error initializing mcp3002 library.Try to continue


E' di nuovo il problema della libreria mcp3002.
Inoltre noto questo:

[14/06/2016-19:21:51] 3G Dongle not detected


Se non hai collegato la chiavetta 3G va bene, altrimenti non ci siamo. E' come se le modifiche dei giorni precedenti fossero state magicamente annullate. Non è che hai aggiornato swpi?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7078 da uolly78
Risposta da uolly78 al topic Versione 3 continui riavvii
ciao seven
temo di aver premuto per sbaglio il pulsante check for update nella web config.

Quel pulsante fa danni inimmaginabili: ha modificato il file relativo al sensore e forse qualche altra cosa. Ora il log non va neanche più avanti, la stazione non aggiorna più i dati meteo e non avendo il log non so dove si blocca.
L'unica cosa che posso fare è rimettere su la vecchia immagine, rimodificare tutto e sperare di non premere più quel pulsante (che a questo punto tenterò di togliere)


grazie :-)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7079 da seven
Risposta da seven al topic Versione 3 continui riavvii
Buon uolly io ripartirei da qui:

www.vololiberomontecucco.it/vlmc/index.p...-23-82?start=30#6943


Questo dovrebbe risistemare la questione mcp3002 e forse appianare automagicamente le altre magagne (ri)apparse.


Concordo sul fatto che dovremmo implementare in swpi una richiesta di conferma prima di effettuare l'aggiornamento, a volte cliccare quel pulsante per errore è un attimo e si vanno a cancellare possibili preziose customizzazioni...

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7085 da uolly78
Risposta da uolly78 al topic Versione 3 continui riavvii
effettivamente questa modifica l'avevo già fatta.
comunque oggi magicamente è ripartito e funziona perfettamente.

Concordo sul fatto che va messa una conferma, quel tasto è troppo accessibile :-)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa - 2 Anni 11 Mesi fa #7086 da uolly78
Risposta da uolly78 al topic Versione 3 continui riavvii
ritiro tutto
ha funzionato un paio d'ore e poi si è completamente bloccata, non scrive log non fa nessun tipo di aggiornamento sul server e l'swpi status mi restituisce che sta girando.

non è che si riavvia... proprio non parte più.

terribile.
stavolta riformatto
Ultima Modifica 2 Anni 11 Mesi fa da uolly78.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7105 da seven
Risposta da seven al topic Versione 3 continui riavvii
Vediamo se è una questione di riformattare, spero di si altrimenti trovare la magagna senza log è da svenarsi.....

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.539 secondi