× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file il logger mi restituisce sempre WRONG PASSWORD

Di più
3 Anni 6 Mesi fa - 3 Anni 6 Mesi fa #6494 da Atin
Ciao a tutti sono Paolo dalla provincia di Napoli. sto cercando di far funzionare una stazione meteo Sint Wind ma non riesco a spedire i dati al database.
Ho seguito le altre discussioni in merito all'oggetto già presenti sul forum ed ho ricontrollato i file più volte ma non riesco a venirne fuori riuscite a darmi una mano?

ho già ricreato il db e creato i campo con la query segnalata nel forum
allego i file di configurazione magari ho sbagliato qualcosa ma non riesco a capire.

grazie e cieli blu
Paolo
Allegati:
Ultima Modifica 3 Anni 6 Mesi fa da Atin.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6495 da asy961
Ciao Atin, benvenuto,
non conosco il provider netson
però proverei a correggere cosi

[DataLogging]
logdata = True
serverfile = www.razzano.netsons.org/swpi_logger.php

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6497 da tony
Aggiungerei solo che "wrong password" indica che quanto inserito in config.php e swpi.cfg con coincide.
TT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6498 da Atin
Ho provato ad aggiungere il www suggerito da asy961 ed ho ricontrollato le password contenute in config.php ed swpi.cfg (per scrupolo l'ho cambiate) ma nulla, segnala sempre wrong password.

comprendo che il messaggio di errore lo generano queste righe del logger:

$swpipwd1 = $_POST;
if ($swpipwd1 != $swpipwd)
{
die('Wrong password ');
}

ma non riesco a cavare il ragno dal buco. sarà una cavolata ma non la vedo!

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6499 da asy961
potrebbe anche essere un problema nella creazione della tabella.....

prova questo

per creare la tabella copia e incolla questo codice


CREATE TABLE IF NOT EXISTS `METEO` (
`TIMESTAMP_LOCAL` datetime NOT NULL,
`TIMESTAMP_IDX` datetime default NULL,
`WINDIR_CODE` text,
`WIND_DIR` smallint(6) default NULL,
`WIND_AVE` double default NULL,
`WIND_GUST` double default NULL,
`TEMP` double default NULL,
`PRESSURE` double default NULL,
`HUM` double default NULL,
`RAIN` double default NULL,
`RAIN_RATE` double default NULL,
`TEMPINT` double default NULL,
`HUMINT` double default NULL,
`WIND_CHILL` double default NULL,
`TEMP_APPARENT` double default NULL,
`DEW_POINT` double default NULL,
`UV_INDEX` double default NULL,
`SOLAR_RAD` double default NULL,
`WIND_DAY_MIN` double default NULL,
`WIND_DAY_MAX` double default NULL,
`WIND_DAY_GUST_MIN` double default NULL,
`WIND_DAY_GUST_MAX` double default NULL,
`TEMP_OUT_DAY_MIN` double default NULL,
`TEMP_OUT_DAY_MAX` double default NULL,
`TEMP_IN_DAY_MIN` double default NULL,
`TEMP_IN_DAY_MAX` double default NULL,
`HUM_OUT_DAY_MIN` double default NULL,
`HUM_OUT_DAY_MAX` double default NULL,
`HUM_IN_DAY_MIN` double default NULL,
`HUM_IN_DAY_MAX` double default NULL,
`PRESSURE_DAY_MIN` double default NULL,
`PRESSURE_DAY_MAX` double default NULL,
`WIND_DIR_AVE` double default NULL
) ENGINE=MyISAM DEFAULT CHARSET=latin1;

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6500 da Atin
già fatto.(ho seguito una discussione simile)
I campi risultano creati correttamente del database ma il log del sintwind segnala che "Error connecting to server : razzano.netsons.org/swpi_logger.php "

swpi_logger.php mi continua a dire Wrong Password

per sicurezza ho fatto l'accesso ad DB con altra applicazione e lo leggo regolarmente.

ho provato a cambiare anche la password del sint wind e quella di config.php ma nulla.

potrebbe essere qualche problema di permessi sui file?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6501 da asy961
potyrebbe essere...

nelle caratteristiche degli spazi web gratuiti su Netsons è indicato che l'Accesso Remoto al DB MySql non è attivo....

forse sarà quello??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa - 3 Anni 6 Mesi fa #6503 da tony
In effetti non credo sia un problema del server o DB. Wrong password è un messaggio del logger.
Non so cosa pensare. Il logger è la prima modalità di invio dati che ho sviluppato e non lo uso più da molto. Preferisco l'upload del file meteo.txt e per i grafici weaterunderground.
TT
Ultima Modifica 3 Anni 6 Mesi fa da tony.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6504 da asy961
prova a leggere questo

www.netsons.com/knowledgebase.php?action=displayarticle&id=19

magari l'hai già controllato, però....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa #6505 da Atin
si già fatto :-(
nei prossimi giorni vedo di provare con qualche altro host

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Mesi 1 Settimana fa #8485 da giulio
Scusate, ma volevo sapere se il problema è stato risolto. Mi si è presentato anche a me in seguito al cambio di server da parte del mio provider.
Ho provato a cambiare la pwd del sintwindinPI e ovviamente anche sul config.php senza sortire effetto. Ho provato a modificare i permessi dei file swpi_logger e config via FTP mettendoli 777, ma nulla. L'unica cosa certa è che col cambio di server è cambiato anche l'ip e le versioni di mysql e di php.
Qualche idea ?
Grazie e una saluto.

se ascolto dimentico,
se vedo ricordo,
se faccio comprendo

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Mesi 2 Giorni fa #8486 da roberto2011
Prova a modificare il file PHP aggiungendo.
error_reporting(E_ALL);
ini_set('display_errors', 1);
Poi richiama la pagina direttamente dal browser.
Che versione PHP usi adesso?

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Mesi 2 Giorni fa #8487 da giulio
Intanto grazie Roberto per la sollecita risposta.
Questo è quanto mi risponde il logger modificato:

Notice: Undefined index: pwd in /var/www/html/domini/it/gvlnifollonica/gvlnifollonica.it/meteo/swpi_logger.php on line 10
Wrong password

Sembra che il sint-wind PI non invii la password ?!? Possibile ?!?

La Versione del PHP è 5.4.16

Grazie e attendo tua.

se ascolto dimentico,
se vedo ricordo,
se faccio comprendo

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Mesi 2 Giorni fa #8488 da roberto2011
Scusami se ti dico cose banali ma nel config.php hai inserito tutte queste variabili?
$server = "Di solito locslhost oppure ip server";
$user = "username del database";
$pwd = "password del database";
$db = "ylnome del database";
$swpipwd = "stessa password del file swpi.conf";

Puoi gentilmente postare le prime 15 righe del file lpgger.php ?nel mio nelle prime righe non c'è nessuna variabili con il nome $pwd .
Ciao

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Mesi 1 Giorno fa #8489 da giulio
Ecco le prime 20 righe del swpi_logger.php :
<?php



require("config.php");

error_reporting(E_ALL);
ini_set('display_errors', 1);

$swpipwd1 = $_POST;

if ($swpipwd1 != $swpipwd)
{
die('Wrong password ');

}

$last_measure_time = $_POST;
$idx = $_POST;
$wind_dir_code = $_POST;


e di seguito il config.php :

<?php

$server = "localhost";
$user = "gvlni2013";
$pwd = "xxxxxxxx";
$db = "gruppovelico";
$swpipwd = "xxxxxxx";
?>


Ovviamente $swpipwd è la stessa del Sint-Wind PI .

se ascolto dimentico,
se vedo ricordo,
se faccio comprendo

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Mese 4 Settimane fa #8490 da roberto2011
Forse il copia sul forum ha elimianto un po di cose. Usa la funzione codice.
<?php
error_reporting(E_ALL);
ini_set('display_errors', 1);

require("config.php");

$swpipwd1 = $_POST['pwd'];

if ($swpipwd1 != $swpipwd)
{
  die('Wrong password ');
}

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Mese 4 Settimane fa #8492 da giulio
Si è il forum kunema che taglia,

Ti allego gli screenshot:

se ascolto dimentico,
se vedo ricordo,
se faccio comprendo
Allegati:

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
1 Mese 4 Settimane fa #8493 da asy961
Ciao,
noi abbiamo l'indirizzo IP del server MySql al posto di 'localhost' nel file config.php

può essere di aiuto?

Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.546 secondi