× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Pressione e moduli rmf01 e Btp

Di più
4 Anni 4 Mesi fa #4691 da Scarzella
salve a te,
Sono nuovo del forum. Ho acquistato la pce dopo aver avuto esperienza negativa per tanti anni con la stazione meteo della deagostini. Quando ho trovato per caso il vostro sito si sono aperti nuovi orizzonti.
Detto questo i miei problemi attuali sono: la pce è stata connessa con successo al rasberry pi b e attualmente manda dati corretti a meteo undergrond, tutti tranne quello della pressione, che, nonostante sia stata settata correttamente, almeno credo, la relativa con l''assoluta ancora risulta sballata sul sito web. Ora la relativa è 1024 hpa, su wu invece 1033, non ne capisco il motivo.
L'altro problema è il fallimento della connessione tramite il modulo rmf01. Tra tutti gli errori mi ricordo un pipe broken. Non essendo esperto di linguaggio Linux onestamente non so proprio come fare a collegare la pce tramite rmf01. Ho già letto molte delle vostre guide.
Grazie Max

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 4 Mesi fa #4692 da Ciaschini
Ciao, nel frattempo che ti risponda qualcuno più esperto ti posso consigliare di ricontrollare le impostazioni di altitudine sulla pagina di configurazione, per il modulo rfm prova a ricontrollare i collegamenti, un'altra cosa da monitorare è l'alimentatore, se non sbaglio un'altra utente ha avuto questo problema perché alimentata con 3v dalla GPIO.
Ringraziano per il messaggio: Scarzella

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 4 Mesi fa #4693 da asy961
Risposta da asy961 al topic Pressione e moduli rmf01 e Btp
Ciao Scarzella,
se hai acquistato la PCE completa di consolle il sensore rmf01 a cosa ti serve?? tale sensore serve solo nel caso che tu abbia solo il gruppo sensori PCE senza la consolle, collegando il sensore alla GPIO del raspberry e settandolo correttamente permette di leggere il gruppo sensori PCE direttamente dal raspberry senza la consolle.

www.vololiberomontecucco.it/vlmc/index.p...&catid=13&Itemid=169


Per il dato della pressione ricontrolla, come ha detto Ciaschini, le configurazioni.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 4 Mesi fa - 4 Anni 4 Mesi fa #4694 da ragugo
Risposta da ragugo al topic Pressione e moduli rmf01 e Btp
@Scarzella
Ciao anche io dei problemi con rmf01, funziona agiorni alterni, prova a fare come spiegato qui www.vololiberomontecucco.it/vlmc/index.p...&catid=13&Itemid=169

lancia sudo ./wh1080rf
troverai il simbolo < sulla riga LNA_0,RSSI_97 idx4
se i valori sono a zero dopo pochi secondi dovresti vedere il dati della lettura, se vedi solo puntini blocca con Ctrl+C e rilancia sudo ./wh1080rf aggiungendo i parametri -f (frequenza) -b (banda) -r (rssi) -l (lna)
metti i parametri delle righe che contengono tutti zeri
esempio nel mio caso avevo tutti zeri sulla riga LNA_6,RSSI_85 quindi sudo ./wh1080_rf -f 868 -r 85 -l 6
vedrai che il simbolo < è sulla riga LNA_6,RSSI_85 aspetta per vedere se la lettura viene effettuata o se vengono visualizzati ancora i puntini.
Io ho provato tutte le impostazioni ed ho scelto quella che mi rispondeva con la lettura nel minor tempo.Se hai problemi prova ad agire anche sulla banda con il parametro -b guarda i valori possibili sulla pagina di configurazione di swpi.
Ogni tanto fa i cavoli suoi e smette di leggere, ogni tanto devo reboottare il Raspy però bene o male funziona.
Ultima Modifica 4 Anni 4 Mesi fa da ragugo.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 4 Mesi fa #4695 da Ciaschini
@asy961
anche io possiedo la stazione completa di console, ma utilizzo ugualmente l'RFM01, perchè la console almeno è libera dentro casa, inoltre l'usb dopo un po mi dava problemi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 4 Mesi fa #4697 da Scarzella
Grazie. Proverò a settare con i tuoi consigli. Per quanto riguarda il fatto che devi riavviare il rasp ho letto di una sequenza che ti permette il riavvio automatico. Devo cercare nella cronologia e poi te la mando.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 4 Mesi fa #4699 da tony
Risposta da tony al topic Pressione e moduli rmf01 e Btp
Purtroppo l'RFM01 è un sensore molto difficile da mettere a punto.
Ci vuole pazienza e delle buone batterie nel trasmettitore in modo che il segnale sia il più possibile costante.
TT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.461 secondi