× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Probabile problema scheda SD

More
2 weeks 4 days ago #8496 by Fulminao
Salve a tutti.
Purtroppo, dopo circa un anno dall'installazione del Sint PI al Poggio San Vicino, il Sint ha cessato di funzionare.
Tutto l'hardware sembra funzionare, il problema, a quanto pare, sembra sia la scheda SD che in qualche modo si sia corrotta.
Infatti, ho scoperto che il programma "swpi.py" non partiva dando errore di "Indentazione" per la linea 136 su file swpi.py.
Andando a leggere il file con "less" subito la risposta era un altro errore "Errore di segmentazione"
Riuscendo poi a leggere il file swpi.py con "nano" ho visto che alla suddetta riga 136 il codice era pressochè illeggibile con dei caratteri sparsi e strani. Ne ho dedotto che la SD si sia corrotta non dappertutto ma che abbia colpito alcuni segmenti di memoria, dove tra l'altro risiede il programma "less" e il file "swpi.py"
Ora la mia domanda è questa: La scheda SD (Kingston da 16GB formattata a 4GB) si è corrotta a causa del calore di Agosto oppure a causa degli arresti del raspberry eseguiti da un timer, togliendo semplicemente l'alimentazione non eseguendo quindi una procedura di spegnimento tradizionale?
Avete esperienze in merito?

Allego file delle schermate e del tipo di SD

Grazie in anticipo.
Attachments:

Please Log in to join the conversation.

More
2 weeks 2 days ago #8497 by tony
Replied by tony on topic Probabile problema scheda SD
si .. sembra un problema sulla SD. Strano . Io oramai vado con la stessa SD oramai da 4 anni ma ... le SD non sono eterne.

Please Log in to join the conversation.

More
2 weeks 2 days ago #8499 by seven
Replied by seven on topic Probabile problema scheda SD
Per curiosità, buon Tony, com'è equipaggiata la stazione del "papà" di SWPI? Sempre se si può chiedere, naturalmente :)
Intendo sia lato stazione meteo che lato sensori/accessori Raspberry.

Nik

Please Log in to join the conversation.

More
2 weeks 2 days ago #8500 by tony
Replied by tony on topic Probabile problema scheda SD
Ne ho ora operative 2 (+ una SintWindTT .. progetto non opensource per ora per mancanza di tempo)

- RPI B+ , sensori misto : PCE per la direzione e Thies per l'intensita sempre ad impulsi. BMP280 . Chiavetta telefonica + collegamento ethernet .
- RPI Zero. Sensori PCE, BMP280 , Chiavetta telefonica + LoRA per la connessione internet.

T.

Please Log in to join the conversation.

More
2 weeks 2 days ago #8501 by Fulminao
Forse essendo già usata si portava dietro dei problemi, mah. Comunque ora ne ho comprata un'altra però di grado Industrial (-40 to +85°C in operatività), sperando sia più robusta.

Please Log in to join the conversation.

Time to create page: 2.108 seconds