× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Alcune domande sulla gestione delle Webcam...

Di più
10 Anni 8 Mesi fa #1927 da contangelo
si,mi sarebbe utile sapere in che modo va posizionato il cursore della cam. Dopo la brutta esperienza con camera pi vorrei testare la canon

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 8 Mesi fa #1928 da tony
Che brutta esperienza con ma camera PI ?
Con le canon non puoi proprio far danni. Mettila in automatico.

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 7 Mesi fa - 10 Anni 7 Mesi fa #2002 da alegrechi
Ci deve essere qualche problema ancora con l'ordinamento dei files, non mi prende più come ultima immagine quelle di oggi (2 ottobre). L'ultima mi rimane quella del 01.10.2013 23:58

Il nome delle foto generate e inviate è tipo raspi_02102013-005859.jpg

Qualche idea Roberto?

Edit:
Stamani era ripreso a funzionare. Come non detto. Certo è strano perché per più di 1 h ieri sera non aggiornava l'immagine ultima, nonostante le inviasse correttamente.
Vabbè :)
Ultima Modifica 10 Anni 7 Mesi fa da alegrechi.

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 7 Mesi fa #2004 da roberto2011
<?php
echo date("Y-m-d H:i:s"); 
?>

forse qualche problema con il timezone prova questo script.

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 7 Mesi fa #2005 da alegrechi
Mi sa di si, il server web è 1h indietro

meteostrada.grechi.it/timezone.php

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 7 Mesi fa #2006 da roberto2011
allora inserisci all'inizio dello script
date_default_timezone_set("Europe/Rome");

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: alegrechi

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 7 Mesi fa #2034 da kead
Stesso problema anche a me.
Ogni tanto l'immagine ultima.jpg si blocca al giorno prima ore 23.55 e riparte anche dopo un giorno.
Funziona questa stringa? Dove dovrei inserirla? In che file?
Grazie

Sint Wind Pi su RaspBerry Ver.B + Stazione PCE-FW20 + RFM01 + BMP085
Webcams: Canon A520 + Raspberry Cam

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 7 Mesi fa #2035 da roberto2011
al'inizio di raspicam.php

fammi sapere se funziona!

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi a partecipare alla conversazione.

Di più
10 Anni 4 Mesi fa #3269 da Ciaschini
scusate l'up, ho creato il file camera1.php
salva l'immagine, soltanto che l'immagine è vuota

la patch completa delle immagini è www.sancostanzometeo.altervista.org/swpi/webcam/camera1_xxx.jpg

il file è nella cartella "swpi"

il file camera1.php è questo
<?php
$data = date("dmY");
#path dove si trovano le immagini 
$files = glob("/webcam/camera1_".$data."*.jpg");
#indirizzo web dove si trovano le immagini
$webpath ="www.sancostanzometeo.altervista.org/swpi/webcam/";
rsort ($files);

if (sizeof($files) > 0 ) {
	$name= "".$files[0]."";
}
else {
	$name = "swpi_logo.jpg";
}


$file_a = explode('/',$name);
if (trim(end($file_a)) == '')
    $filename = $file_a[count($file_a)-2];
else
    $filename = end($file_a);

$remote_image = $webpath.$filename;

function save_image($inPath,$outPath)
{ 
    $in=    fopen($inPath, "rb");
    $out=   fopen($outPath, "wb");
    while ($chunk = fread($in,8192))
    {
        fwrite($out, $chunk, 8192);
    }
    fclose($in);
    fclose($out);
}

save_image($remote_image,'webcam/ultima.jpg');

?> 
<img src="webcam/ultima.jpg" alt"Ultima Immagine WebCam">

Si prega Accedi a partecipare alla conversazione.

  • Pietro
  • Avatar di Pietro
  • Visitatori
  • Visitatori
9 Anni 10 Mesi fa #4386 da Pietro
Risposta da Pietro al topic Alcune domande sulla gestione delle Webcam...
@ Roberto
HELP!!! :( Ciao, ho bisogno di aiuto.
Sono alle prese con il trasferimento delle immagini su un sito sperimentale creato su altervista.
Ho provato ad adattare il tuo file postato più su ma non riesco.
Preciso che su altervista ho creato la cartella swpi dove ho copiato l'intero contenuto della cartella server. Le immagini della camera arrivano regolarmente su swpi/img ma il file swpi_camera1.php non le aggancia.
Il tuo file che ho cercato di adattare è:

<?php
$data = date("dmY");
#path dove si trovano le immagini
$files = glob("img/camera1_".$data."*.jpg");
#indirizzo web dove si trovano le immagini
$webpath =" www.torinometeo.altervista.org.it/swpi/img/ ";
rsort ($files);

if (sizeof($files) > 0 ) {
$name= "".$files[0]."";
}
else {
$name = "image/no-immagine.jpg";
}


$file_a = explode('/',$name);
if (trim(end($file_a)) == '')
$filename = $file_a[count($file_a)-2];
else
$filename = end($file_a);

$remote_image = $webpath.$filename;

function save_image($inPath,$outPath)
{
$in= fopen($inPath, "rb");
$out= fopen($outPath, "wb");
while ($chunk = fread($in,8192))
{
fwrite($out, $chunk, 8192);
}
fclose($in);
fclose($out);
}

save_image($remote_image,'img/ultima.jpg');

?>
<img src="img/ultima.jpg" alt"Ultima Immagine WebCam">

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 10 Mesi fa #4387 da asy961
@Pietro
se usi la camera PI devi modificare

function returnimages($dirname,$extension,$start,$stop,$data) {
$image_array = array();
$pattern="(\.".$extension."$)"; //
//$files = array();
$files = glob("./img/raspi_".$data."*.jpg");
//if($handle = @opendir($dirname)) {
foreach($files as $file){
//echo $file;


nel file camera1.php

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

  • Pietro
  • Avatar di Pietro
  • Visitatori
  • Visitatori
9 Anni 10 Mesi fa #4395 da Pietro
Risposta da Pietro al topic Alcune domande sulla gestione delle Webcam...
@asy961
ciao, grazie per aver risposto, finalmente trovo un minuto per dedicarmi a sint wind.
Il file swpi_camera1.php presente nel pacchetto server 2 è così composto

<?php
$data = date("dmY");
$files = glob("./img/camera1_".$data."*.jpg");
rsort ($files);
if (sizeof($files) > 0 ) {
$theimg= '"'.$files[0].'"';
}
else {
$theimg = '"./no-immagine.jpg"';
}
$type = 'image/jpeg';
header('Content-Type:'.$type);
header('Content-Length: ' . filesize($theimg));
readfile($theimg);
// echo '<A HREF='; echo $theimg; echo '><IMG SRC='; echo $theimg; echo ' WIDTH="650px" >' ; echo '</A>' ;
// echo "\n";
?>

Facendo delle modifiche seguendo delle indicazioni sul forum
l'ho cambiato in

<?php
$data = date("dmY");
#path dove si trovano le immagini
$files = glob("img/camera1_".$data."*.jpg");
#indirizzo web dove si trovano le immagini
$webpath =" www.torinometeo.altervista.org/swpi/img/ ";
rsort ($files);

if (sizeof($files) > 0 ) {
$name= "".$files[0]."";
}
else {
$name = "image/no-immagine.jpg";
}


$file_a = explode('/',$name);
if (trim(end($file_a)) == '')
$filename = $file_a[count($file_a)-2];
else
$filename = end($file_a);

$remote_image = $webpath.$filename;

function save_image($inPath,$outPath)
{
$in= fopen($inPath, "rb");
$out= fopen($outPath, "wb");
while ($chunk = fread($in,8192))
{
fwrite($out, $chunk, 8192);
}
fclose($in);
fclose($out);
}

save_image($remote_image,'img/ultima.jpg');

?>
<img src="img/ultima.jpg" alt"Ultima Immagine WebCam">


ma non funziona in nessuno dei due casi. Forse un problema di sintassi o di struttura del file poiché i linguaggio di cui sopra non è il mio forte. Ho provato la modifica da te suggerita ma non ottengo alcun risultato.
Puoi darmi una mano a strutturarlo? Ti ringrazio in anticipo.
Grazie
Pietro

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 10 Mesi fa - 9 Anni 10 Mesi fa #4396 da asy961
@Pietro

Potresti dirmi il nome delle foto nella cartella /swpi/img ???

esempio: a me le salva come raspi_14072014_093124.jpg

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 9 Anni 10 Mesi fa da asy961.

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 10 Mesi fa #4397 da asy961
@Pietro

se le salva con lo stesso nome devi modificare solo questa riga

$files = glob("./img/camera1_".$data."*.jpg");

in

$files = glob("./img/raspi_".$data."*.jpg");

poi fammi sapere

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

  • Pietro
  • Avatar di Pietro
  • Visitatori
  • Visitatori
9 Anni 10 Mesi fa #4398 da Pietro
Risposta da Pietro al topic Alcune domande sulla gestione delle Webcam...
@asy961
ciao,
niente da fare non va ancora.
Tu hai il sito su altervista giusto? Potresti postare per favore il contenuto del tuo file?
Grazie
Pietro

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 10 Mesi fa #4399 da asy961
Scusa Pietro,
per favore mi dici il nome delle foto che trovi nella cartella /swpi/img sul server di altervista????

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

  • Pietro
  • Avatar di Pietro
  • Visitatori
  • Visitatori
9 Anni 10 Mesi fa #4401 da Pietro
Risposta da Pietro al topic Alcune domande sulla gestione delle Webcam...
Ciao,
grazie della risposta, ecco il nome di uno dei files

raspi_15072014-202459.jpg

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 10 Mesi fa #4405 da asy961

Allegato camera1_2014-07-15.zip non trovato



prova con il file completo....anche se la sola modifica riguarda la riga che ti ho descritto prima....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:
Ringraziano per il messaggio: Pietro

Si prega Accedi a partecipare alla conversazione.

  • Pietro
  • Avatar di Pietro
  • Visitatori
  • Visitatori
9 Anni 10 Mesi fa #4406 da Pietro
Risposta da Pietro al topic Alcune domande sulla gestione delle Webcam...
Grazie asy961,
funziona, il file rileva le immagini.
Cena pagata :)
Pietro

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 7 Mesi fa #4614 da omega304
Buongiorno,

sto anch'io smanettando con la cam raspi che peró non mi funziona.
Ho realizzato una stazione meteo per il club di volo Airforce Alta Badia. Mi potreste indicare qual é il file php definitivo per swpi camera1.php
Devo anche inserire qualche cosa nella cartella meteo del mio database.

Grazie e buon lavoro

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 7 Mesi fa #4615 da asy961
Ciao omega304
se usi il sito scaricato dalla sezione donwload dovresti dirmi se trovi dei file nella cartella /swpi/img e come sono nominati (es: raspi_01102014-101021.jpg)

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ringraziano per il messaggio: omega304

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 7 Mesi fa #4616 da omega304
Grazie della risposta. Nella cartella img ho solo i due file originali.

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 7 Mesi fa #4617 da omega304
Sulla cartella del raspi ho i file come tu hai indicato ma probabilmente non riesce ad inviarli. Sará un problema di path
Grazie

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 7 Mesi fa - 9 Anni 7 Mesi fa #4618 da asy961
allora non riesce ad inviare le foto....
devi correggere i dati ftp nel file /home/pi/swpi/swpi.cfg del raspi
al punto.....

[ftp]
ftpserver = ftp.tuosito.xyz
ftpserverdestfolder = /swpi/img
ftpserverlogin = tuo_nome_utente_ftp
ftpserverpassowd = tua_password_ftp
use_thread_for_sending_to_server = True

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 9 Anni 7 Mesi fa da asy961.
Ringraziano per il messaggio: omega304

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 7 Mesi fa #4619 da omega304
Perfetto avevo un punto in meno nella path grazie mille :)

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 6 Mesi fa #4768 da laren
Un buongiorno a tutta la comunità e i miei sinceri complimenti a tutti per le competenze e l'attività svolta in questo forum. Ho letto e riletto i post di questo forum ed è così che, grazie a tutti voi, sono riuscito a mettere online il mio sito raggiungibile all'indirizzo www.castelbuonometeo.altervista.org malgrado le mie scarse competenze di programmazione. La situazione peggiora se parliamo di php :( infatti le pagine delle statistiche non funzionano.
Al momento sul sito è presente una webcam che prevede l'invio di un file jpg il cui nome l'ho impostato direttamente nella ip camera tramite il suo sw.
Intanto ho acquistato un'altra ip camera HD che vorrei aggiungere nel sito ma questa non prevede nel suo sw la creazione di un file univoco jpg ma crea diversi file inserendo l'ora, tipo questo P14112708134910.jpg
Ora chiedo un aiuto perchè non riesco in nessun modo a mandare online le immagini avendo, al massimo, come risultato il mess. che l'immagine non può essere visualizzata perchè contiene degli errori :(
La struttura del sito è quella classica con: nella root la cartella swpi ed all'interno la cartella img nella quale arrivano i file della ipcamera.
Mi aiutate per favore?

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 6 Mesi fa #4769 da tony
i file nella cartella img vengono inviati correttamente ??
TT

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 6 Mesi fa #4770 da laren
Si, senza alcun problema

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 5 Mesi fa - 9 Anni 5 Mesi fa #4795 da Ciaschini
ragazzi ho bisogno di un'aiutino, la modalità della canon in particolare della a75, deve stare in scatto o in visualizzazione? perchè in scatto non viene riconoscita, mentre in visualizzazione ha scattato una foto e adesso non viene riconosciuta di nuovo, non capisco cosa sia :(

RISOLTO: come non detto, muovendo la fotocamera mi si era leggermente staccato un cavo di alimentazione :)
Ultima Modifica 9 Anni 5 Mesi fa da Ciaschini.

Si prega Accedi a partecipare alla conversazione.

Di più
9 Anni 3 Mesi fa #5132 da Ik3max
Ciao a tutti, finalmente ho intallato la stazione meteo con una camera_PI su altervista e attualmente funziona abbastanza bene, ricevo i dati meteo, le foto e si implementano i grafici, però c'è qualcosa che ancora non mi torna.

Premetto che ho installato sulla SD card il firmware V.1 aggiornato, mentre su altervista il server WEB V.1, su ...altervista.org/swpi.

I problemi che incontro sono questi:

-1) Non trovo una corrispondenza di valori di base cumulo con i valori del rispettivo grafico, ad esempio mentre su swpi_smartphone.html mi da 213 mt. sul grafico mi trovo 1.390 mt.

-2) Il file swpi_photoslide.php non mi funziona

-3) Se su Sint Wind PI in WebCam-Camera metto True su (sendImagesToServer) e (sendallimagestoserver), mi registra ogni 10 min. le foto su /swpi/img/raspi_....jpg ma non mi aggiorna più la foto raspi.jpg, contrariamente se setto True solo su (sendImagesToServer) mi aggiorna raspi.jpg e non più le altre.

Per il problema 3) credo sia lo stesso problema che ha avuto @kead sul post #1307, io ho anche seguito tutta la discussione con @kead, @alegrechi, @tony e @roberto2011, ma alla fine mi sono perso nei meandri delle modifiche e in pratica non ne ho capito una mazza.

Chiedo se c'è qualcuno più esperto di mè (e ve lo assicuro ci vuol poco), che mi possa dare una dritta.

Grazie da Giampietro.

Si prega Accedi a partecipare alla conversazione.

Tempo creazione pagina: 0.849 secondi