× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Errore lettura dati meteo PCE-FWS20

  • Tuccillo
  • Avatar di Tuccillo Autore della discussione
  • Visitatori
  • Visitatori
5 Anni 10 Mesi fa - 5 Anni 10 Mesi fa #407 da Tuccillo
Errore lettura dati meteo PCE-FWS20 è stato creato da Tuccillo

Allegato swpi_tucano.cfg.txt non trovato


Salve a tutti,
ho un problema dalle 12.30 di oggi (23/04). Prima che mi restiusse l'errore il sistema ha funzionato ininterrottamente per 2 settimane. L'errore che mi restituisce è il seguente:

Meteo : Error in getting data - status = 64

ho controllato la configurazione e tutto risulta invariato rispetto a quando funzionava (file swpi.cfg allegato, al posto dei dati sensibili ho messo i punti interrogativi)

Vi aggiungo il log dell'errore.

Spero che mi possiate aiutare.

Grazie mille
Fabiano
Allegati:
Ultima Modifica 5 Anni 10 Mesi fa da Tuccillo.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 10 Mesi fa #408 da tony
Ciao Tuccillo,

Questo è un annoso problema delle stazioni PCE.

La tua stazione si è bloccata e non ti resta che togliere e rimettere le batterie.
Il problema potrebbe essere dovuto alla tua configurazione nella quale vedo che hai attivato il server NTP e disattivato la sincronizzazione del tempo con la stazione PCE.
Dovresti fare il contrario :
Disattivare la sincronizzazione NTP e attivare quella della PCE.

Questo per fare in modo che le letture avvengano sempre lontane dallo scoccare del minuto quando la stazione logga i sui dati e non tollera richieste dalla USB. Anche il sw della PCE soffre di questi blocchi ma sincronizzando correttamente i tempi la cosa si evita.

La tua stazione non ha la regolazione dell'ora con il DCF ?
Ringraziano per il messaggio: Tuccillo

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 10 Mesi fa - 5 Anni 10 Mesi fa #409 da tony
Fai le modifiche sopra ma ho rivisto il codice.
Lo stato 64 indica la perdita di segnale wireless dai sensori.

Ma la console cosa ti dice ?
Ultima Modifica 5 Anni 10 Mesi fa da tony.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • Tuccillo
  • Avatar di Tuccillo Autore della discussione
  • Visitatori
  • Visitatori
5 Anni 10 Mesi fa #420 da Tuccillo
Risposta da Tuccillo al topic Errore lettura dati meteo PCE-FWS20
Ciao Tony,
ti ringrazio per la veloce risposta. Purtroppo la centralina la posso controllare solo da remoto, si trova presso un lido. Adesso rifunziona, come dicevi tu probabilmente aveva perso il segnale dal sensore ed adesso si è riagganciata. La distanza tra il trasmettitore ed il ricevitore della PCE è di circa 60-70 m in linea d'aria con ostacoli vari interposti, quindi mi rendo conto che siamo a limite. Ho sempre cercato un modo per potenziare la trasmissione, forse proverò a mettere un riflettore sul trasmettitore.

Per il momento ti ringrazio e complimenti per il lavoro che stai svolgendo sul swpi.

Saluti

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 10 Mesi fa #421 da tony
Bene. Ti consiglio comunque di rivedere la configurazione ed attivare la sincronizzazione tempi tramite stazione.

La tua configurazione funziona lo stesso perché di solito la differenza tra i tempi DCF e NTP e solo di pochi secondi.
Rischi però che, se per qualche motivo la rete non funziona e swpi non riesce ad ottenere il tempo NTP, di bloccare la PCE. A quel punto l'unica soluzione è andare al lido a rimuovere le batterie :-(

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.700 secondi