× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file SINT Wind con sensori standalone + Anemometro PCE

Di più
8 Anni 6 Mesi fa #696 da SkizZO
Aggiornamento.. ieri avviai il raspberry e collegai il DHT11... tutto ok, funziona alla grande.

Ho installato anche l'adattatore wifi, ed anch'esso va alla perfezione. Se vuoi aggiungere un articolo con le istruzioni fai un fischio che è una cretinata (ho utilizzato un micro adattatore wifi usb).


Stasera mi sa che mi do al saldatore ed allo stagno.
Volevo far notare un errore o disguido (soprattutto per un newbie come me):
Nella mappa delle connessioni della GPIO, al PIN12 è indicato correttamente il sensore DHT, e c'è scritto di lato GPIO18.
nell'articolo del sensore DHT, si dice di collegare data al GPIO18 ed io erroneamente l'ho collegato al PIN18 e non funzionava.
confrontando le indicazioni (lo schema) del sensore BMP085, vedo che quando si parla di GPIO21, GPIO1, ecc... vi riferite ai "pin" sulla scheda.

Tutto questo per dire, ad esempio, perchè sul PIN12 c'è scritto GPIO18? non dovrebbe essere "pin18".

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #697 da tony
Bene :-)

Per la wifi se vuoi aprire un post con le istruzioni mi fai un grande favore. Scrivere la documentazione è sempre la parte più dura di un progetto e conto molto su questo forum per un aiuto :-)

Sulla GPIO e numerazione bisogna sempre fare attenzione i quanto, quando si parla di GPIONN, si intende il pin del chip bcm2835 mentre con PINNN si intende il pin del connettore GPIO (che è sequenziale). Normalmente io uso la numerazione GPIO in quanto nel software faccio riferimento a questa.
Vedi l'immagine sotto per le corrispondenze ( il PINNN e quello cerchiato ).

Ultima Modifica 8 Anni 6 Mesi fa da tony.
Ringraziano per il messaggio: SkizZO

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #698 da SkizZO
Svelato l'arcano... ho capito perchè con alcuni alcuni "GPIO" mi trovavo...
Vedendo lo schema del sensore BMP, se ad esempio si collegava al PIN16, io scrivevo GPIO16 (invece è GPIO23).
Alla fine non mi trovavo solo col sensore DHT poichè l'hai scritto tu, per gli altri collegamenti ho seguito le tracce fino al PIN e ci ho dato il nome GPIO....

Cmq tutte le cose che mi linki le ho studiate abbondantemente, per questo faccio 1000 domande...
Sono lieto di fare un howto per il wireless

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #715 da SkizZO
Allora, costruiti 2 circuiti (x 2 stazioni) con sensori PCE, entrambi vanno bene (almeno soffiando e girando la bandieruola...), uno però (collegato alla stessa raspberry) quando si lancia il comando per testarlo, da un errore:

Error accssing 0x77: Check your I2C address.

Poi però da le rilevazioni.

Cortesemente, mi servirebbero i comandi per testare il bmp055 :D

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #716 da tony
Quell'errore non è relativo al PCE ma proprio al BMP085. Non viene visto.
Il programma per testare il BMP085 da solo è
sudo python BMP085.py

Ma lo puoi testare anche col comando che testa il PCE ( se hai impostato use_bmp085)
sudo python sensor_argent80422.py

Comunque finché il sensore non viene visto ed hai quell'errore dubito riuscirai ad ottenere nulla.

Prova
sudo i2cdetect -y 1

Mi raccomando 1 alla fine e non 0 come nella figura sotto.
Se non vedi in fondo un 77 .... ricontrolla i collegamenti


Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #717 da SkizZO
Dopo aver smanettato un casino a controllare contatti & company, ho risolto l'arcano......

Ho usato dei connettori RJ11 femmina "riciclati" nei quali ho usato come "contatto" il cavetto RJ45 spellato (che è rigido)

Ebbene dopo 3-4 inserimenti rimane piegato e non fa contatto!!! (stavo uscendo pazzo)

Me ne sono accorto perchè all'improvviso la bandieruola segnava sempre W, e l'anemometro non funzionava....
staccando e riattaccando il cavo, la bandieruola non funzionava, e funzionava stavolta l'anemometro...

Dunque funziona sia il DHT11, sia il BMP085, e sia i sensori PCE... THANKS!!!
Ora devo montare il bmp nel diffusore passivo.

Mi chiedavo se c'era un modo per avere un vero e proprio "remote desktop"... cioè in SSH è come se si aprisse un altra sessione o sbaglio? io vorrei vedere quello che vedo attaccando il raspberry al pc
Last login: Sat May 18 11:10:31 2013
SSH
pi@swpi ~ $ cd /home/pi/swpi
pi@swpi ~/swpi $ sudo python sensor_argent80422.py
Speed: 0.0 Dir: (0.0, 'N') Temp; None
Speed: 0.0 Dir: (0.0, 'N') Temp; None
Speed: 0.0 Dir: (0.0, 'N') Temp; None
Speed: 0.0 Dir: (0.0, 'N') Temp; None
Speed: 2.4 Dir: (0.0, 'N') Temp; None
Speed: 9.6 Dir: (0.0, 'N') Temp; None
Speed: 2.4 Dir: (0.0, 'N') Temp; None
Speed: 0.0 Dir: (0.0, 'N') Temp; None
Speed: 0.0 Dir: (225.0, 'SW') Temp; None
Speed: 0.0 Dir: (225.0, 'SW') Temp; None
Speed: 0.0 Dir: (225.0, 'SW') Temp; None
Speed: 0.0 Dir: (225.0, 'SW') Temp; None

pi@swpi ~/swpi $ sudo python BMP085.py
Temperature: 21.50 CPressure:    1006.27 hPa
Temperature: 21.50 CPressure:    1006.24 hPa
Temperature: 21.50 CPressure:    1006.24 hPa
Temperature: 21.50 CPressure:    1006.26 hPa
Temperature: 21.50 CPressure:    1006.25 hPa
Temperature: 21.50 CPressure:    1006.29 hPa
Temperature: 21.50 CPressure:    1006.31 hPa
Temperature: 21.50 CPressure:    1006.24 hPa
Temperature: 21.50 CPressure:    1006.33 hPa


pi@swpi ~/swpi $ cd DHT
pi@swpi ~/swpi/DHT $ sudo chmod +x DHT
pi@swpi ~/swpi/DHT $ sudo python test.py
Temperature: 24.0 C Humidity:    39.0
Temperature: 24.0 C Humidity:    44.0
Temperature: 24.0 C Humidity:    43.0
Temperature: 24.0 C Humidity:    44.0
Temperature: 24.0 C Humidity:    43.0
Temperature: 24.0 C Humidity:    43.0
Temperature: 24.0 C Humidity:    39.0
Temperature: 24.0 C Humidity:    36.0
Temperature: 24.0 C Humidity:    35.0
Temperature: 24.0 C Humidity:    44.0
Temperature: 24.0 C Humidity:    43.0
Temperature: 24.0 C Humidity:    43.0

pi@swpi ~/swpi/DHT $ sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- 77
pi@swpi ~/swpi/DHT $


La sto mettendo online... al momento da quest'errore (sarà perchè forse ho due processi swpi attivi??)
onnected with IP : 79.1.22.XX
Exception in thread Thread-4:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/home/pi/swpi/web_server.py", line 242, in run
    s=SocketServer.TCPServer(("",port),ScriptRequestHandler)
  File "/usr/lib/python2.7/SocketServer.py", line 419, in __init__
    self.server_bind()
  File "/usr/lib/python2.7/SocketServer.py", line 430, in server_bind
    self.socket.bind(self.server_address)
  File "/usr/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

...da premettere che sto operando con raspberry avviato, in SSh, dunque presuppongo che ci siano 2 sessioni con 2 processi swpi attivi, infatti via ssh killando prima swpi (killswpi mi pare), e poi avviandolo, l'errore di cui sopra non lo da.

Per ora ho impostato solo l'upload via ftp, anche se ho anche un database da usare...

nel logo, dopo varie misure:
[18/05/2013-13:49:30] Calculating Meteo data and statistics
/home/pi/swpi/web_server.py:83: PendingDeprecationWarning: cgi.parse_qs is depre                                                                                                 cated, use urlparse.parse_qs instead
  self.body = cgi.parse_qs(qs, keep_blank_values=1)
192.168.0.106 - - [18/May/2013 13:49:34] "POST /login.py HTTP/1.1" 301 -
192.168.0.106 - - [18/May/2013 13:49:34] "POST /login.py HTTP/1.1" 200 -
192.168.0.106 - - [18/May/2013 13:49:35] "GET /swpi_webconfig.py HTTP/1.1" 200 -
192.168.0.106 - - [18/May/2013 13:49:35] "GET /swpi-banner.jpg HTTP/1.1" 200 -
192.168.0.106 - - [18/May/2013 13:49:35] code 404, message File not found
192.168.0.106 - - [18/May/2013 13:49:35] "GET /favicon.ico HTTP/1.1" 404 -
[18/05/2013-13:49:45] Logging data to Database


..credevo che questa sarebbe stata la parte più facile.... :( sentirete poi quando dovrò creare le tabelle nel Db ahah
Ultima Modifica 8 Anni 6 Mesi fa da SkizZO.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #718 da tony

Mi chiedavo se c'era un modo per avere un vero e proprio "remote desktop"... cioè in SSH è come se si aprisse un altra sessione o sbaglio? io vorrei vedere quello che vedo attaccando il raspberry al pc


per vedere l'output dei swpi da una sessione SSh usa :

tail -f nome_dell_ultimo_log.log

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #751 da SkizZO
Credo che questo weekend installerò la stazione... ho solo un dubbio.. un forte dubbio...

Non ho ancora testato la stazione all'esterno (e credo che debba farlo), ma girando le palette dell'anemometro leggo dal log:
[20/05/2013-22:16:30] BMP085 - Temperature: 22.2 C Pressure:    1010.7
[20/05/2013-22:16:30] DHT - Temperature: 22.0 C Humidity:    36.0
[20/05/2013-22:16:30] Calculating Meteo data and statistics
[20/05/2013-22:16:53] Logging data to Database
[20/05/2013-22:16:53] Dir: NE - Spd: 1.81425485961 - Gst: 0.979619254651 - Tout:                                                                                                  22.2 - Tin: 22.0 - Hout: 36.0 - P: 1010 - Rtot: 77.0 - RDay: 0.0 - R1h: 0.0 - R                                                                                                 24h: 0.0 - CB: 1925
[20/05/2013-22:17:30] BMP085 - Temperature: 22.5 C Pressure:    1010.7
[20/05/2013-22:17:31] DHT - Temperature: 22.0 C Humidity:    42.0
[20/05/2013-22:17:31] Calculating Meteo data and statistics
[20/05/2013-22:17:53] Logging data to Database
[20/05/2013-22:17:54] Dir: S - Spd: 4.4060475162 - Gst: 2.37907533272 - Tout: 22                                                                                                 .5 - Tin: 22.0 - Hout: 42.0 - P: 1010 - Rtot: 77.0 - RDay: 0.0 - R1h: 0.0 - R24h                                                                                                 : 0.0 - CB: 1653
[20/05/2013-22:18:30] BMP085 - Temperature: 22.8 C Pressure:    1010.7
[20/05/2013-22:18:30] DHT - Temperature: 22.0 C Humidity:    37.0
[20/05/2013-22:18:30] Calculating Meteo data and statistics
[20/05/2013-22:18:53] Logging data to Database
[20/05/2013-22:18:53] Dir: S - Spd: 6.09071274298 - Gst: 3.28872178347 - Tout: 2                                                                                                 2.8 - Tin: 22.0 - Hout: 37.0 - P: 1010 - Rtot: 77.0 - RDay: 0.0 - R1h: 0.0 - R24                                                                                                 h: 0.0 - CB: 1884
[20/05/2013-22:19:30] BMP085 - Temperature: 22.9 C Pressure:    1010.7
[20/05/2013-22:19:30] DHT - Temperature: 22.0 C Humidity:    36.0
[20/05/2013-22:19:30] Calculating Meteo data and statistics
[20/05/2013-22:19:53] Logging data to Database
[20/05/2013-22:19:53] Dir: S - Spd: 8.42332613391 - Gst: 4.54823225374 - Tout: 2                                                                                                 2.9 - Tin: 22.0 - Hout: 36.0 - P: 1010 - Rtot: 77.0 - RDay: 0.0 - R1h: 0.0 - R24                                                                                                 h: 0.0 - CB: 1935
wlan0 is up

Non credo sia normale... la raffica è la metà della velocità :(
E' anche vero però che la maggiorparte delle misurazioni sono 0.. ma non credo conti..
Domani mi armo anche io di phon, ho capito :D
Ultima Modifica 8 Anni 6 Mesi fa da SkizZO.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #755 da tony
C'era un baco nella gestione dei Nodi.
Aggiorna e riprova.

Dire di tenerla ancora un pò in test .. sei il primo con PCE+BMP+DH11 ed il tuo log mi sembra strano.

[20/05/2013-22:17:54] Dir: S - Spd: 4.4060475162 - Gst: 2.37907533272 - Tout: 22

dopo quei valori dovresti vedere anche la pressione e l'umidità che invece non vedo ??????? :huh: :S
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #763 da Roberto Vaccaro
Ciao Tony

Bhe... anche io ho PCE+BMP+DH11 e RFM01 anche se non proprio come SkizZO

A parte che si è guastato il sensore temperatura e umidità, è bloccato da un paio di giorni a 7.5 °C e 86%.
Comunque ti volevo chiedere un ragguaglio relativo al DH11, è possibile che l'umidità sia così diversa da quella letta dalla consolle?

www.iw1pur.com/swpi_test/meteobargagli.html (Ambiente di test)

www.iw1pur.com/swpi/meteobargagli.html (produzione)

se guardi la differenza è veramente notevole.

Un'altra cosa, dove prende il valore di "R1h:" quel valore assurdo è da ieri sera che c'è e volevo capire se poteva dipendere sempre dalla centralina esterna.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #764 da tony
Purtroppo il DH11 è molto impreciso ... d'altronde le sue specifiche lo dichiarano molto esplicitamente !!

Appena me ne sono accorto l'ho subito sostituito con un DH22 che rispetto alla console non si discosta mai per più di qualche decimale.
Per me è importante in quanto l'umidità determina la Base Cumulo che è la massima quota alla quale riusciamo a volare. Il DH22 l'ho preso in China a circa 8€ compresa spedizione ... ma almeno 3 settimane per averlo.


R1h lo calcolo confrontando il totale rain letto dall'RFM01 ( nel tuo caso ) ed il valore loggato nel database un'ora prima. sulla mia stazione non vedo anomalie .. sei aggiornato con software ??
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #765 da Roberto Vaccaro
Ok ordinerò un DH22...
Si sono aggiornato.
Eccoti un pezzetto di log:
[21/05/2013-13:57:06] Starting SINT WIND PI  ... 
************************************************************************
*                      Sint Wind PI 01.19.77                           *
*                                                                      *
*          2012-2013 by Tonino Tarsi  <tony.tarsi@gmail.com>           *
*                                                                      *
*     System will start in 10 seconds - Press Ctrl-C to cancel         *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[21/05/2013-13:57:27] Checking internet connetion ...
[21/05/2013-13:57:27] Starting sensor reading - Sensor type is : WH1080-RFM01
[21/05/2013-13:57:27] Starting RF listening
[21/05/2013-13:57:27] Internet ok
[21/05/2013-13:57:27] Checking internet connetion ...
[21/05/2013-13:57:27] Internet ok
[21/05/2013-13:57:28] Connected with IP : 31.194.199.226 
[21/05/2013-13:57:28] Local IP :192.168.123.108 Public IP :  31.194.199.226 
[21/05/2013-13:57:28] Config Server running on port 80
[21/05/2013-13:57:28] Starting General WatchDog
mar 21 mag 2013, 13.57.54, CEST
[21/05/2013-13:57:54] System time adjusted from NPT server : europe.pool.ntp.org
[21/05/2013-13:57:57] Mail sent to :iw1pur@iw1pur.com
[21/05/2013-13:58:02] First data received from RFM01 station 0A00 .. processing
[21/05/2013-13:58:02] BMP085 - Temperature: 16.8 C Pressure:    963.0 
[21/05/2013-13:58:02] loading plugins
[21/05/2013-13:58:02] Checking internet connetion ...
[21/05/2013-13:58:02] Internet ok
[21/05/2013-13:58:02] Logging data ...
[21/05/2013-13:58:03] Data sent to server : OK
[21/05/2013-13:58:03] Uploading data ...
[21/05/2013-13:58:03] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-13:58:03] Calculating Meteo data and statistics
[21/05/2013-13:58:03] Rereading config file ..
[21/05/2013-13:58:03] Disk space left = 1471340544
[21/05/2013-13:58:03] Sleeping 300 seconds
[21/05/2013-13:58:03] Sent file to server : meteo.txt
[21/05/2013-13:58:03] Deleted file : ./meteo.txt
mar 21 mag 2013, 13.58.04, CEST
[21/05/2013-13:58:04] System time adjusted from NPT server : europe.pool.ntp.org
[21/05/2013-13:58:21] Logging data to Database
[21/05/2013-13:58:21] Dir: S - Spd: 4.9 - Gst: 7.34 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-13:58:50] New data received from RFM01 station 0A00 .. processing
[21/05/2013-13:58:50] BMP085 - Temperature: 16.8 C Pressure:    962.9 
[21/05/2013-13:58:51] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-13:58:51] Calculating Meteo data and statistics
[21/05/2013-13:59:09] Logging data to Database
[21/05/2013-13:59:09] Dir: WNW - Spd: 6.12 - Gst: 12.24 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-13:59:38] New data received from RFM01 station 0A00 .. processing
[21/05/2013-13:59:38] BMP085 - Temperature: 16.8 C Pressure:    963.1 
[21/05/2013-13:59:38] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-13:59:38] Calculating Meteo data and statistics
[21/05/2013-13:59:57] Logging data to Database
[21/05/2013-13:59:57] Dir: SW - Spd: 8.57 - Gst: 14.69 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:03:03] Checking internet connetion ...
[21/05/2013-14:03:03] Internet ok
[21/05/2013-14:03:03] Logging data ...
[21/05/2013-14:03:03] Uploading data ...
[21/05/2013-14:03:04] Rereading config file ..
[21/05/2013-14:03:04] Disk space left = 1471320064
[21/05/2013-14:03:04] Sleeping 300 seconds
mar 21 mag 2013, 14.03.05, CEST
[21/05/2013-14:03:05] System time adjusted from NPT server : europe.pool.ntp.org
[21/05/2013-14:03:37] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:03:37] BMP085 - Temperature: 16.8 C Pressure:    963.1 
[21/05/2013-14:03:37] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-14:03:37] Calculating Meteo data and statistics
[21/05/2013-14:03:56] Logging data to Database
[21/05/2013-14:03:56] Dir: SW - Spd: 8.57 - Gst: 14.69 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:04:27] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:04:27] BMP085 - Temperature: 16.7 C Pressure:    963.0 
[21/05/2013-14:04:27] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-14:04:27] Calculating Meteo data and statistics
[21/05/2013-14:04:46] Logging data to Database
[21/05/2013-14:04:46] Dir: SW - Spd: 8.57 - Gst: 14.69 - Tout: 7.5 - Tin: 16.7 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:05:15] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:05:15] BMP085 - Temperature: 16.8 C Pressure:    963.0 
[21/05/2013-14:05:16] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-14:05:16] Calculating Meteo data and statistics
[21/05/2013-14:05:34] Logging data to Database
[21/05/2013-14:05:34] Dir: SW - Spd: 8.57 - Gst: 14.69 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:06:03] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:06:03] BMP085 - Temperature: 16.8 C Pressure:    963.0 
[21/05/2013-14:06:03] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-14:06:03] Calculating Meteo data and statistics
[21/05/2013-14:06:21] Logging data to Database
[21/05/2013-14:06:21] Dir: SW - Spd: 8.57 - Gst: 14.69 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:06:50] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:06:50] BMP085 - Temperature: 16.8 C Pressure:    962.9 
[21/05/2013-14:06:51] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-14:06:51] Calculating Meteo data and statistics
[21/05/2013-14:07:09] Logging data to Database
[21/05/2013-14:07:09] Dir: SW - Spd: 8.57 - Gst: 14.69 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:07:39] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:07:39] BMP085 - Temperature: 16.8 C Pressure:    963.0 
[21/05/2013-14:07:39] DHT - Temperature: 17.0 C Humidity:    38.0 
[21/05/2013-14:07:39] Calculating Meteo data and statistics
[21/05/2013-14:07:54] Last main Thread delay ratio: 1.0
[21/05/2013-14:07:57] Logging data to Database
[21/05/2013-14:07:57] Dir: S - Spd: 8.57 - Gst: 13.46 - Tout: 7.5 - Tin: 16.8 - Hout: 86.0 - Hin: 38.0 - P: 1013 - Rtot: 6.0 - RDay: 0.0 - R1h: 0.0 - R24h: -693.6 - CB: 696
[21/05/2013-14:08:04] Checking internet connetion ...
[21/05/2013-14:08:04] Internet ok
[21/05/2013-14:08:04] Logging data ...
[21/05/2013-14:08:05] Data sent to server : OK
[21/05/2013-14:08:05] Uploading data ...
[21/05/2013-14:08:05] Rereading config file ..
[21/05/2013-14:08:05] Disk space left = 1471270912
[21/05/2013-14:08:05] Sleeping 300 seconds
mar 21 mag 2013, 14.08.06, CEST
[21/05/2013-14:08:06] System time adjusted from NPT server : europe.pool.ntp.org
[21/05/2013-14:08:11] Sent file to server : meteo.txt
[21/05/2013-14:08:11] Deleted file : ./meteo.txt
[21/05/2013-14:08:27] New data received from RFM01 station 0A00 .. processing
[21/05/2013-14:08:27] BMP085 - Temperature: 16.9 C Pressure:    963.0 
[21/05/2013-14:08:28] DHT - Temperature: 17.0 C Humidity:    38.0 

Dimenticavo, ieri ho resettato la centralina.
Ultima Modifica 8 Anni 6 Mesi fa da Roberto Vaccaro.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #766 da tony
Allora dovrai aspettare domani per riavere dei dati sensati. E' ovvio che se resetti il totale :
( totale - il_valore_di_ieri )... è negativo :blush:
Ultima Modifica 8 Anni 6 Mesi fa da tony.
Ringraziano per il messaggio: Roberto Vaccaro

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #775 da SkizZO
Ciao, per quanto riguarda la raffica ora pare ok ! :D

ho girato un po con le mani ed osservato le misurazioni, effettivamente la raffica ora è maggiore della media!
Per quanto riguarda il mio log, facendo copia/incolla, mi troncava il testo (BAH!!)
[21/05/2013-23:02:06] System time adjusted from NPT server : europe.pool.ntp.org
[21/05/2013-23:02:30] BMP085 - Temperature: 22.0 C Pressure:    1000.7
[21/05/2013-23:02:31] DHT - Temperature: 23.0 C Humidity:    34.0
[21/05/2013-23:02:31] Calculating Meteo data and statistics
[21/05/2013-23:02:49] Logging data to Database
[21/05/2013-23:02:49] Dir: W - Spd: 0.0 - Gst: 0.0 - Tout: 22.0 - Tin: 23.0 - Hout: 34.0 - P: 1000 - Rtot: 77.0 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 2022 - Trend: 0.00


Intanto ho quasi finito di incassare il tutto in una cassetta di derivazione rettangolare x elettricisti, non stagna tanto starà al coperto (con il dht all'esterno del box), poi la posizionerò un po in prova fino a sabato (credo che domani sera la metto fuori).
Dopo aver configurato il tutto, ho altre domande (..ovviamente)

1) Come già chiesto da alcuni, perchè non arrotondi i nodi alla 1° decimale?
2) Ma il template aggiornato dove lo scarico? (../swpi_smartphone.php), ho trovato quello del tablet, ma la tendenza?
3) Dove cavolo trovo WU Graphs ?? (sono già attivo su wUnderground)

5) Come posso diminuire il tempo di upload dei dati?? vorrei ottenere una cosa tipo rapidfire di wuhu (magari ogni 10-15 secondi)

..credo bastino!! :-o (ahò, stavo zitto da 2 gg :D )
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #776 da tony
Sul punto 4 hai una vecchia versione e riscaricati la parte server

1) li arrotondo dai visualizzatori .. e forse in futuro ...
2) Ho messo tutti i miei script nel nuovo file server .. comunque quella parte la devi un pò personalizzare .. quei file sono solo un punto di partenza.
3) esiste un post di Alessandro a riguardo
5) le misure vengono fatte ogni minuto quindi a 15 secondi non ci puoi arrivare e credo sia inutile.
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #777 da SkizZO
Oh ho controllato il punto fantasma, digitando l'indirizzo non esce più... Ma il file è pubblico o sbaglio (se lo scarico posso leggerlo)?
Comunque meglio di prima!
Per il template dello smartphone l'avevo, appunto, "fregato" da jessica 2.. Hai cambiato l'url delle immagini e li ho dovuti aggiornare :-)

Poi personalizzo....
Per l'update interval che ora è a 600 secondi, non ho trovato la variabile da configurare a 60 sec.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #778 da tony
Le password sono in un file php di configurazione quindi credo siano al sicuro. I php non sono scaricabili ed è fondamentalmente lo stesso meccanismo che usi probabilmente in joomla o altro CMS.

Comunque potresti anche evitarti tutta la parte in php e mysql ed usare solo la parte html. Anche io oramai su questo sito il logger ( e relativi php ) li uso pochissimo e presto l'abbandonerò completamente a favore magari di un nuovo logger che usi una struttura tabelle tipo quella di Weather Display ( compatibile con i grafici di WU Graphs )

In tal caso i file che ti servono sono solo ;

swpi_dahboard_meteo.html ( o una qualunque variante che trovi in server.zip )
swpi_smartphone.html
swpi_tablet.html

Nessuno di questi usa il database ma il file meteo.txt.
Nelle ultime versioni, nel file meteo.txt, invio anche altre informazioni ( non le pwd :-) ) tra qui le unità di misura del vento. Contavo di modificarli in modo da funzionare sia in kmh che in nodi ma .. probabilmente arriverai prima tu :-)


Per l'intervallo di uploading il parametro è webcaminterval . La webcam,l'uploader ed il logger condividono lo stesso intervallo. Se li vuoi separate devi usare un plugin come spiego nel post dedicato ai plugin.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #780 da SkizZO
Per le password... non sapevo che i files in php non si scaricassero (figurati!), quindi ora va bene :D

Effettivamente basta cambiare la dicitura nel file html per l'unità di misura... già fatto, serve solo farlo nei grafici ma ancora devo darci un'occhiata.

Se non loggo nel database, non avrò i grafici sul sito mobile giusto? quelli richiamano i files in .php (potrò vedere solo quelli generati da WU Graphs..). Il Db l'ho già configurato e funziona tutto :D

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #781 da tony
Per avere i grafici di WU Graphs non è necessario ne il database ne il logger. Basta che hai una stazione su www.wunderground.com e che installi e configuri WU Graphs

Tieni solo presente che wunderground, anche se gli invii i dati ogni minuto, li registra solo a 5 mimuti. Per i nostri scopi ( e credo anche i vostri ) và più che bene.

Quando hai finito magari di sistemate le tue versioni in nodi postale ( magari in nuovo post ) che potrebbero essere utili ad altri kite-surver :-)
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #782 da SkizZO
Si ma infatti per wu graphs ci siamo (anche se ancora devo trovare il post)

Io mi riferisco ai grafici della versione mobile

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #783 da tony
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #784 da SkizZO
Uhmmm ero convinto che erano in flash...
Se si vedono sul cell, allora mi sa che opterò per questa soluzione... ovvero grafici di WU Graphs linkati alle pagine del template smartphone (e tablet... 2 in 1)

E per il web invece utilizzerò un template chiaro che ho visto, e magari se ci riesco faccio due modifiche...

Queste erano le pagine della vecchia stazione:
Situazione Attuale
Grafici

Poi penserò alla webcam che ahimè credo non sia gestibile dal raspberry...
Abbiamo una Thera5 antivandalo motorizzata, al momento usiamo livestream per pubblicarla; sul pc ho installato Adobe FMLE per l'encoding video che viene trasmesso ai loro servers.
Ovviamente la cam è attaccata ad una scheda di acquisizione che converte il segnale in digitale (la cam ha il classico cavetto coassiale)

La WEBCAM è questa , c'è un'interferenza dovuta ad una pompa di sollevamento dell'acqua dolce difettosa, stiamo aspettando il ricambio della pompa (staccandola si vede bene).

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #795 da SkizZO
Trovato WU Graphs (l'altra sera il server da cui scaricarlo era down...

Lo ho "installato" e funziona alla grande.

Mi chiedevo se secondo te c'è un espediente per modificare l'unità di misura dei grafici da km/h - m/S a KTS
Ultima Modifica 8 Anni 6 Mesi fa da SkizZO.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #796 da tony
Hacherando il codice.
Io l'ho fatto per aggiungere la base cumulo.

Il file che devi modificare è graphd4a.php in fondo dove trovi :
data: comArr(dAvgWS)

lo modifichi con :
data: comArrKnots(dAvgWS)

e definisci una nuova funzione in cima al file
function comArrKnots(dAvgWS) { 
    var outarr = [];
    for (var i = 0; i < timeArray.length; i++) {
     outarr[i] = dAvgWS[1] * 0.544;
    }
  return outarr;
}

Lo stesso per la raffica ....


La costante di conversione controllala che l'ho butta giù approssimativa.
In bocca al lupo e fai prima un backup del vecchio :-)


[edit]

Aspetta perché mentre ero sulla tazza :-) mi mi venuto in mente che forse cìè un baco nell'invio dei dati a WU. WU vuole i dati in nodi mentre forse io gli li mando in kmh.

[riedit]

Allora ho modificato però aiutami tu che sicuraente sei più ferrato di me.

Knots = kmh * 0.539956803456
mph = kmh * 0.621371192

Ti torna ?
Ho visto che tra i paramitri WU grapg cìè l'opzione Imperial .. Non và bene ?
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #812 da SkizZO
Purtroppo imperial lo da in miglia orarie!! (mph) A me servirebbe Nautical :(
Comunque ho notato che i grafici di WU graph sono diversi dai miei, o meglio non ci sto a capì più una mazza:

A) I grafici generati dal database del "mio" server segnano KM/h ma presuppongo siano nodi (SINTWIND è impostato a kts) GRAFICO DA DB
B ) I grafici generati da wu graphs invece sono in km/h,

Se guardi i 2 picchi, ti accorgi che il grafico A ha un picco sui 16,8 km/h (presuppongo KTS, visto che sintwind è impostato su kts), invece il grafico B (WUGraphs) ha un picco di 12,1 km/h

Ora visto che 1 nodo = 1,852 km/h,
1 Km/h = 1/1,852 = 0,5399568034557235 nodi.

se considero i due grafici, diciamo che uno dovrebbe essere un poco più della metà dell'altro (parlo dell'asse y), e così pare

un miglio orario invece (mph) = 0,86897699263671 nodi, dunque in questo caso un ipotetico grafico in nodi comparato con uno stesso in miglia orarie, dovrebbe apparire all'incirca quasi il doppio.

Provo la tua funzione, intanto lascio attiva anche la parte che logga sul server, siamo sicuri che li è in nodi (o sbaglio?)

In ogni caso appena mi trovo sul posto faccio 2 comparazioni con l'anemometro portatile.






Intanto domani la porto in spiaggia, una volta montata lì i dati del vento saranno sicuramente più stabili (perdonatemi ma è montata in mezzo a dei palazzi per prova...) :D

[edit]
Ci ho provato ad editare il file, ma esce sempre un grafico bianco :(
Ultima Modifica 8 Anni 6 Mesi fa da SkizZO.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #817 da tony
1) Se aggiorni all'ultima versione ora a WU invio i dati correttamente quini i kmh che leggi dovrebbero essere corretti.
2) Non ho capito il problema di temp e press. Hai dei problemi ai sensori ?
3) Per avere i grafici in nodi quindi l'unica alternativa e quella di modificare il codice come ti dicevo .. se non ci riesci appena trovo 2 minuti te lo faccio io. Non potrai utilizzare lo sticker di WU ma potrai sempre usare quello di Alessandro.
4) Si .. installala cosi vediamo con il vento vero e sarà più facile capire i problemi
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #818 da SkizZO
1) e 4) : La stazione è offline, la installeranno lunedì :( onestamente lo faccio fare a loro (gli ho spiegato come e dove..); tral'altro oggi ho avuto problemi con il wifi (si connetteva alla rete, ma non scambiava pacchetti, e non rispondeva al ping..) dopo 45 minuti mi sono rotto i maroni e sono entrato in acqua..... onde oltre i 2,5m e vento 26/32 nodi :-o
Da notare che sarà il router cinese che hanno....a casa mia ha funzionato al primo colpo, invece al lido ho avuto problemi anche con un notebook ed una ipcam.

Credo che la connetteremo via cavo al router.

2) Avevo problemi di visualizzazione dei valori, ma smanettando con le impostazioni ho risolto tutto...
3) ci ho provato, ma è come se non vedesse la funzione, ed il grafico è bianco. mi sa che la metto al posto sbagliato ma ne ho provati vari....
Ci sono riuscito (o quasi..) non con il tuo metodo :D
Guardando nel file WUG-settings, ad un certo punto la variabile $windcon, se si seleziona km/h è uguale ad 1 (infatti più in su si setta l'unità di misura del db di provenienza..), se si seleziona m/s è uguale a ... non ricordo.. cmq io l'ho messa uguale a 0.539956, e secondo me il vento viene convertito in questo modo da wugraphs.

Il grafico è diminuito ^_^ ^_^, ora devo trovare solo la stringa dell'unità di misura (praticamente sto convertendo tutti i "m/s" in kts)
Ho editato anche settings.php e configurator.php... praticamente ora scelgo i nodi dal configuratore...
Un più bravo di me, potrebbe tranquillamente aggiungere anche quelli (io ho sostituito kts con m/s, conversione inclusa)
WUGRAPHS IN KTS
Cmq per stare più tranquillo installo WUGraphs anche in un altra dir e confronto magari 2 picchi uguali (km/h e kts) per vedere se la conversione va bene... tutto cmq gira su $windcon e $windmu

Un'altra cosa che non sono riuscito a fare, è trovare quel colore porpora... ho cercato in tutti i css ma non ce n'è traccia... (class ui-li-aside, non trovo il colore #890789)

EDIT:
Se non vedete niente nel grafico, selezionate il giorno 23 maggio che la stazione è staccata da stamattina....
Ultima Modifica 8 Anni 6 Mesi fa da SkizZO.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa - 8 Anni 6 Mesi fa #821 da tony
Grande :-)

Ora sto lavorando ad una App Android .. quasi pronta.

Intanto questa è una versione di swpi_smartphone.html con le unità di misura automatiche.


Allegato swpi_smartphone_2013-05-24.zip non trovato



Non mi hai risposto ( o mi è sfuggito ) se hai intenzione di usare anche la chiavetta telefonica ?
Allegati:
Ultima Modifica 8 Anni 6 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #822 da SkizZO
no niente chiavetta per il momento, ho però un pluviometro della ws23xx che quasi quasi.......

Per ora voglio perfezionare/ottimizzare il tutto, poi ho tutto pronto per costruire la seconda (e lo farò ad occhio in 4 giorni, ho anche l'mcp già saldato e testato, e tutti i pezzi) che a quanto pare già ha trovato una "casa di appoggio" :D dunque niente pannelli e chiavette per il momento.

Si prega Accedi a partecipare alla conversazione.

Di più
8 Anni 6 Mesi fa #823 da tony
Purtroppo il pluviometro da solo .. non è ancora supportato.

Si prega Accedi a partecipare alla conversazione.

Tempo creazione pagina: 0.884 secondi