× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Oregon WMR88 e Sint Wind PI

More
8 years 11 months ago #2624 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
si metto WMR100

Please Log in to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #2625 by alegrechi
Allora provate a abilitare un po' di log.

Scaricate il file che vi allego e sostituitelo al sensor_wmr100.py che usate (prima fatene una copia!). Poi riavviate swpi.
Guardate il log in consolle e vedrete diverse info in più sui dati ricevuti.


Attachment sensor_wmr100.py.zip not found

Attachments:
Last edit: 8 years 11 months ago by alegrechi. Reason: Cambio allegato

Please Log in to join the conversation.

More
8 years 11 months ago #2627 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
help....
mi collego da teminale al rasberry...
usando ubuntu
che comandi devo dare?

Please Log in to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #2629 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
scusa non mi fa scaricare il file...
sensor_wmr100.py
Last edit: 8 years 11 months ago by oss.

Please Log in to join the conversation.

More
8 years 11 months ago #2630 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
il file systeminfo.php l'ho inserito...

Please Log in to join the conversation.

More
8 years 11 months ago #2632 by iw7eex
Replied by iw7eex on topic Oregon WMR88 e Sint Wind PI
iw7eex.altervista.org/swpi/systeminfo.php

Inizio a credere che ci siano problemi sul database..

Please Log in to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #2633 by roberto2011
si infatti
www.vololiberoserrasanta.it/images/sint/systeminfo.php

mancano anche molti dati nel file meteo.txt

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Last edit: 8 years 11 months ago by roberto2011.

Please Log in to join the conversation.

More
8 years 11 months ago #2635 by iw7eex
Replied by iw7eex on topic Oregon WMR88 e Sint Wind PI
Niente da fare.. ragazzi io mi arrendo. Le mie limitate conoscenze non mi permettono di capire il perchè di questo sfasamento tra stazione e swpi. Ho reinstallato tutto. Server e db. Non so più cosa pensare.

iw7eex.altervista.org/swpi/systeminfo.php

Please Log in to join the conversation.

More
8 years 11 months ago #2636 by alegrechi

oss wrote: scusa non mi fa scaricare il file...
sensor_wmr100.py

Ho cambiato l'allegato, ora è uno zip col file dentro.

@iw7eex questo systeminfo che hai postato contiene i dati corretti?

In ogni caso con l'allegato che ho messo potete vedere nel log molti più dati che ricevete dalla stazione. Magari ci aiuta ad identificare dove è il problema!

Please Log in to join the conversation.

More
8 years 11 months ago #2639 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
ecco cosa esce con il systeminfo.php
meteocevedale.altervista.org/systeminfo.php

Please Log in to join the conversation.

More
8 years 11 months ago #2640 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI

alegrechi wrote:

oss wrote: scusa non mi fa scaricare il file...
sensor_wmr100.py

Ho cambiato l'allegato, ora è uno zip col file dentro.

@iw7eex questo systeminfo che hai postato contiene i dati corretti?

In ogni caso con l'allegato che ho messo potete vedere nel log molti più dati che ricevete dalla stazione. Magari ci aiuta ad identificare dove è il problema!


ok scaricato lo zip...ma come faccio a caricarlo sul rasberry?
ciao

Please Log in to join the conversation.

More
8 years 11 months ago #2643 by roberto2011
errore nel nome della tabella adesso funziona !!

Attachment systeminfo_2013-11-28-4.zip not found


Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Attachments:
The following user(s) said Thank You: iw7eex

Please Log in to join the conversation.

More
8 years 11 months ago #2645 by iw7eex
Replied by iw7eex on topic Oregon WMR88 e Sint Wind PI
iw7eex.altervista.org/swpi/systeminfo.php

ok grazie mille ora funge.
Fatto sta che la velocità del vento continua a non combaciare tra stazione e swpi..

Please Log in to join the conversation.

More
8 years 11 months ago #2646 by roberto2011
C'e' qualcosa che non va nel driver come aveva suggerito Ale.

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Please Log in to join the conversation.

More
8 years 11 months ago #2647 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI

iw7eex wrote: iw7eex.altervista.org/swpi/systeminfo.php

ok grazie mille ora funge.
Fatto sta che la velocità del vento continua a non combaciare tra stazione e swpi..

te sei riuscito a copiare il file sulla raspberry sensor_wmr100.py? postato da alegrechi?
io non so come fare...sigh sigh sigh

Please Log in to join the conversation.

More
8 years 11 months ago #2648 by roberto2011
Collegati al raspberry tramite ssh.
con questo programma
mobaxterm.mobatek.net/download.html

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Please Log in to join the conversation.

More
8 years 11 months ago #2651 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
uso ubuntu..al rasberry mi collego già tramite ssh ma purtroppo non so i comandi per copiarci dentro i file...

Please Log in to join the conversation.

More
8 years 11 months ago #2652 by tony
Replied by tony on topic Oregon WMR88 e Sint Wind PI
usa filezilla usando il protocollo SFTP . E' il metodo più semplice.

Please Log in to join the conversation.

More
8 years 11 months ago #2653 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
lo farei pure....ma non so come fare..hehhe
filezilla lo uso ma per collegarmi al database esterno...
come lo configuro per accedere al rasberry?

Please Log in to join the conversation.

More
8 years 11 months ago #2654 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
ok risolto messo i dati ip del rasberry locale...
e poi inserito user e pw
sono dentro....

Please Log in to join the conversation.

More
8 years 11 months ago #2655 by alegrechi
Ora fai una copia del file sensor e sovrascrivilo con quello che hai scaricato.
Poi riavvia swpi e posta il log

Please Log in to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #2656 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
questo il log dopo il riavvio
[28/11/2013-16:38:38] Starting SINT WIND PI ...

10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[28/11/2013-16:38:57] Checking internet connetion ...
[28/11/2013-16:38:57] Starting sensor reading - Sensor type is : WMR100
[28/11/2013-16:38:57] Thread started
[28/11/2013-16:38:57] USB initialization
[28/11/2013-16:38:57] USB WMR100 found
[28/11/2013-16:38:57] USB WMR100 open
[28/11/2013-16:38:57] USB WMR100 initialized
[28/11/2013-16:38:57] Internet ok
[28/11/2013-16:38:57] Checking internet connetion ...
[28/11/2013-16:38:57] Internet ok
[28/11/2013-16:38:57] Connected with IP : 79.16.104.13
[28/11/2013-16:38:57] Config Server running on port 80
[28/11/2013-16:38:57] Starting General WatchDog
gio 28 nov 2013, 16.39.12, CET
[28/11/2013-16:39:12] System time adjusted from NPT server : europe.pool.ntp.org
[28/11/2013-16:39:51] Temp Battery Ok: True Sensor thInt Temperature: 24.1 C (Rising), Humidity: 40 % (Good, Falling), Dew Point: 10 C
[28/11/2013-16:40:01] Clock 28/11/2013 16:40, power: 1, Powered: True, Battery: True, RF: True
[28/11/2013-16:40:23] Barometer Forecast: Cloudy, Absolute pressure: 959.0 mb, Sea Level Pressure: 1026.0
[28/11/2013-16:40:31] Rain Battery Ok: True Rate 0, This Hr 0, This Day 0, Total 2913.89 since 2009/ 1/ 1 12: 1
[28/11/2013-16:40:32] Calculating Meteo data and statistics
[28/11/2013-16:40:33] loading plugins
[28/11/2013-16:40:34] No digital cameras found
[28/11/2013-16:40:34] Checking internet connetion ...
[28/11/2013-16:40:34] Internet ok
[28/11/2013-16:40:34] Logging data ...
[28/11/2013-16:40:34] Data sent to server : OK
[28/11/2013-16:40:34] Logging data to Wunderground ...
[28/11/2013-16:40:35] Log to Wunderground : success
[28/11/2013-16:40:35] Uploading data ...
[28/11/2013-16:40:36] Rereading config file ..
[28/11/2013-16:40:36] Disk space left = 853749760
[28/11/2013-16:40:36] Sleeping 598 seconds
gio 28 nov 2013, 16.40.37, CET
[28/11/2013-16:40:37] System time adjusted from NPT server : europe.pool.ntp.org
[28/11/2013-16:40:37] Sent file to server : meteo.txt
[28/11/2013-16:40:37] Deleted file : ./meteo.txt
[28/11/2013-16:40:47] Logging data to Database
[28/11/2013-16:40:47] Dir: NE - Spd: 0.9 - Gst: 0.9 - Tin: 24.1 - Hin: 40.0 - P: 1017 - Rtot: 2913.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0
[28/11/2013-16:40:47] Wind Battery Ok: False direction: 2 (45/NE), gust: 0.9 m/s, avg. speed: 0.9 m/s
[28/11/2013-16:40:47] Temp Battery Ok: True Sensor th1 Temperature: 0.5 C (Falling), Humidity: 49 % (-, Rising), Dew Point: -9 C
[28/11/2013-16:41:00] Calculating Meteo data and statistics
[28/11/2013-16:41:13] Logging data to Database
[28/11/2013-16:41:13] Dir: NE - Spd: 0.0 - Gst: 0.0 - Tout: 0.5 - Tin: 24.1 - Hout: 49.0 - Hin: 40.0 - P: 1017 - Rtot: 2913.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 1654
[28/11/2013-16:41:13] Wind Battery Ok: False direction: 2 (45/NE), gust: 0 m/s, avg. speed: 0 m/s
[28/11/2013-16:41:13] Clock 28/11/2013 16:41, power: 1, Powered: True, Battery: True, RF: True
[28/11/2013-16:41:23] Barometer Forecast: Cloudy, Absolute pressure: 959.0 mb, Sea Level Pressure: 1026.0
Last edit: 8 years 11 months ago by oss.

Please Log in to join the conversation.

More
8 years 11 months ago #2657 by iw7eex
Replied by iw7eex on topic Oregon WMR88 e Sint Wind PI
OSS scusa son tornato ora e non ho avuto modo di risponderti.

Il mio Log recita così:

[28/11/2013-16:42:34] System time adjusted from NPT server : europe.pool.ntp.org
[28/11/2013-16:42:35] Sent file to server : meteo.txt
[28/11/2013-16:42:35] Deleted file : ./meteo.txt
[28/11/2013-16:42:59] Temp Battery Ok: True Sensor thInt Temperature: 17.9 C (Steady), Humidity: 54 % (-, Steady), Dew Point: 9 C
[28/11/2013-16:43:01] Barometer Forecast: Cloudy, Absolute pressure: 1017.0 mb, Sea Level Pressure: 1017.0
[28/11/2013-16:43:02] Calculating Meteo data and statistics
[28/11/2013-16:43:08] Temp Battery Ok: True Sensor th1 Temperature: 9.3 C (Steady), Humidity: 94 % (Fair, Steady), Dew Point: 9 C
[28/11/2013-16:43:39] Calculating Meteo data and statistics
[28/11/2013-16:44:04] Barometer Forecast: Cloudy, Absolute pressure: 1017.0 mb, Sea Level Pressure: 1017.0
[28/11/2013-16:44:06] Calculating Meteo data and statistics
[28/11/2013-16:44:11] Last main Thread delay ratio: 1.0

Please Log in to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #2658 by roberto2011
Tony non sbaglia mai! quindi sicuramente sbaglio io :)
file sensor_wmr100.py riga 355 e 356
io eliminerei 0.1 *
avgSpeed =  ((record[6] << 4) + ((record[5]) >> 4))
gustSpeed = (((record[5] & 0x0F) << 8) + record[4])

Attachment not found


Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Last edit: 8 years 11 months ago by roberto2011.

Please Log in to join the conversation.

More
8 years 11 months ago #2660 by alegrechi
Si dal log si vede che il gust ed il wind avg sono sempre uguali.

Il problema credo che sia proprio intorno alle righe che ha segnalato roberto.

Sul moltiplicatore 0.1: ma non vi tornano nè il valore di gust nè quello del vento con la stazione?

Il vero problema è che gustSpeed e avgSpeed restituiscono lo stesso valore...

Ho inserito un'altra riga di log... provate questa versione.

Attachment sensor_wmr100.py_2013-11-28.zip not found

Attachments:

Please Log in to join the conversation.

More
8 years 11 months ago #2661 by tony
Replied by tony on topic Oregon WMR88 e Sint Wind PI
Vedo che siete al pezzo di brutto :-)
Purtroppo ho dimenticato la chiavetta USB col codice e sinceramente non ricordo quei passi. Domani gli do una occhiata anche io.

Please Log in to join the conversation.

More
8 years 11 months ago #2663 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
che posso dire....grazie per il vostro aiuto...non vi conosco ma l'impressiono è che siate tutti bravi ragazzi.
grazie ancora per l'aiuto.

Please Log in to join the conversation.

More
8 years 11 months ago #2665 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI

alegrechi wrote: Si dal log si vede che il gust ed il wind avg sono sempre uguali.

Il problema credo che sia proprio intorno alle righe che ha segnalato roberto.

Sul moltiplicatore 0.1: ma non vi tornano nè il valore di gust nè quello del vento con la stazione?

Il vero problema è che gustSpeed e avgSpeed restituiscono lo stesso valore...

Ho inserito un'altra riga di log... provate questa versione.

Attachment sensor_wmr100.py_2013-11-28.zip not found


quando ho caricato il tuo file sensor non mi si avviava più swpi dando questi errori:

Traceback (most recent call last):
File "swpi.py", line 24, in <module>
import sensor_thread
File "/home/pi/swpi/sensor_thread.py", line 33, in <module>
import sensor_wmr100
File "/home/pi/swpi/sensor_wmr100.py", line 361
self._report_wind(dir, dirDeg, dirStr, gustSpeed, avgSpeed)
^
SyntaxError: invalid syntax

quando ho caricato qello di roberto invece mi partiva swpi ma poi si legge:

***********************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[28/11/2013-21:12:49] Checking internet connetion ...
[28/11/2013-21:12:49] Starting sensor reading - Sensor type is : WMR100
[28/11/2013-21:12:49] Thread started
[28/11/2013-21:12:49] USB initialization
[28/11/2013-21:12:49] USB WMR100 found
[28/11/2013-21:12:49] USB WMR100 open
[28/11/2013-21:12:49] USB WMR100 initialized
[28/11/2013-21:12:49] Internet ok
[28/11/2013-21:12:49] Checking internet connetion ...
[28/11/2013-21:12:49] Internet ok
[28/11/2013-21:12:49] Connected with IP : mio ip

[28/11/2013-21:12:49] Config Server running on port 80
[28/11/2013-21:12:50] Starting General WatchDog
gio 28 nov 2013, 21.13.19, CET
No handlers could be found for logger "station.wms100"
[28/11/2013-21:13:19] System time adjusted from NPT server : europe.pool.ntp.org
[28/11/2013-21:13:48] Temp Battery Ok: True Sensor thInt Temperature: 18.3 C (Steady), Humidity: 50 % (-, Steady), Dew Point: 8 C
[28/11/2013-21:14:00] Rain Battery Ok: False Rate 0, This Hr 0, This Day 0, Total 2913.89 since 2009/ 1/ 1 12: 1
[28/11/2013-21:14:01] Clock 28/11/2013 21:14, power: 1, Powered: True, Battery: True, RF: True
^CTraceback (most recent call last):
File "swpi.py", line 794, in <module>
time.sleep(1)
KeyboardInterrupt


spero che siano informazioni a voi utili

Please Log in to join the conversation.

More
8 years 11 months ago #2666 by roberto2011
Prova il mio file.
Ale ha esagerato con i log :)

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Please Log in to join the conversation.

More
8 years 11 months ago #2667 by oss
Replied by oss on topic Oregon WMR88 e Sint Wind PI
ok mo riprovo....
mi faresti un altro favore? mi passeresti il file
sensor_wmr100.pyc erroneamente l'ho cancellato...azz

Please Log in to join the conversation.

Time to create page: 0.549 seconds