× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

lightbulb RFM01

  • fabiomarzaduri
  • fabiomarzaduri's Avatar
  • Visitor
  • Visitor
9 years 3 months ago #5549 by fabiomarzaduri
Replied by fabiomarzaduri on topic RFM01
Buongiorno.
Dopo mesi di prove con il modulo rfm01, in cui non ho mai ricevuto nemmeno un pacchetto di dati corretto, ho deciso di provare con il modulo Aurel 868, seguendo lo schema proposto.
Nemmeno con questo ho fin'ora ricevuto nulla: ogni 48 secondi, ad ogni lampeggio del led sul trasmettitore della stazione meteo, ricevo solamente un BAD DATA RECEIVED FROM RFM01.
Sono demoralizzato perchè, evidentemente, mi sfugge qualcosa di macroscopico...
Grazie per l'aiuto...

Please Log in to join the conversation.

More
9 years 3 months ago #5550 by pierpis
Replied by pierpis on topic RFM01
Quindi non potrei neanche provvisoriamente collegare la consolle?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
9 years 3 months ago #5551 by pierpis
Replied by pierpis on topic RFM01

fabiomarzaduri wrote: Buongiorno.
Dopo mesi di prove con il modulo rfm01, in cui non ho mai ricevuto nemmeno un pacchetto di dati corretto, ho deciso di provare con il modulo Aurel 868, seguendo lo schema proposto.
Nemmeno con questo ho fin'ora ricevuto nulla: ogni 48 secondi, ad ogni lampeggio del led sul trasmettitore della stazione meteo, ricevo solamente un BAD DATA RECEIVED FROM RFM01.
Sono demoralizzato perchè, evidentemente, mi sfugge qualcosa di macroscopico...
Grazie per l'aiuto...

Ma è lo stesso che ho montato io?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

  • fabiomarzaduri
  • fabiomarzaduri's Avatar
  • Visitor
  • Visitor
9 years 3 months ago #5552 by fabiomarzaduri
Replied by fabiomarzaduri on topic RFM01
Si si, lo stesso che avete montato voi...
premetto che sono mesi che faccio prove con l'rfm01, e nemmeno con quello ho mai ricevuto un solo pacchetto valido!!
boh...

Please Log in to join the conversation.

More
9 years 3 months ago #5553 by Ik3max
Replied by Ik3max on topic RFM01
Visto che ultimamente si è generato un pò di confusione riguardo ai collegamenti del ricevitore RX-AM8SF e relative modifiche, ho pensato di ridisegnare il circuito elettrico definitivo, aggiungendo anche il modulo BMP085.
Spero che in questo modo di dissipare molti dubbi almeno per quanto riguarda il cablaggio elettrico.
Ciao a tutti da Giampietro
Attachments:

Please Log in to join the conversation.

More
9 years 3 months ago #5554 by pierpis
Replied by pierpis on topic RFM01
Fantastico Ik3max, mi serviva proprio per aggiungere il BMP085 (che stò già ordinando)
Fabio, io non sarei proprio quello da prendere per esempio, ma se ti riguardi le foto vedrai sarà molto facile, quello che sò per la mia esperienza sono disponibile a dirti come ho fatto.... ma abbiamo qui chi ne sa anche moooolto più di me e mi hanno aiutato tantissimo.

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #5555 by Ik3max
Replied by Ik3max on topic RFM01
Ciao Fabio, ho visto che sei stato colpito dalla sfiga più nera ultimamente!!! :sick:
Sai è difficile darti una dritta in queste condizioni.... prova a verificare il cablaggio, poi come avevo suggerito a pierpis per essere sicuro di avere un buon segnale, prendi la tua PCE e posizionala vicino al ricevitore (un paio di metri) per fare le prove di ricezione.
Prova se hai un tester a verificare se le alimentazioni +5V e +3,3V sono corrette, ed infine verifica le configurazioni ....anche quelle sono importanti!!!
Se neanche così non riesci... :dry: ...posso solo pensare al Raspberry difettoso o la PCE.
Ciao Giampietro
Last edit: 9 years 3 months ago by Ik3max.

Please Log in to join the conversation.

  • fabiomarzaduri
  • fabiomarzaduri's Avatar
  • Visitor
  • Visitor
9 years 3 months ago #5558 by fabiomarzaduri
Replied by fabiomarzaduri on topic RFM01
Ciao IK3MAX, e grazie per la risposta.
Ho provato con 2 raspy differenti, ho provato con 3 modulini rfm01 differenti, ho provato a spostare la PCE fino a 50 cm dal ricevitore (l'installazione originale era comunque a 5/6 metri di distanza)...
Cablaggi e tensioni sono la prima cosa che ho verificato...
Ho il dubbio che possa trattarsi di un problema di cfg ma, effettivamente, non è che ci sia poi la possibilità di cambiare molti parametri...
Boh, sono scoraggiato, ma continuerò a provare...
Grazie a tutti, Fabio IK4XQH

Please Log in to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #5559 by tony
Replied by tony on topic RFM01
RFM01 può ricevere male ma deve ricevere qualcosa al primo colpo.
Se hai fatto molte prove diverse e non funziona vuol dire che commetti sempre lo stesso errore.
Rivedi i collegamenti e per ora lascia stare la configurazione e usa il programmino di test.
TT
Last edit: 9 years 3 months ago by tony.

Please Log in to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #5560 by Ik3max
Replied by Ik3max on topic RFM01
Ciao Fabio, do sicuramente ragione a Tony, stai commettendo un errore banale che quando lo scoprirai batterai la testa contro il muro. :ohmy:
Come ultima risorsa, ti invio la configurazione del mio Raspy, spero che all'interno troverai qualcosa di utile per risolvere il tuo problema.
Ciao Giampietro
Attachments:
Last edit: 9 years 3 months ago by Ik3max.

Please Log in to join the conversation.

  • fabiomarzaduri
  • fabiomarzaduri's Avatar
  • Visitor
  • Visitor
9 years 3 months ago #5561 by fabiomarzaduri
Replied by fabiomarzaduri on topic RFM01
Grazie Tony, grazie ik3max...
La maggiora parte delle prove l'ho fatta proprio con il programmino incluso wh1080_rf, anche perchè mi era molto più semplice e immediato...
Sono sicuro di sbagliare qualcosa di banale, anche perchè vedo che vi funziona a tutti al primo colpo, a meno che non sia un problema di fw dei miei due raspy (un modello A e un modello B+)..
Confronterò anche la cfg, anche se non andando nemmeno con il programma wh1080_rf non ho molte speranza, in quanto questo programma non va a leggere i parametri di swpi...
Però mi sento un po' stressato :-) :-)
Grazie ancora a tutti, fabio

Please Log in to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #5562 by pierpis
Replied by pierpis on topic RFM01
No eBay APP ID défined in Kunena configurationBuongiorno a tutti, stò cercando in rete il sensore per la pressione BMP085 per inserirlo nella mia stazione, ma questo che vi allego.... è lui?


Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Attachments:
Last edit: 9 years 3 months ago by pierpis.

Please Log in to join the conversation.

More
9 years 3 months ago #5563 by Roberto Vaccaro
Replied by Roberto Vaccaro on topic RFM01
Si è lui

Please Log in to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #5564 by pierpis
Replied by pierpis on topic RFM01
Opsss.... aggiornamento a singhiozzo, il modulino fa le bizze :(

Mi sono ritrovato l'aggiornamento a 30 ore fa :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Attachments:
Last edit: 9 years 3 months ago by pierpis.

Please Log in to join the conversation.

More
9 years 2 months ago #5566 by tony
Replied by tony on topic RFM01
Devi tarare un po con i parametri -l e -r
TT

Please Log in to join the conversation.

More
9 years 2 months ago #5567 by pierpis
Replied by pierpis on topic RFM01

tony wrote: Devi tarare un po con i parametri -l e -r
TT


:S :S :S ????

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

  • fabiomarzaduri
  • fabiomarzaduri's Avatar
  • Visitor
  • Visitor
9 years 2 months ago #5568 by fabiomarzaduri
Replied by fabiomarzaduri on topic RFM01
Il modulo Aurel non è programmabile, quindi la modifica dei parametri rssi e lna non ha effetto...

pierpis wrote:

tony wrote: Devi tarare un po con i parametri -l e -r
TT


:S :S :S ????

Please Log in to join the conversation.

More
9 years 2 months ago #5569 by tony
Replied by tony on topic RFM01
Per l aurel aprite un post dedicato altrimenti facciamo confusione
TT

Please Log in to join the conversation.

  • fabiomarzaduri
  • fabiomarzaduri's Avatar
  • Visitor
  • Visitor
9 years 2 months ago #5576 by fabiomarzaduri
Replied by fabiomarzaduri on topic RFM01
Sono finalmente arrivato alla fine del mio calvario con i moduli radio.
La settimana scorsa mi ero rassegnato a lasciare il display collegato usb al raspy, e stavo studiando un contenitore da esterno per entrambi, e ho deciso di acquistare una seconda stazione completa e identica, sia per avere un secondo display da mettere in casa, che per avere un nuovo anemometro e un nuovo supporto del termometro, entrambi rotti dalla nevicata di febbraio. Appena arrivata la nuova stazione ho notato subito che il nuovo display non riceveva i sensori della mia vecchia stazione. Allora ho spento il vecchio tx e attivato il nuovo, collegando i vecchi sensori. In questa nuova situazione il nuovo display riceve correttamente, mentre il vecchio non riceve più. E da questo momento ho cominciato anche a ricevere i dati con i moduli rfm01 e aurel.
Subito ho pensato che la vecchia stazione fosse siglata a 868 mhz, ma in realtà fosse il modello a 434 mhz, e ricevevo su quella frequenza la prima armonica del segnale principale a 434, che quindi non decodificavo. Con l analizzatore di spettro però non ho trovato segnali in banda 434, a aprendo il vecchio display all'interno ho visto che viene utilizzato come ricevitore il modulo rfm01 della hoperf, il modello a 868 con il connettore,uguale a quello che avevo utilizzato io per le prove senza successo...
Quindi, in definitiva, il problema nasceva dalla stazione meteo, ma non l'ho ancora identificato precisamente...ci studierò ancora...
Dalle prime prove preferisco il modulo rfm01, che non ho trovato assolutamente critico nei settaggi come descritto qui sul forum, mentre il modulo aurel si é bloccato più volte nel corso delle prove, e ha richiesto numerosi riavvii del modulo.
Spero di essere stato utile a qualcuno, e vi ringrazio per l'aiuto che voi avete dato a me.
Grazie, Fabio

Please Log in to join the conversation.

More
9 years 1 month ago #5652 by pierpis
Replied by pierpis on topic RFM01
Non trovo lo schema di collegamento del modulino bmp085, chi può fornirlo?
Grazie

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
9 years 1 month ago #5653 by Roberto Vaccaro

Please Log in to join the conversation.

More
9 years 1 month ago #5657 by pierpis
Replied by pierpis on topic RFM01
Grazie Roberto per la tua disponibilità

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
9 years 1 month ago #5658 by pierpis
Replied by pierpis on topic RFM01
Ciao a tutti
Sono in difficoltà come al solito :( :(
il modulino bmp085 è diverso dallo schema che ha spedito Roberto e mi sono bloccato.
Potete aiutarmi per i collegamenti?
Allego foto (almeno quelle le sò fare ... come ha detto qualcuno :) )

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Attachments:

Please Log in to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #5662 by Roberto Vaccaro
Replied by Roberto Vaccaro on topic RFM01
Quello della foto è un BMP180.Dovrebbe andare ugualmente bene. Puoi collegarlo come da disegno allegato, eventualmente si può provare ad alimentarlo anche dai 3,3 Volt. Al posto dei 5 Volt

Attachment bmp180.jpg not found



Occhio che la disposizione dei pin di quello del disegno è diversa dal tuo. Tieni come riferimento i nomi
Attachments:
Last edit: 9 years 1 month ago by Roberto Vaccaro.

Please Log in to join the conversation.

More
9 years 1 month ago #5663 by pierpis
Replied by pierpis on topic RFM01
Il piedino 3 e 6 del rasp, sono occupati dall'altro modulo di ricezione, posso fare i collegamenti del + e del - in altri piedini?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
9 years 1 month ago #5664 by Roberto Vaccaro
Replied by Roberto Vaccaro on topic RFM01
Quale modulo ???
Mi pare che l'RFM01 e L'Aurel non usino il pin 3 (SDA).
Il 6 è il negativo (massa) ed è comune a tutti i moduli.

Poco più sopra IK3MAX nel post #5553 ha messo uno schema dove si vede chiaramente i collegamenti, anche quelli del BMP085

Controlla meglio

73 a IK3MAX de IW1PUR
The following user(s) said Thank You: pierpis

Please Log in to join the conversation.

More
9 years 1 month ago #5665 by pierpis
Replied by pierpis on topic RFM01
Grazie, funziona tutto!! :cheer: :cheer: :cheer:

E' bastato spostare il connettore dal 2o del rasp (credevo che la massa andava bene pure quella) Fatto saldatura sul n. 6 e funge tutto.

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

More
9 years 1 month ago #5683 by pierpis
Replied by pierpis on topic RFM01
Buongiorno
E' arrivato il momento di sostituire l'Aurel col RFM01 mi è stato spedito e come al solito (almeno per me) me lo sono ritrovato diverso da quello di Ale Grechi di cui ho preso buona visione delle foto e letture dal suo blog.
Ho difficoltà nei collegamenti percho mi è arrivato con i piedini e le posizioni di connessione sono diverse da quelle delle foto.
Qualcuno può darmi qualche indicazione?
Con l'Aurel stò accendendo e spegnendo in continuazione il Rasp.... penso che non sia una cosa favorevole.
Allego 2 foto

Attachment 2015-06-1311.03.38.jpg not found



Attachment 2015-06-1311.23.36.jpg not found


Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Attachments:

Please Log in to join the conversation.

More
9 years 1 month ago #5684 by Roberto Vaccaro
Replied by Roberto Vaccaro on topic RFM01

Please Log in to join the conversation.

More
9 years 1 month ago #5685 by pierpis
Replied by pierpis on topic RFM01
Bello, per un ingeniere elettronico è una pacchia.. :cheer: :cheer:

Scherzo, ho visto che nella pagina 4 dovrei reperire quello che mi serve.... speriamo bene :( :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Please Log in to join the conversation.

Time to create page: 0.725 seconds