× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Ho la stazione ferma!!!

Di più
2 Anni 6 Mesi fa #7257 da pierpis
Ho la stazione ferma!!! è stato creato da pierpis
:angry:
Come da titolo ho la mia stazione che si è fermata, dal giorno 18/9 che non si collega col ricevitore.
Stamattina ho voluto prendere in mano nuovamente la situazione che da più di un anno non mi ha dato motivi di allarmarmi.
Ho provveduto allo smontaggio del trasmettitore dallo schermo solare che avevo costruito, lo porto all'interno casa, pulisco e controllo le batterie ricaricabili, tutto a posto e rimetto le batterie nella sede, aspetto la famosa lucina rossa e parte normalmente, ogni 48/50 secondi si accende, quindi trasmette (volevo vedere.... nuovo di trinca)
Quindi penso sia il modulo RMF01 che si sia bloccato?
Controllo le saldature e connessioni, tutto a posto e tutto attaccato.
Come faccio a sapere che sia quel modulo che non funge?
Nel Rasp è normale il leddino verde (quello laterale) costantemente accende/spegne a ritmo costante?
Se c'è qualcuno che può rispondermi :( :(
Grazie

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7258 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Perchè non riesco ad entrare nella configurazione? Eppure ho preso il numero IP dalla schermata del router :( :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7262 da seven
Risposta da seven al topic Ho la stazione ferma!!!
Azz..
C'è da capire se il problema è la Raspberry o il trasmettitore/sensore:

hai la console originale della stazione meteo? Riceve i dati dal sensore?
Se si allora il problema è la Raspberry, molto probabilmente la scheda SD che ha fatto il grande salto. Il fatto che i led siano accesi purtroppo non significa che il sistema operativo sia davvero operativo... Se non riesci nemmeno ad entrare in configurazione come sintomi direi che ci siamo...

Prova a fare un'installazione da zero di SWPI su una SD diversa e vedi se riesci a ricevere i dati.
Ringraziano per il messaggio: pierpis

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7264 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Ti ringrazio della tua risposta, in pratica è tutto fermo a quello che avevo impostato circa 2 o 3 anni fa, Raspberry (credo) prima versione, la SD mai aggiornata, e con la sostituzione alla consolle PCE (perchè non funzionante) con ricevitore RFM01 e BPMo85.
Con l'aiuto dei moderatori sono riuscito a mettere su il tutto.
Ora avendo cambiato il trasmettitore della mia PCE (quindi nuovo) ho appurato che il segnalo lo manda e sono fermo su questo.
In considerazione della mia età :( non ricordo in pratica lo svolgimento del tutto, ma la voglia di rimettere in piedi l'apparato è tanta e non vorrei perderla.
Vi prego datemi una mano a capire quale elemento della strumentazione non funziona.
Vi ringrazio

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa - 2 Anni 6 Mesi fa #7265 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Son voluto ripartire da capo per capirci nuovamente qualcosa,
Ho riattaccato un monitor al raspberry e ho notato che il sistema operativo parte, arriva alla maschera del SWPI tarda qualche secondo e poi parte ma credo con scritte anomale..... si spegne tutto e riparte col sistema operativo e ripete tutto all'infinito.... che cosa succede???

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Allegati:
Ultima Modifica 2 Anni 6 Mesi fa da pierpis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa - 2 Anni 6 Mesi fa #7267 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Ho scaricato Il file SWPI_845.rar devo scompattarlo? Se si, metto tutti i file e le cartelle dentro la SD?
I file che attualmente sono dentro la SD che fine fanno?
Gran confusione :(

PS:
Ma il file scaricato è nominato "ultimi_dati" ??

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Ultima Modifica 2 Anni 6 Mesi fa da pierpis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa - 2 Anni 6 Mesi fa #7268 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
Pierpis mi sa che dovrai rileggerti un pò di post arretrati ma soprattutto la sezione Documentation.....

cmq una volta scaricata l'immagine devi scompattarla e scriverla su una SD (a questo punto ti consiglio di prenderne una nuova) e poi riparti con la configurazione

vediamo dove arrivi altrimenti scrivi qua che qualcuno ti darà una mano di sicuro.


semmai ricordati di allegare il file di configurazione omettendo le password o qualche schermata di errore per capire meglio....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 2 Anni 6 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7269 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Oggi tutto il giorno aleggere, avevo fatto tutto 3 anni fa e..... la memoria non è più quella di una volta :( però quello che ricordo è che avevo scaricato un file immagine, ora mi trovo con un aggiornamento .rar
vabbè, domani riinizio a smanettare come ho fatto oggi, speriamo bene :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7270 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Buongiorno,
Oggi di buona mattina ho deciso di rileggere la sezione Documentation come mi ha consigliato asy961 e la parte che forse interessa il mio problema è Sint Wind PI - Raspberry PI.

Premetto che ho un Raspberry Pi mod.B 512 MB e scheda SD da 8 giga, connesso al rasp ho il RFM01 + BMP085

Detto ciò, leggo tutta la descrizione scaricando dalla sezione Download il file preso da qui: mega.nz/#!yUoXSTaR!iTsJwsZHwdb34xdECWrq7Fba74FxG0bYjYymcXPk8oE
e scompattandolo nel mio pc, mi accorgo però che non è una immagine ma una cartella con estensione.rar
Ho formattato la scheda SD eliminando tutti i dati precedenti.

Ora, come consigliato ho pure scaricato Win32DiskImager per il trasferimento dei dati alla Sd, ma Win32DiskImager mi porta alla ricerca di una immagine che non c'è.

Dove sto sbagliando e cosa non ho capito?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7271 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
Pierpis
i file con estensione .rar sono file compressi, lo devi scompattare e ti ritroverai con l'immagine da scrivere sulla SD, se usi un PC o Portatile con sistema operativo Windows ti consiglio il software 7zip lo trovi qui www.7-zip.org/
capace di lavorare con molti tipi di compressione, e comunque ti consiglio di usare anche una scheda SD nuova....non si sa mai

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa - 2 Anni 6 Mesi fa #7272 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Ho già nel mio computer lo scompattatore per i rar, ma non mi da un'immagine, mi da una cartella con i file dentro (come ha fatto sempre quando scompatto i .rar)
Vorrei chiedere se va bene una micro SD con adattatore.
Comunque, devi credermi.... non si apre l'immagine una volta scompattato il file.

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Ultima Modifica 2 Anni 6 Mesi fa da pierpis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7273 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
non saprei dirti per il file .rar
prova a scaricare un'altra versione

per la micro SD dovrebbe andare bene anche se io preferisco la versione normale SD per evitare altri contatti.....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7274 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Buongiorno,
Ho scaricato il file swpi_832.rar e scompattandolo mi ha fornito una immagine :) :)
Ho voluto subito provare a scaricarla nella SD che ho sempre usato (sul momento non ne avevo altra) e dopo la formattazione ha caricato tutto il file senza problemi se non un primo messaggio prima di iniziare tipo "questa operazione potrebbe causare danni al supporto fisico"..... vabbè l'ho fatta lo stesso.
Inserita, vedo che parte tutto, compreso i dati della stazione che presumibilmente il raspberry sta ricevendo, però do uno sguardo al sito e vedo che l'aggiornamento non è avvenuto.
Dovrei guardare nella configurazione (pannello rosa) on line? Oppure il logger, il meteo.txt ??
Ho notato che anche weather underground non riceve i dati.

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Allegati:

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7275 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
Pierpis
le immagini di solito sono configurate in SIMULATE quindi i dati che vedi non sono quelli dalla tua stazione.....

devi fare di nuovo tutta la configurazione....

buon lavoro

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7276 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Grazie asy961
Be, se non altro qualcosa si smuove :lol:
Ora cerco di fare una configurazione, perchè effettivamente ora ho visto che è in SIMULATE, però ho notato che il database è fermo al 18/9/2016 alle ore 18:06 quindi presumo che bisogna far partire il DB.
Ora ricontrollo la configurazione :)
Grazie

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa - 2 Anni 6 Mesi fa #7277 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Situazione attuale:
Il database ha ricominciato ad aggiornare i dati, mi sono accorto che la pressione segna NULL, però ho configurato il mio BMP085 in true :( non so che abbia :(

weather underground ha ricominciato a segnare i miei dati ad esclusione della pressione.

Ma nel mio sito nulla, nada de nada :( :( :( :(
Non viene aggiornato il file swpi_dashboard_lcd.html che uso nel sito

:cheer: :cheer: :cheer: Trovato l'inghippo alla pressione, connettore di collegamento alla BMP085 lento e non faceva contatto :) :)

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Allegati:
Ultima Modifica 2 Anni 6 Mesi fa da pierpis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 6 Mesi fa #7278 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Ora l'unica cosa che non si aggiorna è il file swpi_dashboard_lcd.html

il meteo.txt funziona ed è visibile il funzionamento su weather underground

Se vado a vedere il vecchio sito (visibile su meteoportocervo.it menu Old Site)
Funziona tutto.

Che cavolo è successo al file che non si aggiorna?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7281 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
:( :( :( :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7282 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
Pierpis purtroppo devi configurare bene recuperando se possibile la vecchia configurazione....il problema sta li

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7283 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Ho riprovato mille volte cambiando sempre la configurazione, mi sembra configurato normale,
Ma qual'è il file che aggiorna il swpi_dashboard_lcd.html ?
Figurati che non si aggiorna neanche lo smartphone.
Eppure weather underground si sta aggiornando, quindi presumo che il file meteo.txt è a posto.
Cliccando sopra il file swpi_dashboard_lcd.html mi restituisce una pagina bianca, roba che non aveva mai fatto.
:( :( :(
Vi posso mostrare la mia config per vedere se secondo voi è a posto?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7284 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
posta il file swpi.cfg omettendo le password ovviamente

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa - 2 Anni 5 Mesi fa #7285 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Trovato :) :) in una cartella nel desktop

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)
Allegati:
Ultima Modifica 2 Anni 5 Mesi fa da pierpis.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7286 da Roberto Vaccaro
Il file swpi.cfg e sul raspberry.
Comunque la vecchia pagina non si aggiorna tramite il file meteo.txt ma da db.
Qui il file che serve è fermo al 18/09/2016.
www.meteoportocervo.it/swpi/meteo.txt
Questo mi fa pensare che tu non mandi o lo mandi in una posizione sbagliata il file meteo.txt.
Quindi controlla il file swpi.cfg sul raspberry.
Inoltre dovresti capire il problema anche dal log che puoi visualizzare sempre sul raspberry.

Devi collegarti con putty o con winscp al raspi oppure da web all'indirizzo del tuo raspberry

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7287 da Roberto Vaccaro
Desktop?
Quale?
Windows?

Devi trovarlo sul raspberry,
comunque l'errore potrebbe essere qui

[Upload]
upload_data = True
upload_folder = meteoportocervo.it/folder

"folder" ???? forse swpi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7288 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!

Roberto Vaccaro ha scritto: Desktop?
Quale?
Windows?

Devi trovarlo sul raspberry,
comunque l'errore potrebbe essere qui

[Upload]
upload_data = True
upload_folder = meteoportocervo.it/folder

"folder" ???? forse swpi

Ho scritto sul descktop perchè lo avevo salvato li, in pratica è quello che è attualmente nel rasp :)

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7289 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!

Roberto Vaccaro ha scritto: Il file swpi.cfg e sul raspberry.
Comunque la vecchia pagina non si aggiorna tramite il file meteo.txt ma da db.
Qui il file che serve è fermo al 18/09/2016.
www.meteoportocervo.it/swpi/meteo.txt
Questo mi fa pensare che tu non mandi o lo mandi in una posizione sbagliata il file meteo.txt.
Quindi controlla il file swpi.cfg sul raspberry.
Inoltre dovresti capire il problema anche dal log che puoi visualizzare sempre sul raspberry.

Devi collegarti con putty o con winscp al raspi oppure da web all'indirizzo del tuo raspberry


Roberto, ma come te lo spieghi che weather underground www.wunderground.com/personal-weather-st...hboard?ID=ISARDEGN61 si aggiorna costantemente?, ma loro non prendono il file meteo.txt?

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7290 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Roberto hai ragione, il file meteo.txt è fermo alla data del 18/9/2016 mentre il database è in continuo aggiornamento :( :(
Ma io dico, è mai possibile che da quando si è fermata la stazione si è sconfigurato tutto? Perchè manualmente io non avevo toccato nulla :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7292 da asy961
Risposta da asy961 al topic Ho la stazione ferma!!!
Pierpis, la stazione si è fermata perchè (molto probabilmente) ti si è guastata/corrotta la SD quindi perdendo tutti i dati....

Consiglio:
una volta ripristinato il tutto fatti un bel backup....
o almeno salvati il file swpi.cfg da qualche parte

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7293 da Roberto Vaccaro
Sul tuo sito non si è sconfigurato nulla.
E' il raspberry che non manda i dati giusti.
Avresti dovuto salvare il file swpi.cfg prima di rifare la sd.
Modifica la riga che ti ho evidenziato sopra.
Probabilmente risolvi

upload_folder = meteoportocervo.it/swpi/

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 5 Mesi fa #7295 da pierpis
Risposta da pierpis al topic Ho la stazione ferma!!!
Ho modificato, ma ancora sempre uguale :(

Sensori PCE-FWS20, DVB-T 820T2 SDR, BMP085, Raspberry Pi mod. B www.meteoportocervo.it (Abbiadori Porto Cervo - Arzachena - OT) 108 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.834 secondi