× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Raspberry PI Camera Board

Di più
4 Anni 11 Mesi fa #3940 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
dopo svariate prove ancora non funziona....sembra che si avvii regolarmente...

************************************************************************
* Sint Wind PI 01.21.79 *
* *
* 2012-2014 by Tonino Tarsi <Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[12/04/2014-20:14:10] loading plugins
[12/04/2014-20:14:10] Starting sensor reading - Sensor type is : PCE-FWS20
[12/04/2014-20:14:10] Config Server running on port 80
[12/04/2014-20:14:11] Detected : Dream Link WH1080 Weather Station / USB Missile Launcher
[12/04/2014-20:14:11] Trying to get time from WH1080. Please wait ...
[12/04/2014-20:14:12] sms reset

[12/04/2014-20:14:12] Modem Model : K3765
[12/04/2014-20:14:12] Revision : 11.126.03.06.00
[12/04/2014-20:14:12] Modem Serial Number : R07NAA1040100565
[12/04/2014-20:14:12] Pin Status : READY
[12/04/2014-20:14:12] Device Center : +393492000200 145
[12/04/2014-20:14:12] Signal quality : 18
[12/04/2014-20:14:12] Checking new sms messages...
[12/04/2014-20:14:12] Checking internet connetion ...
[12/04/2014-20:14:12] No Internet
[12/04/2014-20:14:12] Trying to connect to internet with 3G dongle ....
[12/04/2014-20:14:15] Waiting for a valid IP ...
[12/04/2014-20:14:16] No IP yet. Retrying ..59
[12/04/2014-20:14:18] No IP yet. Retrying ..58
[12/04/2014-20:14:20] No IP yet. Retrying ..57
[12/04/2014-20:14:24] sms reset
[12/04/2014-20:14:24] Checking internet connetion ...
[12/04/2014-20:14:24] Internet ok
[12/04/2014-20:14:25] Connected with IP : 91.253.102.220
[12/04/2014-20:14:25] [12/04/2014-20:14:25]SunHalter: System will Halt in 160.0 seconds
Starting General WatchDog
sab 12 apr 2014, 20.16.00, CEST
[12/04/2014-20:16:00] System time adjusted from WH1080
[12/04/2014-20:16:30] Calculating Meteo data and statistics
[12/04/2014-20:16:43] Logging data to Database
[12/04/2014-20:16:43] Dir: SW - Spd: 0.0 - Gst: 0.648 - Tout: 16.8 - Tin: 23.7 - Hout: 73.0 - Hin: 61.0 - P: 1013 - Rtot: 63.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 593



ma quando scatta la foto si blocca qualcosa....



[12/04/2014-20:16:45] CameraPI - Using Dayligth settings-n -w 1024 -h 768 -ex auto -ev -5 -mm average
[12/04/2014-20:16:49] Waiting for a valid IP ...
[12/04/2014-20:16:49] No IP yet. Retrying ..59
[12/04/2014-20:16:51] Processing image :./img/raspi_12042014-201645.jpg
[12/04/2014-20:16:51] No IP yet. Retrying ..58
[12/04/2014-20:16:52] Processed image :./img/raspi_12042014-201645.jpg
[12/04/2014-20:16:52] Checking internet connetion ...
[12/04/2014-20:16:52] No Internet
[12/04/2014-20:16:52] Checking internet connetion ...
[12/04/2014-20:16:52] No Internet
[12/04/2014-20:16:52] Error. Non internet connection available
[12/04/2014-20:16:57] No IP yet. Retrying ..57
[12/04/2014-20:17:03] No IP yet. Retrying ..56
[12/04/2014-20:17:09] No IP yet. Retrying ..55
[12/04/2014-20:17:15] No IP yet. Retrying ..54
[12/04/2014-20:17:21] No IP yet. Retrying ..53
[12/04/2014-20:17:23] No IP yet. Retrying ..52
[12/04/2014-20:17:25] No IP yet. Retrying ..51
[12/04/2014-20:17:27] No IP yet. Retrying ..50
[12/04/2014-20:17:29] No IP yet. Retrying ..49
[12/04/2014-20:17:30] ERROR with PCE-FWS20 pywws.device_cython_hidapi.USBDevice.read_data failed . Will retry ...
[12/04/2014-20:17:31] No IP yet. Retrying ..48
[12/04/2014-20:17:31] Detected : Dream Link WH1080 Weather Station / USB Missile Launcher
[12/04/2014-20:17:32] Calculating Meteo data and statistics
[12/04/2014-20:17:33] No IP yet. Retrying ..47
[12/04/2014-20:17:35] No IP yet. Retrying ..46
[12/04/2014-20:17:37] No IP yet. Retrying ..45
[12/04/2014-20:17:39] No IP yet. Retrying ..44
[12/04/2014-20:17:41] No IP yet. Retrying ..43
[12/04/2014-20:17:43] No IP yet. Retrying ..42
[12/04/2014-20:17:45] Logging data to Database
[12/04/2014-20:17:45] Dir: SW - Spd: 0.648 - Gst: 1.512 - Tout: 16.7 - Tin: 23.8 - Hout: 73.0 - Hin: 61.0 - P: 1013 - Rtot: 63.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 593
[12/04/2014-20:17:45] No IP yet. Retrying ..41
[12/04/2014-20:17:47] No IP yet. Retrying ..40
[12/04/2014-20:17:49] No IP yet. Retrying ..39
[12/04/2014-20:17:51] No IP yet. Retrying ..38
[12/04/2014-20:17:53] No IP yet. Retrying ..37
[12/04/2014-20:17:55] Halting system ..
[12/04/2014-20:17:55] No IP yet. Retrying ..36


oltre la chiavetta si blocca anche la PCE....


allego anche le foto della shell dove si vede cosa succede...




Allegato 20140412_200704.jpg non trovato



Allegato 20140412_200649.jpg non trovato



Allegato 20140412_200628.jpg non trovato



Allegato 20140412_200614.jpg non trovato



Allegato 20140412_200559.jpg non trovato



Allegato 20140412_200546.jpg non trovato



Allegato 20140412_200532.jpg non trovato



Allegato 20140412_200514.jpg non trovato


Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3941 da tony
Risposta da tony al topic Raspberry PI Camera Board
Con
alwaisoninternet = True
cosa succede ??

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3942 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
non cambia niente.... :-(

se scollego la camera PI, imposto cameraPI = False
funziona alla grande....invia i dati senza mai fermarsi...

ma come ricollego la CameraPI e imposto su True ritorna a bloccarsi tutto....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3943 da tony
Risposta da tony al topic Raspberry PI Camera Board
E se usi i comandi della cameraPI con swpi spento funziona la camera ?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3944 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
la camera scatta la foto....nella sd trovo le foto scattate...


raspistill -d la camera si attiva, vedo immagine sullo schermo


allego swpi.cfg

[General]
station_name = Sint Wind ALTA TENSIONE - PIZZORNE
config_web_server = True
set_sistem_time_from_ntp_server_at_startup = False
ntp_server = europe.pool.ntp.org
reboot_at = None
shutdown_at = None
shutdown_hour_before_sunset = -0.5
location_latitude = 43.351983
location_longitude = 12.743187
location_altitude = 0.0
wifi_reset_if_down = False
config_web_server_port = 80
cloudbase_calib = 1.0
set_time_at_boot = None
wind_speed_units = kmh
ntp_url = None

[Dongle]
usedongle = True
alwaysoninternet = False
donglectrlport = /dev/ttyUSB2
dongleaudioport = /dev/ttyUSB1
dongledataport = /dev/ttyUSB0
usedonglenet = True
operator = tre
prober_timeout = 2.0
modem_baudrate = 460800
audio_baudrate = 115200
ctrl__baudrate = 9600
dialnum = *99#
pppd_path = /usr/sbin/pppd

[Security]
smspwd = admin

[DataLogging]
logdata = True
serverfile = www.sintwindaltatensione.altervista.org/swpi/swpi_logger.php

[Upload]
upload_data = False
upload_folder = /swpi

[Sensors]
sensor_type = PCE-FWS20
davis_error = 0
use_wind_sensor = True
number_of_measure_for_wind_dir_average = 10
windspeed_offset = 0.0
windspeed_gain = 0.6
windmeasureinterval = 5
use_bmp085 = False
use_tmp36 = False
use_dht = False
dht_type = DHT11
number_of_measure_for_wind_trend = 30
wind_trend_limit = 10.0
number_of_measure_for_wind_average_gust_calculation = 10
sensor_temp_out = Default
sensor_temp_in = Default

[Sensor_PCE-FWS20]
set_system_time_from_weatherstation = True

[Sensor_serial]
sensor_serial_port = /dev/ttyUSB0

[RFM01]
rfm01_frequenzy = 868
rfm01_band = 134
rfm01_lna = 0
rfm01_rssi = 97

[WebCam]
webcamdevice1 = None
webcamdevice2 = None
webcamlogo = www.altatensione.org - Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
sendimagestoserver = True
webcaminterval = 180
webcamdevice1captureresolution = 640x480
webcamdevice2captureresolution = 640x480
webcamdevice1finalresolution = 640x480
webcamdevice2finalresolution = 640x480
captureprogram = fswebcam
sendallimagestoserver = False
delete_images_on_sd = True

[Camera]
usecameradivice = False
cameradivicefinalresolution = 800x600
gphoto2options = ,,,,,,,,,,
gphoto2options_night = ,,,,,,,,,,
reset_usb = False
clear_all_sd_cards_at_startup = True
start_camera_number = 1
gphoto2_capture_image_and_download = True
use_camera_resetter = False
camera_resetter_normaly_on = False

[CameraPI]
use_camerapi = True
camerapi_day_settings = -n -w 1024 -h 768 -ex auto -ev -3 -mm average
camerapi_night_settings = -n -w 1024 -h 768 -ex auto

[ftp]
ftpserver = ftp.sintwindaltatensione.altervista.org
ftpserverdestfolder = /swpi/img
ftpserverlogin = sintwindaltatensione
ftpserverpassowd = ************
use_thread_for_sending_to_server = True

[Radio]
useradio = False
radiointerval = 900
radio_verbosity = only_wind

[Mail]
gmail_user = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
gmail_pwd = raspberrypi
mail_to = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
use_mail = False
mail_ip = True

[SMS]
send_ip_by_sms = False
number_to_send = +393330000000

[WeatherUnderground]
weatherunderground_logdata = False
weatherunderground_id = KCASANFR5
weatherunderground_password = XXXXXXXX

[PWS]
pws_logdata = False
pws_id = KCASANFR5
pws_password = XXXXXXXX

[CWOP]
cwop_logdata = False
cwop_id = EW0000
cwop_password = -1

[DNSExit]
use_dnsexit = False
dnsexit_uname = user
dnsexit_pwd = pwd
dnsexit_hname = xxxx.linkpc.net




provato a cambiare sendallimagestoserver = False con True
ma ancora niente...

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3945 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
ho fatto una prova scollegando la chiavetta e collegato tramite LAN

all'avvio carica tutto, internet ok, PCE, allineamento ora con PCE

però dopo il comando alla CameraPI e relativo Processing / Processed

perde la connessione internet..... anche da LAN



Allegato 20140413_105216.jpg non trovato



Allegato 20140413_105200.jpg non trovato



Allegato 20140413_105147.jpg non trovato



Allegato 20140413_105103.jpg non trovato



Allegato 20140413_105044.jpg non trovato




e perde momentaneamente anche la PCE che viene subito dopo

riallineata (WH1080)

AIUTOOOOOOOO


aggiornamento:
se disattivo da swpi.cfg la CameraPI (CameraPI = False) ma non la scollego il sistema funziona... :S

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3946 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
Ancora prove......
ho scoperto che uno dei problemi era l'alimentazione del raspberry, il riduttore da 12V a 5V cinese non ha una potenza adeguata, alimentando con l'alimentatore da 220V-5V alcuni problemi sono risolti, adesso quando sono collegato con la LAN riesco a trasmettere sia i dati che le foto, ma quando scollego la LAN e collego la chiavetta i dati li trasmette ma non risece a trasmettere le foto.

di seguito il log e la configurazione

[13/04/2014-14:43:29] Starting SINT WIND PI ...
************************************************************************
* Sint Wind PI 01.21.79 *
* *
* 2012-2014 by Tonino Tarsi <Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[13/04/2014-14:43:47] loading plugins
[13/04/2014-14:43:47] Starting sensor reading - Sensor type is : PCE-FWS20
[13/04/2014-14:43:47] Config Server running on port 80
[13/04/2014-14:43:49] Detected : Dream Link WH1080 Weather Station / USB Missile Launcher
[13/04/2014-14:43:49] Trying to get time from WH1080. Please wait ...
[13/04/2014-14:43:50] sms reset

[13/04/2014-14:43:50] Modem Model : K3765
[13/04/2014-14:43:50] Revision : 11.126.03.06.00
[13/04/2014-14:43:50] Modem Serial Number : R07NAA1040100565
[13/04/2014-14:43:50] Pin Status : READY
[13/04/2014-14:43:50] Device Center : +393492000200 145
[13/04/2014-14:43:50] Signal quality : 21
[13/04/2014-14:43:50] Checking new sms messages...
[13/04/2014-14:43:50] Checking internet connetion ...
[13/04/2014-14:43:50] No Internet
[13/04/2014-14:43:50] Trying to connect to internet with 3G dongle ....
[13/04/2014-14:43:53] Waiting for a valid IP ...
[13/04/2014-14:43:53] No IP yet. Retrying ..59
[13/04/2014-14:43:56] sms reset
[13/04/2014-14:43:56] Checking internet connetion ...
[13/04/2014-14:43:56] Internet ok

[13/04/2014-14:43:57] Connected with IP : 91.252.2.12
[13/04/2014-14:43:57][13/04/2014-14:43:57] Try to disconnect
SunHalter: System will Halt in 20042.0 seconds
[13/04/2014-14:43:57] Starting General WatchDog
[13/04/2014-14:43:59] sms reset
dom 13 apr 2014, 14.45.00, CEST
[13/04/2014-14:45:00] System time adjusted from WH1080
[13/04/2014-14:45:30] Calculating Meteo data and statistics
[13/04/2014-14:45:43] Logging data to Database
[13/04/2014-14:45:43] Dir: E - Spd: 0.0 - Gst: 1.08 - Tout: 21.3 - Tin: 25.0 - Hout: 67.0 - Hin: 53.0 - P: 1014 - Rtot: 63.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 778
[13/04/2014-14:45:45] CameraPI - Using Dayligth settings-n -w 1024 -h 768 -ex auto
[13/04/2014-14:45:52] Processing image :./img/raspi_13042014-144545.jpg
[13/04/2014-14:45:52] Processed image :./img/raspi_13042014-144545.jpg
[13/04/2014-14:45:52] Checking internet connetion ...
[13/04/2014-14:45:52] No Internet
[13/04/2014-14:45:52] Trying to connect to internet with 3G dongle
[13/04/2014-14:45:52] Waiting for a valid IP ...
[13/04/2014-14:45:53] No IP yet. Retrying ..59
[13/04/2014-14:45:55] No IP yet. Retrying ..58
[13/04/2014-14:45:57] No IP yet. Retrying ..57
[13/04/2014-14:45:59] Connected with IP :1.75.112.68
[13/04/2014-14:45:59] Checking internet connetion ...
[13/04/2014-14:45:59] Internet ok
[13/04/2014-14:45:59] Logging data ...
[13/04/2014-14:45:59] Data sent to server : OK
[13/04/2014-14:46:01] Public IP : 91.255.50.161
[13/04/2014-14:46:01] Rereading config file ..
[13/04/2014-14:46:01] Try to disconnect
[13/04/2014-14:46:01] sms reset
[13/04/2014-14:46:01] sms reset
[13/04/2014-14:46:01] Disk space left = 819683328
[13/04/2014-14:46:01] Sleeping 90 seconds
[13/04/2014-14:46:30] Calculating Meteo data and statistics
Exception
timed out
[13/04/2014-14:46:30] Error sending file to server : raspi_13042014-144545.jpg
[13/04/2014-14:46:30] Deleted file : ./img/raspi_13042014-144545.jpg

[13/04/2014-14:46:43] Logging data to Database
[13/04/2014-14:46:43] Dir: S - Spd: 1.08 - Gst: 2.52 - Tout: 21.3 - Tin: 25.0 - Hout: 67.0 - Hin: 53.0 - P: 1014 - Rtot: 63.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 778
[13/04/2014-14:47:30] Calculating Meteo data and statistics
[13/04/2014-14:47:43] Logging data to Database
[13/04/2014-14:47:43] Dir: N - Spd: 0.0 - Gst: 1.08 - Tout: 21.3 - Tin: 25.0 - Hout: 67.0 - Hin: 53.0 - P: 1014 - Rtot: 63.9 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 778

======================================================================

[General]
station_name = Sint Wind ALTA TENSIONE - PIZZORNE
config_web_server = True
set_sistem_time_from_ntp_server_at_startup = False
ntp_server = europe.pool.ntp.org
reboot_at = None
shutdown_at = None
shutdown_hour_before_sunset = -0.5
location_latitude = 43.351983
location_longitude = 12.743187
location_altitude = 0.0
wifi_reset_if_down = False
config_web_server_port = 80
cloudbase_calib = 1.0
set_time_at_boot = None
wind_speed_units = kmh
ntp_url = None

[Dongle]
usedongle = True
alwaysoninternet = False
donglectrlport = /dev/ttyUSB2
dongleaudioport = /dev/ttyUSB1
dongledataport = /dev/ttyUSB0
usedonglenet = True
operator = tre
prober_timeout = 2.0
modem_baudrate = 460800
audio_baudrate = 115200
ctrl__baudrate = 9600
dialnum = *99#
pppd_path = /usr/sbin/pppd

[Security]
smspwd = admin

[DataLogging]
logdata = True
serverfile = www.sintwindaltatensione.altervista.org/swpi/swpi_logger.php

[Upload]
upload_data = False
upload_folder = /swpi

[Sensors]
sensor_type = PCE-FWS20
davis_error = 0
use_wind_sensor = True
number_of_measure_for_wind_dir_average = 10
windspeed_offset = 0.0
windspeed_gain = 1.0
windmeasureinterval = 5
use_bmp085 = False
use_tmp36 = False
use_dht = False
dht_type = DHT11
number_of_measure_for_wind_trend = 30
wind_trend_limit = 10.0
number_of_measure_for_wind_average_gust_calculation = 10
sensor_temp_out = Default
sensor_temp_in = Default

[Sensor_PCE-FWS20]
set_system_time_from_weatherstation = True

[Sensor_serial]
sensor_serial_port = /dev/ttyUSB0

[RFM01]
rfm01_frequenzy = 868
rfm01_band = 134
rfm01_lna = 0
rfm01_rssi = 97

[WebCam]
webcamdevice1 = None
webcamdevice2 = None
webcamlogo = www.altatensione.org - Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
sendimagestoserver = False
webcaminterval = 120
webcamdevice1captureresolution = 640x480
webcamdevice2captureresolution = 640x480
webcamdevice1finalresolution = 640x480
webcamdevice2finalresolution = 640x480
captureprogram = fswebcam
sendallimagestoserver = True
delete_images_on_sd = True

[Camera]
usecameradivice = False
cameradivicefinalresolution = 800x600
gphoto2options = ,,,,,,,,,,
gphoto2options_night = ,,,,,,,,,,
reset_usb = False
clear_all_sd_cards_at_startup = True
start_camera_number = 1
gphoto2_capture_image_and_download = True
use_camera_resetter = False
camera_resetter_normaly_on = False

[CameraPI]
use_camerapi = True
camerapi_day_settings = -n -w 1024 -h 768 -ex auto
camerapi_night_settings = -n -w 1024 -h 768 -ex auto

[ftp]
ftpserver = ftp.sintwindaltatensione.altervista.org
ftpserverdestfolder = /swpi/img
ftpserverlogin = sintwindaltatensione
ftpserverpassowd = ***********
use_thread_for_sending_to_server = True

[Radio]
useradio = False
radiointerval = 900
radio_verbosity = only_wind

[Mail]
gmail_user = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
gmail_pwd = raspberrypi
mail_to = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
use_mail = False
mail_ip = True

[SMS]
send_ip_by_sms = False
number_to_send = +393330000000

[WeatherUnderground]
weatherunderground_logdata = False
weatherunderground_id = KCASANFR5
weatherunderground_password = XXXXXXXX

[PWS]
pws_logdata = False
pws_id = KCASANFR5
pws_password = XXXXXXXX

[CWOP]
cwop_logdata = False
cwop_id = EW0000
cwop_password = -1

[DNSExit]
use_dnsexit = False
dnsexit_uname = user
dnsexit_pwd = pwd
dnsexit_hname = xxxx.linkpc.net





PENSO DI AVER RISOLTO
:cheer:
alwaysoninternet = True (prima era false)

ADESSO STA' FUNZIONANDO
LO TESTO ANCORA UN PO'
:whistle:

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3947 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
Alegrechi scrive

........
Inoltre credo sia il caso di disabilitare il led rosso che si accende durante lo scatto.

Dovrebbe bastare editare il file /boot/config.txt inserendo la riga
disable_camera_led=1



Potresti spiegare meglio....io ho due cartelle una /Boot e una /Boot.bak ma nella cartella /Boot non vedo nessun file config.txt mentre lo vedo nella cartella /Boot.bak

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3952 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
allora...alla fine devo dire che funziona quasi tutto.....
nelle foto che vengono inviate sul sito, noto che nel banner in basso che indica i valori meteo, il valore Base Cumulo in fondo a destra rimane fuori dai bordi...è un problema di definizione??


queste le mie impostazioni:

[WebCam]
webcamdevice1 = None
webcamdevice2 = None
webcamlogo = www.altatensione.org - Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo. - +393914148488
sendimagestoserver = False
webcaminterval = 120
webcamdevice1captureresolution = 640x480
webcamdevice2captureresolution = 640x480
webcamdevice1finalresolution = 640x480
webcamdevice2finalresolution = 640x480
captureprogram = fswebcam
sendallimagestoserver = True
delete_images_on_sd = True

[Camera]
usecameradivice = False
cameradivicefinalresolution = 800x600
gphoto2options = ,,,,,,,,,,
gphoto2options_night = ,,,,,,,,,,
reset_usb = False
clear_all_sd_cards_at_startup = True
start_camera_number = 1
gphoto2_capture_image_and_download = True
use_camera_resetter = False
camera_resetter_normaly_on = False

[CameraPI]
use_camerapi = True
camerapi_day_settings = -n -w 1024 -h 768 -ex auto
camerapi_night_settings = -n -w 1024 -h 768 -ex auto



Allegato raspi_15042014-210045.jpg non trovato




ah....anche l'ora, sempre in basso, mi pare anomala....

grazie!!

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3953 da tony
Risposta da tony al topic Raspberry PI Camera Board
visto che acqusisci a 1024 forse ti conviene portare anche la camerafinalresolution a quel valore. a 1024 i testi dovrevvero essere ok
TT
Ringraziano per il messaggio: asy961

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3954 da tony
Risposta da tony al topic Raspberry PI Camera Board
vedo poi che hai sendimagestpserver a false. così non vengono inviate.
Ringraziano per il messaggio: asy961

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa - 4 Anni 11 Mesi fa #3956 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
Grazie Tony,
pensavo che con il ridimensionamento 800x600 adeguasse tutto,
invece, nonostatnte abbia 'sendimagestoserver= false' le immagini vengono inviate e si possono vedere nella pagina '..swpi/camera1.php', come lo spieghi?
e perchè lo slideshow parte dalla più recente e torna alla prima?
sbaglio io qualcosa?

invece per l'ora in cui si vedono anche i 'milionesimi' di secondo che si pouò fare??

Scusami per la tante domande, ormai sono agli aggiustamenti finali.

ps:
stò cercando di registrare nuovi file .mp3 per vedere se riesco a modulare meglio la voce sia come qualità che come volume, vi farò sapere dove arrivo.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 4 Anni 11 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3961 da tony
Risposta da tony al topic Raspberry PI Camera Board
> nonostatnte abbia 'sendimagestoserver= false' le immagini vengono inviate

questo sembrerebbe un baco .. devo controllare

> perchè lo slideshow parte dalla più recente e torna alla prima

E' volutamente fatto cosi .. comunque se lo vuoi rovesciato è semplice e basta che vedi un po il codice


TT
Ringraziano per il messaggio: asy961

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3969 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
> E' volutamente fatto cosi .. comunque se lo vuoi rovesciato è semplice e basta che vedi un po il codice

ok tony, vedrò di modificarlo...forse, va bene anche così...

ma dell'orario in basso alle foto che mi dici? si potrebbe avere solo nel formato hh:mm?? avere i secondi e i milionesimi di secondo non credo che abbia importanza.....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 11 Mesi fa #3970 da tony
Risposta da tony al topic Raspberry PI Camera Board
si. versione 01.21.83
Ringraziano per il messaggio: asy961

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 8 Mesi fa #4350 da Ciaschini
Risposta da Ciaschini al topic Raspberry PI Camera Board
stesso problema, ho un alimentatore da 2 ampere ed è collegata tramite LAN, questo il log:
[26/06/2014-19:18:13] CameraPI - Using Dayligth settings
[26/06/2014-19:18:19] Processing image :./img/raspi_26062014-191813.jpg
[26/06/2014-19:18:25] Processed image :./img/raspi_26062014-191813.jpg
[26/06/2014-19:18:25] Checking internet connetion ...
[26/06/2014-19:18:26] No Internet
[26/06/2014-19:18:26] Error. Non internet connection available

il raspberry perde la connessione ma continua a rilevare i dati dall'rfm01

inoltre, se già non bastasse, andando a prendere le foto dentro la sd le ho trovate tutte a righe, penso che sia difettosa

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 8 Mesi fa #4351 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
sembrebbe più un problema di perdita della connessione a internet.....
riprova scollegando la camera pi......
io ho avuto dei problemi simili ed era la camera pi che bloccava tutto....


per le righe nelle foto prova con un'altro alimentatore....
magari questo non è al 100% stabilizzato.....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 8 Mesi fa #4352 da Ciaschini
Risposta da Ciaschini al topic Raspberry PI Camera Board
effettivamente il problema si presentava quando collegavo la camera pi, nonostante l'alimentatore da 2 ampere sembrava non bastare nel momento dello scatto, leggendo su internet ho letto di provare a controalimentare il raspberry con un cavo usb-usb direttamente nelle porte usb, e indovinate? funziona! :)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 8 Mesi fa #4353 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
Bene....
cmq io alimenterei il rpy con un alimentatore adeguato evitando la controalimentazione da usb.....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 8 Mesi fa #4356 da Ciaschini
Risposta da Ciaschini al topic Raspberry PI Camera Board
qualcuno di voi ha attiva la camera board con la versione sperimentale di swpi? io ci sto provando ma esce solo "CameraPI - Using Dayligth settings" e non scatta

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 8 Mesi fa #4357 da tony
Risposta da tony al topic Raspberry PI Camera Board
Io effettivamente no. Non vorrei ci fossero problemi col filesystem in sola lettura ...

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 7 Mesi fa - 4 Anni 6 Mesi fa #4477 da patrickcr1985
Salve a tutti, proseguo su questo topic, per dei settaggi alla camera pi. Grazie ad un amico, abbiamo fatto prove per migliorare la qualita dello scatto,non tanto per le foto di giorno quanto quelle di notte con un esposizione di 6 secondi. Per fare questo però dalle prove avevamo bisogno anche del comando -ss che nella versione raspistill contenuta nel firmware attuale non è supportata.

Quindi aggiorno con
sudo apt-get update && sudo apt-get upgrade

e
sudo rpi-update

Reboot d'obbligo e via con i nuovi set, chiaramente la cosa è soggettiva ma mi trovo bene per lo scatto di giorno con questo set:

-n -w 1024 -h 768 -co 15 -sa 20 -sh 50 -ev 5 -awb horizon

rispetto al semplice:
-n -w 1024 -h 768 -ex auto

Queste le differenze sullo scatto:


Allegato prima.jpg non trovato



Allegato dopo.jpg non trovato



Per quanto rigurada la notte, da foto totalmente buie, con il set:

-n -w 1024 -h 768 -sa 20 -sh 50 -ISO 600 -ev 5 -awb fluorescent -awbg 1,1 -ss 6000000 -t 60000

ottengo:

Allegato notte.jpg non trovato



E credetemi nel dire che riesce a fotografare le fievoli luci delle stelle.

Aggiungo che per lo scatto di notte ho dovuto disabilitare il led della camera perchè altrimenti dava una fastidiosa illuminazione sulle foto.

Tutto bene fin qui se non fosse per una noia che sto avendo questi giorni per l'upload delle foto verso il server altervista, in quanto alcune foto,e non sempre, vengono trasferite "tagliate", per farvi capire:
meteoselva.altervista.org/meteo/img/raspi_19082014-111248.jpg

e sul log del sint wind ottengo questa scritta:

Exception
timed out
[19/08/2014-13:15:57] Error sending file to server : raspi_19082014-131447.jpg
[19/08/2014-13:15:57] Deleted file : ./img/raspi_19082014-131447.jpg

Quindi sul server arrivano con dei kb in meno mentre sulla sd del raspberry sono belle integre. E' sicuramente un problema di connessione o carico ftp ma l'unica cosa che ho aggiunto in questi giorni rispetto all'invio del file meteo.txt e foto, è l'invio dei dati a wunderground con relativi grafici o trend presi dalla sezione download. Chiedevo è possibile evitare il "Exception timed out" variando questo time out se impostato da qualche parte?


[Edit]
Provato ad aumentare il timeout nel TTLib.py , inserito un time.sleep nella sequenza di invio al server prima del carico della foto, disabilitato invio dati a wundergroung ma in modo del tutto random invia la foto a pezzi.
Tornato a firmware pulito senza update & upgrate per ora tutto ok.
Allegati:
Ultima Modifica 4 Anni 6 Mesi fa da patrickcr1985.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 2 Mesi fa #4878 da skatman84
Risposta da skatman84 al topic Raspberry PI Camera Board
>Buongiorno a tutti,
io ho notato che se attivo nella configurazione web la camera pi

perdo la connessione ad internet, pur non avendo collegata fisicamente la camera.

Sto utilizzando il configuratore web, raspi collegato via LAN, ricevitore rfm01 (nel log vengono rilevati i dati inviati da stazione PCE), raspi B + con versione di SWPI ver 2 .
Grazie...sto combattendo da un pé... :-(

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
4 Anni 2 Mesi fa #4970 da TeoBW
Risposta da TeoBW al topic Raspberry PI Camera Board

alegrechi ha scritto: Era lo stesso codice che avevo provato io (uguale a quello postato anche da Roberto).

Purtroppo (non so perchè) non mi funziona e ottengo questo:

meteostrada.grechi.it/meteo/swpi_raspi.php

Edit:
per adesso comunque ho fatto una modifica a swpi.py e invio entrambe le immagini al server... in questo modo ottengo quello che voglio ed ho meno problemi ad inviare/incorporare l'immagine live.
Capisco che sia un doppione, ma 100k in più di banda non mi fa molta differenza :)

if ( cfg.use_cameraPI and bcPI ): 
					if (cfg.sendallimagestoserver ):
						waitForHandUP()
						sendFileToServer(cPIFilemane,getFileName(cPIFilemane),cfg.ftpserver,cfg.ftpserverDestFolder,cfg.ftpserverLogin,cfg.ftpserverPassowd,cfg.delete_images_on_sd,cfg.use_thread_for_sending_to_server)
						sendFileToServer(cPIFilemane,"raspi.jpg",cfg.ftpserver,cfg.ftpserverDestFolder,cfg.ftpserverLogin,cfg.ftpserverPassowd,cfg.delete_images_on_sd,cfg.use_thread_for_sending_to_server)

					else:
						waitForHandUP()
						sendFileToServer(cPIFilemane,"raspi.jpg",cfg.ftpserver,cfg.ftpserverDestFolder,cfg.ftpserverLogin,cfg.ftpserverPassowd,cfg.delete_images_on_sd,cfg.use_thread_for_sending_to_server)

Riprendo questo tuo post, perchè volevo attuare anceh io qst metodo per avere file fisso da linkare, ma ottengo un errore,
Error sending file to server : raspi.jpg
File "swpi.py", line 981, in <module>
sendFileToServer(cPIFilemane,"raspi.jpg",cfg.ftpserver,cfg.ftpserverDestFolder,cfg.ftpserverLogin,cfg.ftpserverPassowd,cfg.delete_images_on_sd,cfg.use_thread_for_sending_to_server)
File "/home/pi/swpi/TTLib.py", line 945, in sendFileToServer
sendFileToFTPServer(filename,name,server,destFolder,login,password,delete)
File "/home/pi/swpi/TTLib.py", line 939, in sendFileToFTPServer
os.remove(filename)
OSError: [Errno 2] No such file or directory: './img/raspi_14012015-112827.jpg'

a voi non è mai successo?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 6 Mesi fa - 3 Anni 6 Mesi fa #5747 da Roberto Vaccaro
MEGLIO TARDI CHE MAI

La soluzione a questo problema è scrivere un False al posto dell'argomento delete_images_on_sd nella riga che aggiungete per inviare l'immagine senza il timestamp
if ( cfg.use_cameraPI and bcPI ): 
					if (cfg.sendallimagestoserver ):
						waitForHandUP()
						sendFileToServer(cPIFilemane,getFileName(cPIFilemane),cfg.ftpserver,cfg.ftpserverDestFolder,cfg.ftpserverLogin,cfg.ftpserverPassowd,cfg.delete_images_on_sd,cfg.use_thread_for_sending_to_server)
						sendFileToServer(cPIFilemane,"raspi1.jpg",cfg.ftpserver,cfg.ftpserverDestFolder,cfg.ftpserverLogin,cfg.ftpserverPassowd,False,cfg.use_thread_for_sending_to_server)
Ultima Modifica 3 Anni 6 Mesi fa da Roberto Vaccaro.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 3 Settimane fa #6478 da asy961
Risposta da asy961 al topic Raspberry PI Camera Board
rispolvero questo topic per segnalare questa novità.....interessante??

Multi camera adapter

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ringraziano per il messaggio: tony

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.574 secondi