× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

question-circle Bugs v.1.23.84

Di più
3 Anni 2 Settimane fa - 3 Anni 1 Settimana fa #6899 da SkizZO
Bugs v.1.23.84 è stato creato da SkizZO
Salve a tutti, volevo segnalare

a) wind_chill = temp_out
Con 15/18 nodi di vento, il windchill è identico alla temperatura, fino ll'ultima cifra.
b) wind_trend_limit < wind_trend
Ho un wind trend limit impostato a 6, ma il wind trend va anche oltre il 10 ??
c) Il frame aggiunto all'immagine webcam, riporta unità di misura del vento errate (impostati kts, visualizzati kts, u.misura km/h)
Ultima Modifica 3 Anni 1 Settimana fa da SkizZO.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Settimane fa - 3 Anni 2 Giorni fa #6955 da SkizZO
Risposta da SkizZO al topic Bugs v.1.23.84
Aggiungo/chiedo:

BME280 + DHT11

Ho impostato :
sensor_temp_out = Default
sensor_temp_in = DHT

...va alla grande.

Nel log di swpi però di HumIn non c'è traccia, come anche in meteo.txt: "hum_in": null. Nel GET del file php, ricava hum_out al posto di hum_in (lo scrive su db)

Posso avere anche l'umidità interna?, è un bug?
Ultima Modifica 3 Anni 2 Giorni fa da SkizZO.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Settimane fa #6956 da asy961
Risposta da asy961 al topic Bugs v.1.23.84
use_bmp085 = False
use_bme280 = True
use_tmp36 = False
use_dht = True
dht_type = DHT11

sensor_temp_out = Default
sensor_temp_in = Default

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Settimane fa #6957 da SkizZO
Risposta da SkizZO al topic Bugs v.1.23.84
Ti ringrazio, ma come hai scritto tu non esce nemmeno la temperatura interna. Impostando a default il sensor temp in, non fa vedere la temperatura.

use_bmp085 = False
use_bme280 = True
use_tmp36 = False
use_dht = True
dht_type = DHT11

sensor_temp_out = Default
sensor_temp_in = DHT

In questo modo la temp. Interna (dal dht) funziona, l'umidità viene letta dal DHT, e scritta nel log, ma non viene riportata da swpi, ne nel file meteo.txt, ne in coda a tutte le misurazioni).

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Settimane fa #6959 da asy961
Risposta da asy961 al topic Bugs v.1.23.84
:( hai ragione,
ho rimontato i sensori anch'io per provare e le Temp_in e Hum_in nella configurazione con BME280 e DHT11 non vengono trasmesse,
credo che sia un problema nel file sensor.py

col BMP085 le Temp_in (DHT11) e Temp_out (BMP085) funzionano
la Hum_in no avendo in questa configurazione solo un sensore H è giusto che sia quella out

invece sarebbe opportuno fare la modifica che nella configurazione BME280 (T,P,H) e DHT11 (T,H) i valori del DHT siano assegnati a Temp_in e Hum_in

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Settimane fa #6972 da SkizZO
Risposta da SkizZO al topic Bugs v.1.23.84
sensor_temp_out = Default
sensor_temp_in = DHT

Così la Temp in c'è

manca solo hum

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 1 Settimana fa #7026 da SkizZO
Risposta da SkizZO al topic Bugs v.1.23.84
Ieri per l'hum_in del DHT11 accoppiato al BME, inserii questa stringa in sensors.py alla riga 107:
globalvars.meteo_data.hum_in = dht_hum

Ma forse sbaglio la sintassi (ho in swpi.cfg - sensor_temp_in = DHT).

Ho visto che dopo assegna l'umidità interna al DHT (stessa stringa) ma forse non rientra nei casi previsti.

Ho notato inoltre (altro bug aggiunto alla lista al primo post) che la "cornice" delle immagini webcam, riporta le unità di misura errate del vento.
Come cambio le informazioni che escono nel frame?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
3 Anni 2 Giorni fa - 3 Anni 2 Giorni fa #7071 da SkizZO
Risposta da SkizZO al topic Bugs v.1.23.84
BME + DHT :
temp out, hum out, pressione = BME

il dht solo temp in, ma....

swpi scambia i dati del DHT con il BME...:
wlan0 is up
[14/06/2016-17:56:23] CameraPI - Using Dayligth settings-n -w 1280 -h 772 -hf -ex auto
[14/06/2016-17:56:29] Processing image :./img/raspi_14062016-175623.jpg
[14/06/2016-17:56:30] Processed image :./img/raspi_14062016-175623.jpg
[14/06/2016-17:56:30] Checking internet connetion ...
[14/06/2016-17:56:30] Internet ok
[14/06/2016-17:56:30] Logging data ...
[14/06/2016-17:56:30] Data sent to server : WxWuLogger v1.1: MysqlTable Aggiornata
[14/06/2016-17:56:30] Uploading data ...
[14/06/2016-17:56:31] Disk space left = 524 Mb
[14/06/2016-17:56:31] Sleeping 52 seconds
[14/06/2016-17:56:31] Sending file to server : raspi.jpg OK
mar 14 giu 2016, 17.56.31, CEST
[14/06/2016-17:56:31] System time adjusted from NPT server : ntp.inrim.it
[14/06/2016-17:56:31] Deleted file : /dev/shm/meteo.txt
[14/06/2016-17:56:31] Sending file to server : meteo.txt OK Deleted
[14/06/2016-17:56:31] DHT - Temperature: 33.0 C Humidity:    30.0 
[14/06/2016-17:56:31] BME280 - Temperature: 26.2 C Pressure:    998.7 humidity 48
[14/06/2016-17:56:31] Calculating Meteo data and statistics
[14/06/2016-17:56:35] Logging data to Database
[14/06/2016-17:56:36] Dir: SW - Spd: 5.05399568035 - Gst: 6.47948164147 - Tout: 26.2 - Tin: 33.0 - Hout: 48.3 - P: 998 - Rtot: 9.0 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 1437 - Trend: -2.82
[14/06/2016-17:57:22] Deleted file : ./img/raspi_14062016-175623.jpg
wlan0 is up
[14/06/2016-17:57:23] CameraPI - Using Dayligth settings-n -w 1280 -h 772 -hf -ex auto
[14/06/2016-17:57:28] Processing image :./img/raspi_14062016-175723.jpg
[14/06/2016-17:57:30] Processed image :./img/raspi_14062016-175723.jpg
[14/06/2016-17:57:30] Checking internet connetion ...
[14/06/2016-17:57:30] DHT - Temperature: 33.0 C Humidity:    29.0 
[14/06/2016-17:57:30] BME280 - Temperature: 26.0 C Pressure:    998.2 humidity 48
[14/06/2016-17:57:30] Calculating Meteo data and statistics
[14/06/2016-17:57:35] Logging data to Database
[14/06/2016-17:57:35] Dir: SSW - Spd: 7.51619870411 - Gst: 10.3671706264 - Tout: 26.0 - Tin: 33.0 - Hout: 48.1 - P: 998 - Rtot: 9.0 - RDay: 0.0 - R1h: 0.0 - R24h: 0.0 - CB: 1443 - Trend: -2.72
[14/06/2016-17:57:40] No Internet
[14/06/2016-17:57:40] Error. Non internet connection available
[14/06/2016-17:57:40] Disk space left = 524 Mb
[14/06/2016-17:57:40] Sleeping 43 seconds
[14/06/2016-17:58:23] Deleted file : ./img/raspi_14062016-175723.jpg
wlan0 is up
[14/06/2016-17:58:23] CameraPI - Using Dayligth settings-n -w 1280 -h 772 -hf -ex auto
[14/06/2016-17:58:29] Processing image :./img/raspi_14062016-175823.jpg
[14/06/2016-17:58:30] Processed image :./img/raspi_14062016-175823.jpg
[14/06/2016-17:58:30] Checking internet connetion ...
[14/06/2016-17:58:30] DHT - Temperature: 33.0 C Humidity:    29.0 
[14/06/2016-17:58:30] Internet ok
[14/06/2016-17:58:30] Logging data ...
[14/06/2016-17:58:31] BME280 - Temperature: 26.1 C Pressure:    998.7 humidity 49
[14/06/2016-17:58:31] Calculating Meteo data and statistics
[14/06/2016-17:58:31] Sending file to server : raspi.jpg OK
[14/06/2016-17:58:35] Data sent to server : WxWuLogger Alert: Dati anomali - Hum_out (29)  eccede di +/- (6) da ultima misura (48.64) - Duplicato il precedente 
WxWuLogger Alert: Dati anomali - Temp_out (33) eccede di +/- (3) da ultima misura (25.88) - Duplicato il precedente 
WxWuLogger v1.1: MysqlTable Aggiornata

cercate "alert" e vedete i valori dei sensori qualche secondo prima
Ultima Modifica 3 Anni 2 Giorni fa da SkizZO.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
2 Anni 11 Mesi fa #7124 da tetox
Risposta da tetox al topic Bugs v.1.23.84
Salve a tutti ... non volendo iniziare altra discussione , e visto che in questa si parla di bug ... chiedo ...

Log to Wunderground : INVALIDPASSWORDID|Password or key and/or id are incorrect

Questo errore e' eliminabile ??? sul setting relativo c'e' FALSE ma da' ugualmente Errore !!!.
La cosa non e' grave .. giusto cosi' per pura pignoleria !!
Saluti
Stefano i6wvq

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.495 secondi