× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

question-circle Errore con ultimo aggiornamento 1.23.21

Di più
4 Anni 9 Mesi fa - 4 Anni 9 Mesi fa #6226 da asy961
@tony
@roberto

Volevo provare ad installare il nuovo sensore Bosch BME280
e prima ho eseguito un bel
rw
sudo apt-get update
sudo apt-get upgrade

e ho rilanciato swpi per controllare che tutto funzionasse

(premetto che è un montaggio sul banco con solo rpi+bmp285+dhy11+cameraPI)

e tutto funzionava.

Ho quindi aggiornato all'ultimo fw con swpi-update

ed ho ricontrollato che tutto funzionasse
ma ho riscontrato dei problemi

come si vede dal log allegato con la versione 1.22.62 era ok
con la nuova versione 1.23.21 oltre che dare un errore all'inizio (evidenziato) che sul log non viene registrato ma a video si (vedi foto)
dopo lo scatto della cameraPI c'è un errore che fa entrare in loop il sistema spedendo continuamente la foto al server.

Ho notato che modificando la riga 59 del file TTLib.py
da path = "/swpi" a path = "/"
rimane l'errore all'inizio ma il sistema riprende a funzionare bene



Allegato log16122015.log.zip non trovato






Allegato DSC01031.JPG non trovato



Allegato DSC01034.JPG non trovato


Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:
Ultima Modifica 4 Anni 9 Mesi fa da asy961.

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6227 da tony
Grazie Valerio delle segnalazione. In entrambi i casi sono modifiche che ho apportato io.

1) per quanto riguarda l'errore di accesso a ttyUSB0 dovrebbe comparire se hai attivato la chiavetta "use_dongle" ma non viene rilevata. la chiavetta è presente ?

2) Il secondo dipende dalla routene che calcola lo spazio libero sulla scheda SD. Per i sistemi in modalità RO il software è installato nella partizione /swpi. Che tipo di sistema usi / RO o RW ) ?

TT

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa - 4 Anni 9 Mesi fa #6228 da asy961
1) chiavetta NON montata NON configurata

2) versione 1 RW


allego configurazione che uso per prova sul banco


Allegato swpi.cfg_2015-12-16.zip non trovato





eppoi una domanda....
con questo aggiornamento funziona già anche il BME280??

ho visto che è già inserito come possibilità nella configurazione....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:
Ultima Modifica 4 Anni 9 Mesi fa da asy961.

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa - 4 Anni 9 Mesi fa #6229 da tony
Ok.
Per il punto 1 allora è tutto normale. Nelle nuove versioni è possibile mettere "use_dongle" a True pur non connettendo la chiavetta. Nelle vecchie versione il programma in questa configurazione sarebbe andato in errore. Ora ignora la chiavetta.

Per il punto 2 si tratta di un baco per le versioni RW. vedo di aggiornare ma ti consiglio di migrare alla versione 2 RO.

Tony
Ultima Modifica 4 Anni 9 Mesi fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6230 da tony
Per il punto 2 ho uploadato un aggiornamento di tentativo ma senza poterlo provare .. in caso questa sera vedo meglio.
TT

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6231 da asy961
sono partito da una vecchia versione, mi sembra la 630, ma questo è avvenuto all'inizio, poi ho sempre fatto update e salvato la nuova immagine.

invece dovrebbe esserci una /home/pi/swpi/swpi???

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6232 da tony
la 630 è molto vecchia e credo neanche più presente in download .
Ti consiglio di ripartire dalla 824

mega.nz/#!rVRiHAqK!oJeQMJuOBxXjK_0Fxaj6yxtbX2cBISbj2izobE7ztts

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6233 da asy961
caricato la 1.23.22

pare che funziona....la faccio lavorare un pò....

stasera aggiorno


per bme280 invece che mi dici??
su questa versione funziona??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6239 da ciapa85
aggiornato anche io alla versione 1.23.21 con swpi V1
mi da continuamente questi errori nell'allegato e mi carica di continuo i dati sul database
domani provo con la versione swpi2_824
e vi faccio sapere....

voi avete risolto?
Allegati:

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6240 da asy961
fai un update alla 1.23.22

a me funziona

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6243 da asy961
@tony

è da ierisera che gira la versione 1.23.22
per ora sta funzionando alla grande anche con il BME280....

una curiosità...
perchè quando facciamo l'update aggiorna sempre il messaggio vocale dewpoint (sia mp3 che raw) ??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6244 da tony
Bene,
Per gli mp3 hai ragione . Si tratta di un vecchio retaggio. Nelle vecchie immagini ( la 630 per esempio ) il file dewpoint non era presente quindi lo inviavo come aggiornamento. Oa credo che quella immagine sia superata quindi tolgo l'aggiornamentto.
TT

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6245 da asy961
bene...
allora visto che ci siamo volevo anche segnalarti che la sezione download sul sito risulta difficoltoso arrivarci adesso.....
credo dopo l'ultimo aggiornamento??

:(

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6272 da ciapa85
sono passato alla Firmware versione 2 824 ReadOnly.

l'installazione è andata bene, ma ho la necessità di inserire un indirizzo statico al raspberry.

con il comando
sudo pico /etc/network/interfaces
mi dice che il file no ha i permessi di scrittura

ho provato anche con chmod ma non mi cambia i permessi

come posso fare?

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6273 da ciapa85
RISOLTO

ho modificato il file /etc/network/interfaces con un pc linux

Si prega Accedi a partecipare alla conversazione.

Di più
4 Anni 9 Mesi fa #6277 da tony
Piu semplicemente per modificare il mount delle partizioni puoi usare gli alias :

ro
rw

con significato ovvio.
TT

Si prega Accedi a partecipare alla conversazione.

Tempo creazione pagina: 0.634 secondi