× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file A530 Canon

Di più
5 Anni 1 Settimana fa #5833 da linxis
A530 Canon è stato creato da linxis
Buon giorno a tutti del forum.
Ho recuperato una fotocamera A530 Canon per collegarla al mio raspy, scorrendo nella lista delle fotocamere nel file wiki con compare in modello A530
Ho provato a collegarla e non funziona.(vedi segmento file log allegato).
Si può fare qualcosa per rendere compatibile questo modello?
Grazie per la risposta

Allegato a530_2015-10-07-2.txt non trovato

Allegati:

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5834 da roberto2011
Risposta da roberto2011 al topic A530 Canon
Nella documentazione di gphoto2 sembrerebbe non abilitata alla cattura.
Unica possibilità aggiornare gphoto2 and libgphoto2 .

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5835 da linxis
Risposta da linxis al topic A530 Canon
Ciao Roberto, e grazie per la risposta.... mi sebra che nell' elenco fotocamere di libgphoto2 la Canon A530 non preveda la cattura dell' immagine....comunque comunque non saprei come fare per sistemare la cosa.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5836 da roberto2011
Risposta da roberto2011 al topic A530 Canon
wget https://raw.githubusercontent.com/gonzalo/gphoto2-updater/master/gphoto2-updater.sh && chmod +x gphoto2-updater.sh && sudo ./gphoto2-updater.sh

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5837 da roberto2011
Risposta da roberto2011 al topic A530 Canon
con questo comando aggiorni gphoto e librerie .
Poi incroci le dita e provi!

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5838 da linxis
Risposta da linxis al topic A530 Canon
Allora provo a capire.......devo entrare da terminale in SWPI, poi killswpi e scrivere quella stringa che mi hai mandato?

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5839 da roberto2011
Risposta da roberto2011 al topic A530 Canon
Yes

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa - 5 Anni 1 Settimana fa #5840 da linxis
Risposta da linxis al topic A530 Canon
Per favore mi puoi dire come posso fare x avere una copia veloce della microsd del swpi. Quale software posso usare da windows7 e da linux?
Ultima Modifica 5 Anni 1 Settimana fa da linxis.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5842 da asy961
Risposta da asy961 al topic A530 Canon
Ciao Linxis
io uso questi....

X WINDOWS

PER SCRIVERE IMMAGINI SU SD

PER CREARE IMMAGINI DELLE SD

x LINUX

da shell usare il comando dd if=/dev/sd? of=/home/......./SD.img
per creare una copia immagine della sd

da shell usare il comando dd if=/home/....../SD.img of=/dev/sd?
per scrivere un immagine sulla sd

al posto del punto ? devi mettere il numero della sd che linux assegna in automatico....
lo puoi trovare digitando sempre da shell sudo fdisk -l


spero di essere stato chiaro...e d'aiuto

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa - 5 Anni 1 Settimana fa #5843 da linxis
Risposta da linxis al topic A530 Canon
adesso sono arrivati OK Grazie mi sa che sei stato di grande AIUTO!!! Grazie ancora
Ultima Modifica 5 Anni 1 Settimana fa da linxis.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa - 5 Anni 1 Settimana fa #5849 da linxis
Risposta da linxis al topic A530 Canon
Allora Roberto....ho provato a fare l'aggiornamento....il sistema si blocca perchè ho il file system in sola lettura.
Avrei bisogno di sapere per favore, quali sono i comandi per portare il file system di swpi in lettura/scrittura e i comandi per riportarlo come prima...sola lettura.
Vorrei anche cambiare l'IP del Raspy per metterlo fisso ma non me lo permette .
Attualmente io utilizzo il pacchetto/immagine in sola lettura
Ultima Modifica 5 Anni 1 Settimana fa da linxis.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5852 da roberto2011
Risposta da roberto2011 al topic A530 Canon
rw
Poi fai un reboot
Tutto qui!

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5853 da SlamBall
Risposta da SlamBall al topic A530 Canon
Ciao a tutti,
ho lo stesso problema con una Nikon Coolpix 2100.
La camera non viene riconosciuta se e' settata in Sierra Mode, mentre viene riconosciuta se e' settata in PTP mode ma non e' possibile catturare l'immagine.
Ho provato a con il comando
wget raw.githubusercontent.com/gonzalo/gphoto...r/gphoto2-updater.sh && chmod +x gphoto2-updater.sh && sudo ./gphoto2-updater.sh

ma niente... sempre lo stesso comportamento.
linxis hai per caso risolto? se si come?
Altri suggerimenti?

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5854 da tony
Risposta da tony al topic A530 Canon
Credo sia inutile aggiornate gphoto2 sia per la Coolpix 2100 che per la A450.
Dalla documentazione mi sembra chiaro che non sono supportate.
TT
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5855 da SlamBall
Risposta da SlamBall al topic A530 Canon
Ciao Tony,
innanzitutto complimenti per l'idea del Sint Wind Pi.
Dalla documentazione relativa alla release gphoto2 2.5.8 (ultima) sembra che entrambe le fotocamere sono supportate:
gphoto.sourceforge.net/proj/libgphoto2/support.php

La Canon PowerShot A450 in PTP mode.
La Nikon CoolPix 2100 in Sierra Mode e PTP mode.

Anche il fatto che sono riconosciute mi fa pensare che siano supportate.
Che ne pensi?
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5856 da linxis
Risposta da linxis al topic A530 Canon
Scusate la mia fotocamera è A530 non A 450

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5857 da SlamBall
Risposta da SlamBall al topic A530 Canon
Scusami. Come puoi vedere dal link precedente, anche la A530 sembra essere supportata in PTP mode.
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5858 da tony
Risposta da tony al topic A530 Canon
Si ma entrambe non hanno "Image Capture" che mi sembra abbastanza fondamentae per swpi.
Quindi direi : Non supportate.
TT
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5859 da SlamBall
Risposta da SlamBall al topic A530 Canon
Hai ragione Tony, ma in Sierra Mode, almeno per la Nikon c'è scritto
Nikon CoolPix 2100 (Sierra Mode) Image Capture, Liveview, Configuration

Quindi dovrebbe essere supportata.

Sono andato nella shell e ho fatto partire direttamente gphoto2 digitando:
gphoto2 --capture-image

e niente, stesso errore, non si può catturare l'immagine.
A questo punto penso che dovrei contattare i developer di gphoto2 mandando i log e chiedendo come mai non va.
Vi farò sapere appena mi rispondono.
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5860 da linxis
Risposta da linxis al topic A530 Canon
Aspetterò sicuramente vostre notizie mi dispiacerebbe purché è una fotocamera che potrebbe fare il suo lavoro egregiamente....Grazie a tutti e 2 per ľinteressamento.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5861 da tony
Risposta da tony al topic A530 Canon
Hai ragione SlamBall . In Sierra Mode la Nikon dovrebbe andare. Non conosco quella camera e suppongo che tu la abbia configurata correttamemte in Sierra Mode.
TT

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5862 da SlamBall
Risposta da SlamBall al topic A530 Canon
Infatti, dopo prove e riprove ormai da giorni, esattamente ora da shell scrivendo
gphoto2 --capture-image
gphoto2 --capture-image-and-download
la fotocamera fa la foto e la scarica.
Il problema però rimane facendo partire swpi. Continua a venire fuori:
ERROR in capturing webcam image on: ./img/webcam1_08102015-233245.jpg /dev/sg0
No digital cameras found

/dev/sg0 è il percorso dove mi viene montata la camera, e l'ho impostato nel file swpi.cfg al parametro webcamdevice1.

C'è qualcosa che sbaglio io? Suggerimenti?

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5864 da roberto2011
Risposta da roberto2011 al topic A530 Canon
devi settare nel file swpi.cfg
usecameradivice = True

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5867 da tony
Risposta da tony al topic A530 Canon
Oltre a quello indicato giustamente da Roberto devi mettere :
webcamDevice1 = none

A questo punto mi viene il dubbio che la tua camera scatta correttamente ma non venga rilevala.

prova :
gphoto2 --auto-detect

TT

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5868 da SlamBall
Risposta da SlamBall al topic A530 Canon
Appena possibile provero' a settare quanto mi avete suggerito:
usecameradivice = True
webcamDevice1 = none

Per quanto riguarda l'altra prova, se da shell scrivo il comando "gphoto2 --auto-detect" ottengo:
Nikon Coolpix 2100 /dev/sg0

quindi la camera e' riconosciuta.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5869 da SlamBall
Risposta da SlamBall al topic A530 Canon
Ho provato con i settaggi suggeriti ma niente, stessa dicitura:
"No digital cameras found"

con il comando gphoto2 --auto-detect ottengo:
Nikon Coolix 2100 (Sierra Mode) usbscsi:/dev/sg0
e la fotocamera scatta foto e fa il download.

potrebbe essere qualcosa collegata alla porta usb (usbscsi) nel swpi?
A me sembra che ci sia qualcosa che non permetta proprio la connessione (tramite swpi) alla camera.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa - 5 Anni 1 Settimana fa #5870 da tony
Risposta da tony al topic A530 Canon
e' un baco di swpi.
Tutte le altre camere rispondono con
usb:
mentre la tua con
usbscsi:

ti faccio sapere appena trovo il tempo di fare un fix.

TT
Ultima Modifica 5 Anni 1 Settimana fa da tony.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5871 da SlamBall
Risposta da SlamBall al topic A530 Canon
Grazie mille.
Immaginavo fosse qualcosa nel swpi.
Posso io da utente fare qualcosa?

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa - 5 Anni 1 Settimana fa #5872 da linxis
Risposta da linxis al topic A530 Canon
Io ho provato l' aggiornamento libgphoto2 ha impiegato circa mezz'ora per farlo.....non finiva più .
Quando ha terminato ho riprovato ma la mia A530 viene vista ma da il solito errore -6 di la camera non fa il capture.
La userò come fotocamera.
Vorrei chiedere a voi esperti....con il comando rw ho abilitato il file system in scrittura...quale comando devo far eseguire perchè la il file system ridiventi protetto in scrittura?
Grazie a chi mi darà questa dritta
Ultima Modifica 5 Anni 1 Settimana fa da linxis.

Si prega Accedi a partecipare alla conversazione.

Di più
5 Anni 1 Settimana fa #5873 da roberto2011
Risposta da roberto2011 al topic A530 Canon
@SlamBall dovresti cambiare nel file camera.py intorno alla line 113 da
words = line.split('usb:')
a
words = line.split('usbscsi:')

@linxis
sudo reboot
al riavvio è di nuovo in sola lettura .

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ringraziano per il messaggio: linxis

Si prega Accedi a partecipare alla conversazione.

Tempo creazione pagina: 0.933 secondi