× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

question-circle Blocco Anomalo Invio Dati al Server Web

Di più
5 Anni 3 Mesi fa #5640 da asy961
OK.
in fase di costruzione avevo provato anch'io a mettere always internet a 0, a me invece consumava più dati in quanto tutte le volte che si connetteva generava del traffico dati per loggarsi e a me interessava di più consumare meno traffico....di batteria ne abbiamo a sufficienza.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa #5641 da asy961
Roberto ho fatto le modifiche che hai postato e non funziona più LogMeIn Hamachi....proverò ad installarlo di nuovo...
mi venuto un'altro dubbio.....
l'SD che preparo a casa su cui installo LogMeIn Hamachi, naturalmente usando un raspberry che ho per prove, una volta che la monto sul raspberry della stazione funziona regolarmente??? non fa riferimento al MAC-Address del raspi??? tu ne sai qualcosa??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa - 5 Anni 2 Mesi fa #5642 da roberto2011
Le modifiche non c'entrano niente con logmein. (riguardano solo il software swpi.
Per ricevere l'ip pubblico.
@Tony lo ricava da google io da un altro sito.
Poca roba ma mi sembra più immediato.)

Logmein non controlla il MAC-Address, io ho fatto come te .


Okkio quando usi questi comandi scrivi rw.altrimenti non riesce a salvare il file di configurazione .
sudo hamachi login
sudo hamachi attach +email ect ect

Per stoppare e fa ripartire il servizio logmein questi sono i comandi.

sudo /etc/init.d/logmein-hamachi stop
sudo /etc/init.d/logmein-hamachi start

Per controllare lo stato
sudo sudo hamachi

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ultima Modifica 5 Anni 2 Mesi fa da roberto2011.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa #5643 da asy961

tony ha scritto: Non capisco nel tuo log del perché di tutti quei : " System time adjusted from NPT server : europe.pool.ntp.org"
???



Tony sarà per questo???

in swpi.py
........
713 # Set Time from NTP ( using a thread to avoid strange freezing )
714 if ( cfg.set_system_time_from_ntp_server_at_startup ):
715 thread.start_new_thread(SetTimeFromNTP, (cfg.ntp_server,))
........
781 # Set Time from NTP ( using a thread to avoid strange freezing )
782 if ( cfg.set_system_time_from_ntp_server_at_startup ):
783 thread.start_new_thread(SetTimeFromNTP, (cfg.ntp_server,))
........
1035 # Set Time from NTP ( using a thread to avoid strange freezing )
1036 if ( cfg.set_system_time_from_ntp_server_at_startup ):
1037 thread.start_new_thread(SetTimeFromNTP, (cfg.ntp_server,))


in particolare le righe 1035, 1036, 1037 sono all'interno del Thread
quindi si ripete ogni webcaminterval

non ricordo bene ma qualche tempo fa facesti una modifica perchè il shutdown_hour_before_sunset calcolava male il tempo residuo, mi sembra proprio perchè lo faceva prima del Set Time from NTP

ma potrei anche sbagliarmi eh ;-)

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa #5644 da asy961

roberto2011 ha scritto: .........

Okkio quando usi questi comandi scrivi rw.altrimenti non riesce a salvare il file di configurazione .

...........


Grazie Roberto, anche se uso la verione 1 di swpi ?? (quella aperta)

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa #5645 da tony
Non ho fatto modifiche al forum. Gli zip non tr ki allega?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa #5646 da asy961
Non so se è ancora presto per dirlo.......
ma con le ultime modifiche di Roberto sono ormai 5 giorni che non si blocca più......

:) :) :) :) :)

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa #5647 da roberto2011
bella notizia
Anche io ho riattivato Belen




@Tony
alla fine ho fatto anche un ulteriore modifica per ricevere l'ip più velocemente ed evitare il timeout
ip = ([(s.connect(('8.8.8.8', 80)), s.getsockname()[0], s.close()) for s in [socket.socket(socket.AF_INET, socket.SOCK_DGRAM)]][0][1])

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 2 Mesi fa - 5 Anni 2 Mesi fa #5656 da asy961
allora, da circa 12 giorni ormai sembra funzionare tutto alla grande....

@roberto @tony
le modifiche sono state implementate e basta fare un swpi-update oppure bisogna ancora caricare manualmente i file che avete postato qua??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 5 Anni 2 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.489 secondi