× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

question-circle Blocco Anomalo Invio Dati al Server Web

Di più
5 Anni 3 Mesi fa #5533 da asy961
Ragazzi ho problema.....
negli ultimi giorni sto riscontrando un problema di invio dati al server web

Tutto funziona regolarmente salvo che ogni tanto si blocca l'invio dei dati al server web mentre il risponditore telefonico funziona bene.

Pensavo ad un problema legato alla connessione ad internet 3G, ma analizzando i log non mi sembra, non da nessun messaggio di errata connessione, sembra che sia proprio configurato per non inviare niente mentre se lo si chiama risponde regolarmente, quindi la parte che legge i sensori ed elabora i dati stà funzionando.

Il software funziona bene poi all'improvviso, quando dovrebbe iniziare a catturare le foto, non cattura più (non capisco se il problema si origina da li) e smette di inviare i dati al server web fino allo spegnimento della sera, nel log compare ciclicamente "General WatchDog : System will Reboot" ma non rebootta mai fino allo spegnimento del sistema, ho anche provato a forzare io il reboot inviandogli l'SMS RTB ma sembra addirittura non ricevere (o ignorare) anche gli SMS.

Al riavvio della mattina invece tutto ritorna funzionare (anche gli SMS) fino al nuovo imprevisto blocco che può avvenire durante il giorno stesso oppure funzionare bene per due o tre giorni e poi bloccarsi nuovamente, fino al successivo riavvio della mattina successiva.



allego un file log dove si vede il problema (inizia circa alle 12,02)
e il file di configurazione



Allegato log15042015.log.zip non trovato




Allegato swpi.cfg.zip non trovato


Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Allegati:

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5578 da asy961
Nonostante alcuni interventi all'alimentazione dei vari componenti (adesso ogni componente ha una sua linea di alimentazione) il problema continua a ripresentarsi...... :( :( :(

inutile allegare gli ultimi log (sembrano fotocopiati) e la configurazione non è stata modificata..........

Davvero strano......

Perché dopo il messaggio che compare ciclicamente "General WatchDog : System will Reboot" ma non rebootta mai????

Un parere, dopo aver analizzato i file allegati, anche dai più esperti sarebbe gradito.....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5579 da roberto2011
Mi ricordo un problema simile anche sulla mia stazione remota.

Controllerei sms reset.

Per un giorno usa come conf.
alwaysoninternet = False
e sposta gli invii ogni 5/10 minuti.

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5580 da asy961
Grazie Roberto,
la stazione è montata su un decollo e non credo di andarci almeno prima di sabato.....proverò le modifiche che mi hai consigliato...
ma la cosa strana è che fino a circa due mesi fa funzionava tutto regolarmente e anche adesso ci sono giorni che non perde un colpo e altri che si blocca a qualsiasi ora.....però se la chiami via telefono la stazione risponde e da i dati regolarmente....

sto anche pensando che sia un problema legato ai lavori che stanno facendo in zona, forse anche ai ponti radio 3G di TRE, quella zona è stata colpita il 5 di marzo da venti fortissimi (come in versilia Forte dei Marmi e dintorni visti in tv) che hanno fatto dei danni gravissimi sia al bosco, con migliaia e migliaia di piante abbattute, che alle linee elettriche molte delle quali sono state interrotte, linee che alimentano oltre alle case della zona anche ripetitori e ponti radio situati li vicino.

Valerio.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5582 da asy961

roberto2011 ha scritto: .....
Controllerei sms reset.
......



scusami Roberto ma non ho capito cosa dovrei controllare.......

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5583 da roberto2011
ciao Valerio
Che versioni hai del software?

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5584 da asy961
1.22.61
credo l'ultimo....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5585 da roberto2011
Penultima ma va benissimo.
hai aggiornato il firmware ultimamente ??hai fatto un upgrade?
Stavo controllando la mia stazione prima di riportarla in decollo e ho notato lo stesso problema .

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ultima Modifica 5 Anni 3 Mesi fa da roberto2011.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5586 da roberto2011
ho risolto aggiornando un pò tutto.

rw
sudo apt-get update
sudo apt-get upgrade
sudo apt-get clean
sudo mount /boot -o remount,rw
sudo rpi-update
reboot

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5587 da tony
Quando la montate in decollo Roberto ? La nostra al Cucco ha dei problemi al sensore autocostruito. Per ora è attiva solo quella telefonica al decollo : 3663575619
TT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5588 da roberto2011
Ciao Tony,
Domani pomeriggio, se non si presentano problemi.
Adesso e in simulazione in ufficio :-)

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5589 da roberto2011
Come non detto ho lo stesso problema di valerio ..
che sarà successo ..
si dimentica di inviare i dati e rimane la connessione attiva anche se impostato su False
Risponde senza problemi

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5590 da tony
Che sensori hai Valerio ?
Se non usi la Davis proverei a ripristinare una vecchia versione.
TT
Ultima Modifica 5 Anni 3 Mesi fa da tony.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5591 da tony
Non capisco nel tuo log del perché di tutti quei : " System time adjusted from NPT server : europe.pool.ntp.org"
???

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5593 da asy961
ciao Tony,
quel messaggio è da un pò di tempo che viene... da alcuni 'aggiornamenti' fa ma non ha mai dato fastidio.....non ricordo da quale versione di fw ha iniziato ma molto tempo fa....io uso sensori vento PCE + DHT11 + BMP085

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5594 da asy961
Proverò a ripristinare anche una vecchia versione.....
com'erano i comandi per tornare ad una vecchia versione???
potresti indicarmeli??
o almeno il post dove l'avevi descritto che non ricordo??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5595 da tony
per esempio per ripristinare la 01.09.35

swpi-update 01.09.35

TT
Ringraziano per il messaggio: asy961

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5596 da asy961
ok....
preparo un nuova sd con una versione più vecchia
1.22.17 potrebbe andare???

poi quando risolvete farò di nuovo un upgrade....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 5 Anni 3 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5597 da asy961

tony ha scritto: Non capisco nel tuo log del perché di tutti quei : " System time adjusted from NPT server : europe.pool.ntp.org"
???


e cmq dopo l'inizo del problema (vedi log ore 12,03 circa) anche la sincronizzazione del time non avviene più.....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5598 da roberto2011
Buongiorno Valerio,
Hai effettuato un sudo apt-get upgrade prima del problema??

Ho notato che l'ultima immagine ha dei problemi di connessione con il ppp(in pratica si connette ma non naviga). Va semplicemente aggiornato.

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5599 da tony
Quindi il problema sembrerebbe legato alla connessione internet 3G e la cosa spiegherebbe tutto.
Quando dici " Va semplicemente aggiornato" cosa intendi precisamente ?
TT

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5600 da roberto2011
Buongiorno Tony.

Prima volevo capire da Valerio se il problema è comparso su un apt-get upgrade oppure sull'aggiornamento di swpi.

nel primo caso basta effettuare di nuovo:
rw
sudo apt-get update
sudo apt-get upgrade
sudo apt-get clean
e si aggiorna il modulo ppp

Se invece è compraso su un aggiornamento swpi bisogna ricontrollare il codice se c'e' qualche incompatibilità.

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5601 da asy961
Ciao Roberto,

no, non aggiornato, lo sto facendo ora che preparo una nuova SD....

però ho qualche problema a fare il downgrade....

pi@swpi ~ $ swpi-update 1.22.33
1.22.33
arguments supplied
www.vololiberomontecucco.it/swpi/swpi_1.22.33.tar.gz
--2015-04-25 12:43:55-- www.vololiberomontecucco.it/swpi/swpi_1.22.33.tar.gz
Risoluzione di www.vololiberomontecucco.it ( www.vololiberomontecucco.it )... 62.149.130.227
Connessione a www.vololiberomontecucco.it ( www.vololiberomontecucco.it )|62.149.130.227|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2015-04-25 12:43:55 ERRORE 404: Not Found.

tar: swpi_1.22.33.tar.gz: funzione "open" non riuscita: File o directory non esistente
tar: Error is not recoverable: exiting now
rm: impossibile rimuovere "swpi_1.22.33.tar.gz": File o directory non esistente
Changing permissions
pi@swpi ~ $ swpi-update 1.22.17
1.22.17
arguments supplied
www.vololiberomontecucco.it/swpi/swpi_1.22.17.tar.gz
--2015-04-25 12:45:34-- www.vololiberomontecucco.it/swpi/swpi_1.22.17.tar.gz
Risoluzione di www.vololiberomontecucco.it ( www.vololiberomontecucco.it )... 62.149.130.227
Connessione a www.vololiberomontecucco.it ( www.vololiberomontecucco.it )|62.149.130.227|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2015-04-25 12:45:39 ERRORE 404: Not Found.

tar: swpi_1.22.17.tar.gz: funzione "open" non riuscita: File o directory non esistente
tar: Error is not recoverable: exiting now
rm: impossibile rimuovere "swpi_1.22.17.tar.gz": File o directory non esistente
Changing permissions
pi@swpi ~ $ swpi-update 1.22.11
1.22.11
arguments supplied
www.vololiberomontecucco.it/swpi/swpi_1.22.11.tar.gz
--2015-04-25 12:45:55-- www.vololiberomontecucco.it/swpi/swpi_1.22.11.tar.gz
Risoluzione di www.vololiberomontecucco.it ( www.vololiberomontecucco.it )... 62.149.130.227
Connessione a www.vololiberomontecucco.it ( www.vololiberomontecucco.it )|62.149.130.227|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2015-04-25 12:45:55 ERRORE 404: Not Found.

tar: swpi_1.22.11.tar.gz: funzione "open" non riuscita: File o directory non esistente
tar: Error is not recoverable: exiting now
rm: impossibile rimuovere "swpi_1.22.11.tar.gz": File o directory non esistente
Changing permissions
pi@swpi ~ $


forse non è possibile farlo con tutte le versioni ma solo con alcune??

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5602 da asy961

roberto2011 ha scritto: Buongiorno Tony.

Prima volevo capire da Valerio se il problema è comparso su un apt-get upgrade oppure sull'aggiornamento di swpi.

nel primo caso basta effettuare di nuovo:
rw
sudo apt-get update
sudo apt-get upgrade
sudo apt-get clean
e si aggiorna il modulo ppp

Se invece è compraso su un aggiornamento swpi bisogna ricontrollare il codice se c'e' qualche incompatibilità.



no, avevo aggiornato solo SWPI

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5603 da roberto2011
manca uno 0
swpi-update 01.22.33

Non hai aggiornato ne swpi ne il sistema ???

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ultima Modifica 5 Anni 3 Mesi fa da roberto2011.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5604 da tony
si .. manca lo 0 .. errore mio :-(

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5605 da asy961

roberto2011 ha scritto: manca uno 0
swpi-update 01.22.33

Non hai aggiornato ne swpi ne il sistema ???


allora.....
dalla versione 01.22.33 sono passato alla 01.22.61
senza aggiornare sudo apt-get update / sudo apt-get upgrade
(o per lo meno non ricordo di averlo fatto, di solito quando funziona non aggiorno mai volentieri....)

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 5 Anni 3 Mesi fa da asy961.

Si prega Accedi o Crea un account a partecipare alla conversazione.

  • fabiomarzaduri
  • Avatar di fabiomarzaduri
  • Visitatori
  • Visitatori
5 Anni 3 Mesi fa #5606 da fabiomarzaduri
Risposta da fabiomarzaduri al topic Blocco Anomalo Invio Dati al Server Web
Buongiorno.
Rischio di dire una cavolata perchè ho una statistica ancora piuttosto corta, ma per ora è un dato di fatto che la mia stazione, da quando ho aggiunto il barometro bmp085, è diventata meno affidabile e smette spesso di inviare i dati al server e necessita di un riavvio per il ripristino...prima che aggiungessi quel sensore (non ho fatto update nè del s.o., nè del fw, nè di swpi) non si bloccava praticamente mai...
Per ora prendete questa affermazione con le pinze, cercherò di fare altre prove poi vi aggiorno.
Saluti, Fabio

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5607 da asy961

tony ha scritto: si .. manca lo 0 .. errore mio :-(


neanche con lo 0


pi@swpi ~ $ swpi-update 01.22.33
01.22.33
arguments supplied
www.vololiberomontecucco.it/swpi/swpi_01.22.33.tar.gz
--2015-04-25 13:17:21-- www.vololiberomontecucco.it/swpi/swpi_01.22.33.ar.gz
Risoluzione di www.vololiberomontecucco.it ( www.vololiberomontecucco.it )... 62.49.130.227
Connessione a www.vololiberomontecucco.it ( www.vololiberomontecucco.it )|62.149.30.227|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2015-04-25 13:17:21 ERRORE 404: Not Found.

tar: swpi_01.22.33.tar.gz: funzione "open" non riuscita: File o directory non eistente
tar: Error is not recoverable: exiting now
rm: impossibile rimuovere "swpi_01.22.33.tar.gz": File o directory non esistent
Changing permissions
pi@swpi ~ $

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5608 da roberto2011
la 33 non funziona prova la 30.
swpi-update 01.22.30

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Ultima Modifica 5 Anni 3 Mesi fa da roberto2011.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.811 secondi