× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Camera Pi e file da 0 k

Di più
5 Anni 3 Mesi fa #5528 da blanco
Camera Pi e file da 0 k è stato creato da blanco
Buona sera a tutti.

In questi giorni stavo provando a scattare foto con la camera pi.
Ho scaricato l'ultima immagine disponibile del SWPI, l'ho montata sulla SD, ho abilitato la camera, ho fatto l'aggiornamento, ho impostato i dati della Camera Pi

camerapi_day_settings = -n -w 1024 -h 768 -ex auto

riavviato tutto e nella cartella img trovo il file raspi+dataeora.jpg solo che sono tutti da 0 (zero) k.

Mi dite dove sbaglio?

Grazie e un saluto a tutti
Francesco

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5529 da asy961
Risposta da asy961 al topic Camera Pi e file da 0 k
posta il file di configurazione (swpi.cfg)
che trovi nella cartella /home/pi/swpi della SD.

prima nascondi le password però.......

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5543 da blanco
Risposta da blanco al topic Camera Pi e file da 0 k
questo è il file swpi.cfg

[General]
station_name = Sint Wind PI
config_web_server = True
config_web_server_port = 80
set_sistem_time_from_ntp_server_at_startup = True
ntp_server = europe.pool.ntp.org
reboot_at = None
shutdown_at = None
shutdown_hour_before_sunset = None
location_latitude = 43.351983
location_longitude = 12.743187
location_altitude = 0
wifi_reset_if_down = False
cloudbase_calib = 1.0
set_time_at_boot = None
wind_speed_units = kmh
ntp_url = None

[Dongle]
usedongle = False
alwaysoninternet = True
donglectrlport = /dev/ttyUSB2
dongleaudioport = /dev/ttyUSB1
dongledataport = /dev/ttyUSB0
usedonglenet = False
operator = tim
prober_timeout = 2
modem_baudrate = 460800
audio_baudrate = 115200
ctrl__baudrate = 9600
dialnum = *99#
pppd_path = /usr/sbin/pppd

[Security]
smspwd = admin

[DataLogging]
logdata = False
serverfile = www.yoursite.it/swpi_logger.php

[Upload]
upload_data = True
upload_folder = /swpi

[Sensors]
sensor_type = SIMULATE
use_wind_sensor = False
number_of_measure_for_wind_dir_average = 10
windspeed_offset = 0
windspeed_gain = 0.6
windmeasureinterval = 5
use_bmp085 = False
use_tmp36 = False
use_dht = False
dht_type = DHT11
number_of_measure_for_wind_trend = 30
wind_trend_limit = 10
number_of_measure_for_wind_average_gust_calculation = 10
davis_error = 0
sensor_temp_out = Default
sensor_temp_in = Default
solarsensor = False
uvsensor = False

[Sensor_PCE-FWS20]
set_system_time_from_weatherstation = False

[Sensor_serial]
sensor_serial_port = /dev/ttyUSB0

[RFM01]
rfm01_frequenzy = 868
rfm01_band = 134
rfm01_lna = 0
rfm01_rssi = 97

[WebCam]
webcamdevice1 = None
webcamdevice2 = None
webcamlogo = www.yoursite.com - 333000000
sendimagestoserver = True
webcaminterval = 100
webcamdevice1captureresolution = 640x480
webcamdevice2captureresolution = 640x480
webcamdevice1finalresolution = 640x480
webcamdevice2finalresolution = 640x480
sendallimagestoserver = True
delete_images_on_sd = True
captureprogram = fswebcam

[Camera]
usecameradivice = True
cameradivicefinalresolution = 800x600
gphoto2options = ,,,,,,,,,,
gphoto2options_night = ,,,,,,,,,,
reset_usb = False
clear_all_sd_cards_at_startup = True
start_camera_number = 1
gphoto2_capture_image_and_download = True
use_camera_resetter = False
camera_resetter_normaly_on = True
on_off_camera = False

[CameraPI]
use_camerapi = True
camerapi_day_settings = -n -w 1024 -h 768 -ex auto
camerapi_night_settings = -n -w 1024 -h 768 -ex auto

[ftp]
ftpserver = ftp.meteobitti.altervista.org
ftpserverdestfolder = /swpi
ftpserverlogin = ***********
ftpserverpassowd = ***********
use_thread_for_sending_to_server = True

[Radio]
useradio = False
radiointerval = 900
radio_verbosity = only_wind
use_ptt = False

[Mail]
gmail_user = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
gmail_pwd = raspberrypi
mail_to = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
use_mail = False
mail_ip = True

[SMS]
send_ip_by_sms = False
number_to_send = +393330000000

[WeatherUnderground]
weatherunderground_logdata = False
weatherunderground_id = KCASANFR5
weatherunderground_password = XXXXXXXX

[DNSExit]
use_dnsexit = False
dnsexit_uname = user
dnsexit_pwd = pwd
dnsexit_hname = xxxx.linkpc.net

[CWOP]
cwop_logdata = False
cwop_id = EW0000
cwop_password = -1

[PWS]
pws_logdata = False
pws_id = KCASANFR5
pws_password = XXXXXXXX

[IPCam]
ipcaminterval = 600
ipcamcfg = None
ipcamip1 = None
ipcamus1 = None
ipcampw1 = None
ipcamsn1 = None
ipcamip2 = None
ipcamus2 = None
ipcampw2 = None
ipcamsn2 = None
ipcamzzz = 0
ipcamposn = None
ipcamposne = None
ipcampose = None
ipcamposse = None
ipcamposs = None
ipcampossw = None
ipcamposw = None
ipcamposnw = None

[LayOut]
laycolortbc = FF99FF
laycolorttc = 0000FF
laycolorbbc = FF99FF
laycolorbtc = 0000FF



e questo swpi da browser

************************************************************************
* Sint Wind PI 01.22.62 *
* *
* 2012-2015 by Tonino Tarsi <Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[18/04/2015-16:56:14] loading plugins
[18/04/2015-16:56:14] Checking internet connetion ...
[18/04/2015-16:56:14] Config Server running on port 80
[18/04/2015-16:56:14] Internet ok
[18/04/2015-16:56:14] Checking internet connetion ...
[18/04/2015-16:56:14] Internet ok
sab 18 apr 2015, 16.56.32, CEST
[18/04/2015-16:56:32] System time adjusted from NPT server : europe.pool.ntp.org
[18/04/2015-16:56:42] Starting General WatchDog
sab 18 apr 2015, 16.56.42, CEST
[18/04/2015-16:56:42] System time adjusted from NPT server : europe.pool.ntp.org
[18/04/2015-16:56:42] No digital cameras found
[18/04/2015-16:56:42] CameraPI - Using Dayligth settings-n -w 1024 -h 768 -ex auto
[18/04/2015-17:03:21] Last main Thread delay ratio: 4.5
[18/04/2015-17:03:21] General WatchDog : System will Reboot
[18/04/2015-17:05:11] Last main Thread delay ratio: 5.6
[18/04/2015-17:05:11] General WatchDog : System will Reboot
[18/04/2015-17:07:01] Last main Thread delay ratio: 6.7
[18/04/2015-17:07:01] General WatchDog : System will Reboot
[18/04/2015-17:08:06] Starting SINT WIND PI ...


questo da putty:

************************************************************************
* Sint Wind PI 01.22.62 *
* *
* 2012-2015 by Tonino Tarsi <Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.> *
* *
* System will start in 10 seconds - Press Ctrl-C to cancel *
************************************************************************
10.....9.....8.....7.....6.....5.....4.....3.....2.....1.....
[18/04/2015-17:16:27] loading plugins
[18/04/2015-17:16:27] Checking internet connetion ...
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "/home/pi/swpi/web_server.py", line 242, in run
s=SocketServer.TCPServer(("",port),ScriptRequestHandler)
File "/usr/lib/python2.7/SocketServer.py", line 419, in __init__
self.server_bind()
File "/usr/lib/python2.7/SocketServer.py", line 430, in server_bind
self.socket.bind(self.server_address)
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

[18/04/2015-17:16:27] Internet ok
[18/04/2015-17:16:27] Checking internet connetion ...
[18/04/2015-17:16:27] Internet ok
sab 18 apr 2015, 17.16.28, CEST
[18/04/2015-17:16:28] System time adjusted from NPT server : europe.pool.ntp.org
[18/04/2015-17:16:28] Connected with IP : *********
[18/04/2015-17:16:28] Starting General WatchDog
sab 18 apr 2015, 17.16.29, CEST
[18/04/2015-17:16:29] System time adjusted from NPT server : europe.pool.ntp.org
[18/04/2015-17:16:29] No digital cameras found
[18/04/2015-17:16:29] CameraPI - Using Dayligth settings-n -w 1024 -h 768 -ex auto
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Traceback (most recent call last):
File "swpi.py", line 924, in <module>
bcPI = cPI.capture(cPIFilemane)
File "/home/pi/swpi/cameraPI.py", line 41, in capture
log( "ERROR in capturing webcam image on : " + self.device )
AttributeError: 'cameraPI' object has no attribute 'device'
Ultima Modifica 5 Anni 3 Mesi fa da blanco.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa - 5 Anni 3 Mesi fa #5545 da asy961
Risposta da asy961 al topic Camera Pi e file da 0 k
Ciao,

prova a modificare

[WebCam]
webcamdevice1 = None
webcamdevice2 = None
webcamlogo = www.yoursite.com - 333000000
sendimagestoserver = True
webcaminterval = 100
webcamdevice1captureresolution = 640x480
webcamdevice2captureresolution = 640x480
webcamdevice1finalresolution = 640x480
webcamdevice2finalresolution = 640x480
sendallimagestoserver = True --- con False
delete_images_on_sd = True
captureprogram = fswebcam

[IPCam]
ipcaminterval = 600 ---- metti 1


poi prova il comando diretto

raspstill -v -o test.jpg

dovrebbe farti vedere l'immagine per circa 5 secondi sul monitor e dopo chiederti di salvare il file test.jpg
se non funziona prova ad entrare in
sudo raspi-config
ed abilitare la CameraPI
poi riprova il comando raspistill
se non ti funziona ancora prova a sostituire la CameraPI

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ultima Modifica 5 Anni 3 Mesi fa da asy961.
Ringraziano per il messaggio: blanco

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 3 Mesi fa #5546 da blanco
Risposta da blanco al topic Camera Pi e file da 0 k
ciao :(
ho provato a seguire il tuo consiglio ma:

pi@swpi ~ $ raspistill -v -o test.jpg

raspistill Camera App v1.2

Width 2592, Height 1944, quality 85, filename test.jpg
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Full resolution preview No

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 400, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.540 secondi