× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Sint wind pi non esegue upload

Di più
5 Anni 4 Mesi fa #5479 da marconi
ciao, Stazione wh-1080 configurata come PCE-FWS20, server altervista, funziona tutto, ma non esegue upload del file meteo.txt. :(
messaggi:
uploading data...
exception
errno -21 nome o servizio sconosciuto
error sending file to server :meteo.txt
delete file: ./meteo.txt

Per favore qualcuno mi può spiegare che succede?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5482 da enrico.crola
prova a mettere il sistema su classe ip 192.168.1.x ... avevo il tuo stesso problema, ero su classe diversa dalla 1, messo, ha iniziato a trasmettere.
Ringraziano per il messaggio: marconi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5483 da marconi
Ciao, scusa la mia ignoranza, ma che significa in pratica mettere il sistema su classe IP ecc...?

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5484 da enrico.crola
avrai un dhcp che ti rilascia l'ip della tua rete, giusto ? il pc/route/raspberry hanno un ip assegnato ... ho visto che tutto il sistema funziona su classe 1
da un pc fai un ipconfig/all vedi il tuo ip
Ringraziano per il messaggio: marconi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5485 da marconi
ip 192.168.1.104 con il quale faccio la connessione per il config di swpi, metto i parametri così come spiegato nelle istruzioni per l'istallazione e tutto va ok. quando raspberry comincia a lavorare, rileva i dati dalla centralina. tutto ok, quando cerca di connettersi al server su altervista, mi da l'errore citato nel post precedente.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5486 da asy961
Risposta da asy961 al topic Sint wind pi non esegue upload
@marconi

posta il file di configurazione di swpi (swpi.cfg) omettendo le password

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ringraziano per il messaggio: marconi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa - 5 Anni 4 Mesi fa #5488 da marconi
scusa, ma comincio a perdere colpi. quale è la procedura con windovs per postare il file? il sito attualmente funziona con cumulus. Cumulus ha bisogno di un pc sempre acceso e collegato conclusione molto impegnativo. SWPI può lavorare da solo, per favore siate pazienti ed aiutatemi :)
Ultima Modifica 5 Anni 4 Mesi fa da marconi.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5489 da asy961
Risposta da asy961 al topic Sint wind pi non esegue upload
accedi alla configurazione via web con un browser (io uso firefox) digitando l'indirizzo ip del raspberry nella barra degli indirizzi, poi digita la password per autenticarti (di default è admin) poi cerca la funzione per salvare la configurazione. Una volta salvata aprila con un editor di testo (di solito notepad o wordpad) e postala qui, naturalmente dopo aver nascosto le password.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ringraziano per il messaggio: marconi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa - 5 Anni 4 Mesi fa #5491 da marconi
ecco, sto cercando di imparare.
[General]
station_name = Marconi
config_web_server = True
set_sistem_time_from_ntp_server_at_startup = False
ntp_server = time.windows.com
reboot_at = None
shutdown_at = None
shutdown_hour_before_sunset = None
location_latitude = 37.684523
location_longitude = 13.831884
location_altitude = 470.0
wifi_reset_if_down = True
config_web_server_port = 80
cloudbase_calib = 1.0
set_time_at_boot = None
wind_speed_units = kmh
ntp_url = None

[Dongle]
usedongle = False
alwaysoninternet = True
donglectrlport = /dev/ttyUSB2
dongleaudioport = /dev/ttyUSB1
dongledataport = /dev/ttyUSB0
usedonglenet = False
operator = tim
prober_timeout = 2.0
modem_baudrate = 460800
audio_baudrate = 115200
ctrl__baudrate = 9600
dialnum = *99#
pppd_path = /usr/sbin/pppd

[Security]
smspwd = admin

[DataLogging]
logdata = False
serverfile = www.vallelungameteo.altervista.org/swpi_logger.php

[Upload]
upload_data = True
upload_folder = /swpi

[Sensors]
sensor_type = PCE-FWS20
davis_error = 0
use_wind_sensor = True
number_of_measure_for_wind_dir_average = 10
windspeed_offset = 0.0
windspeed_gain = 1.0
windmeasureinterval = 5
use_bmp085 = False
use_tmp36 = False
use_dht = False
dht_type = DHT11
number_of_measure_for_wind_trend = 30
wind_trend_limit = 10.0
number_of_measure_for_wind_average_gust_calculation = 10
sensor_temp_out = Default
sensor_temp_in = Default

[Sensor_PCE-FWS20]
set_system_time_from_weatherstation = True

[Sensor_serial]
sensor_serial_port = /dev/ttyUSB0

[RFM01]
rfm01_frequenzy = 868
rfm01_band = 134
rfm01_lna = 0
rfm01_rssi = 97

[WebCam]
webcamdevice1 = None
webcamdevice2 = None
webcamlogo = www.yoursite.com - 333000000
sendimagestoserver = False
webcaminterval = 600
webcamdevice1captureresolution = 640x480
webcamdevice2captureresolution = 640x480
webcamdevice1finalresolution = 640x480
webcamdevice2finalresolution = 640x480
captureprogram = fswebcam
sendallimagestoserver = False
delete_images_on_sd = False

[Camera]
usecameradivice = True
cameradivicefinalresolution = 800x600
gphoto2options = ,,,,,,,,,,
gphoto2options_night = ,,,,,,,,,,
reset_usb = False
clear_all_sd_cards_at_startup = True
start_camera_number = 1
gphoto2_capture_image_and_download = True
use_camera_resetter = False
camera_resetter_normaly_on = True

[CameraPI]
use_camerapi = False
camerapi_day_settings =
camerapi_night_settings =

[ftp]
ftpserver = ftp.vallelungameteo.altervista.org
ftpserverdestfolder = www.vallelungameteo.altervista.org/swpi
ftpserverlogin = xxxxxxxxxxxxxxx
ftpserverpassowd = xxxxxxxxxxxxxx
use_thread_for_sending_to_server = True

[Radio]
use_ptt = False
radiointerval = 900
radio_verbosity = only_wind
useradio = False

[Mail]
gmail_user = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
gmail_pwd = raspberrypi
mail_to = Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.
use_mail = False
mail_ip = True

[SMS]
send_ip_by_sms = False
number_to_send = +393330000000

[WeatherUnderground]
weatherunderground_logdata = False
weatherunderground_id = KCASANFR5
weatherunderground_password = XXXXXXXX

[PWS]
pws_logdata = False
pws_id = KCASANFR5
pws_password = XXXXXXXX

[CWOP]
cwop_logdata = False
cwop_id = EW0000
cwop_password = -1

[DNSExit]
use_dnsexit = False
dnsexit_uname = user
dnsexit_pwd = pwd
dnsexit_hname = xxxx.linkpc.net

[IPCam]
ipcaminterval = 600
ipcamcfg = None
ipcamip1 = None
ipcamus1 = None
ipcampw1 = None
ipcamsn1 = None
ipcamip2 = None
ipcamus2 = None
ipcampw2 = None
ipcamsn2 = None
ipcamzzz = 0
ipcamposn = None
ipcamposne = None
ipcampose = None
ipcamposse = None
ipcamposs = None
ipcampossw = None
ipcamposw = None
ipcamposnw = None

[LayOut]
laycolortbc = FF99FF
laycolorttc = 0000FF
laycolorbbc = FF99FF
laycolorbtc = 0000FF
Ultima Modifica 5 Anni 4 Mesi fa da marconi.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa - 5 Anni 4 Mesi fa #5492 da blanco
Risposta da blanco al topic Sint wind pi non esegue upload
ciao, prova a cambiare il parametro ftp:

questo il tuo:
[ftp]
ftpserver = ftp.vallelungameteo.altervista.org
ftpserverdestfolder = www.vallelungameteo.altervista.org/swpi
ftpserverlogin = xxxxxxxxxxxxxxx
ftpserverpassowd = xxxxxxxxxxxxxx
use_thread_for_sending_to_server = True


cambia in:
[ftp]
ftpserver = ftp.vallelungameteo.altervista.org
ftpserverdestfolder = /swpi
ftpserverlogin = xxxxxxxxxxxxxxx
ftpserverpassowd = xxxxxxxxxxxxxx
use_thread_for_sending_to_server = True
Ultima Modifica 5 Anni 4 Mesi fa da blanco.
Ringraziano per il messaggio: marconi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5494 da marconi
grazie blanco, ma non cambia nulla. Dispongo di raspberry Pi 2 model B 2014

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5495 da asy961
Risposta da asy961 al topic Sint wind pi non esegue upload
prova a mettere
[ftp]
ftpserver = ftp.vallelungameteo.altervista.org
ftpserverdestfolder = /swpi/img
ftpserverlogin = xxxxxxxxxxxxxxx
ftpserverpassowd = xxxxxxxxxxxxxx
use_thread_for_sending_to_server = True


e ricontrolla di aver inserito user ftp giusto (dovrebbe essere vallelungameteo)
e la giusta password ftp

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa - 5 Anni 4 Mesi fa #5498 da marconi
ASY961 eseguito il suggerimento, ma non cambia nulla. credo che sia un problema legato alla connessione ad internet. Seguendo le istruzioni del tutorial, all'inizio dell'istallazione, la prima volta bisogna fare swpi-upload. dopo aver dato il comando ottengo la risposta che non trova il file dell'upgrade swpi-src.tar. Però il file è presente su vololiberomontecucco e scaricabile con windows. Quindi deduco che swpi, anche se da il messaggio "internet ok" in realtà non si connette.
Non è un problema Hardware perchè con un'altra scheda con debian si connette ad internet regolarmente.
Ultima Modifica 5 Anni 4 Mesi fa da marconi.

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5499 da asy961
Risposta da asy961 al topic Sint wind pi non esegue upload
intanto il comando giusto è swpi-update e non upload

ricontrolla bene il collegamento ad internet e
i dati di accesso FTP ad Altervista

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Ringraziano per il messaggio: marconi

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5504 da marconi
Scusate, non riesco a capirci. Mi connetto con filezilla ed è tutto ok. Uso gli stessi parametri con swpi ed il raspberry e non è possibile spedire files al server. Cosa molto strana non si collega nemmeno con vololiberomontecucco per fare swpi-update, anche se comunica che e connesso con internet. A questo punto per evitare di perdere completamente il senno credo che dovrò rinunciare. Per me è un problema di compatibilità con swpi ed il mio raspberry. :(

Si prega Accedi o Crea un account a partecipare alla conversazione.

Di più
5 Anni 4 Mesi fa #5506 da blanco
Risposta da blanco al topic Sint wind pi non esegue upload
Magari sbaglio ma l'indirizzo del server NTP per sincronizzare l'ora non dovrebbe essere
europe.pool.ntp.org

Nella tua configurazione hai messo: time.windows.com

Francesco

Si prega Accedi o Crea un account a partecipare alla conversazione.

Tempo creazione pagina: 0.718 secondi