× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file release 01.26.98 su SD

More
1 year 6 months ago #8448 by Nello
release 01.26.98 su SD was created by Nello
Salve a tutti.
Dopo diverse prove facendomi prestare un altro raspberry PI (zero wh)
sono riuscito a preparare una scheda SD funzionante anche su ultimi modelli (3B +)
fino ad ora non ero riuscito a farlo funzionare.
SE a qualcuno interessa, dato che non saprei dove fare upload, può chiederlo
ed in qualche modo lo posso inviare.

GRATUITAMENTE SIA CHIARO!

Please Log in to join the conversation.

More
1 year 5 months ago #8453 by danypowersport
A me interesserebbe molto!

Please Log in to join the conversation.

More
1 year 5 months ago - 1 year 5 months ago #8454 by Nello
Replied by Nello on topic release 01.26.98 su SD
Hai qualche idea di come poter fare il trasferimento del file? sono circa 2,6 giga.
Last edit: 1 year 5 months ago by Nello.

Please Log in to join the conversation.

More
1 year 5 months ago #8455 by danypowersport
Dipende molto dalla tua velocità di connessione in upload. Se è sufficiente, ci sono siti web come transfernow.net che permettono di allegare file di grandi dimensioni e inviarli via “mail”. Se per te va bene ti mando in privato la mia email

Please Log in to join the conversation.

More
1 year 5 months ago #8456 by danypowersport
Alternativamente posso aprirti in scrittura una mia cartella di google drive, mandarti il link, così puoi caricarlo lì!

Please Log in to join the conversation.

More
1 year 5 months ago #8457 by Nello
Replied by Nello on topic release 01.26.98 su SD
Ho Tim fibra con 10mega in uload.
Se l'ultimo metodo e rapido usiamo quello.

Please Log in to join the conversation.

More
1 year 5 months ago #8458 by danypowersport
Ottimo. Io adesso sono fuori casa ma in un paio d’ore rientro e ti preparo tutto

Please Log in to join the conversation.

More
1 year 5 months ago #8459 by Nello
Replied by Nello on topic release 01.26.98 su SD
Ok. Quando vuoi.

Please Log in to join the conversation.

More
1 year 5 months ago #8460 by danypowersport
drive.google.com/drive/folders/1C8JQ9une...jWXCQjsS?usp=sharing

Prova a vedere, dovresti poter accedere in scrittura e quindi caricare l'immagine

Please Log in to join the conversation.

More
1 year 5 months ago #8461 by danypowersport
Ciao ho visto che hai messo due file, quale dovrei prendere?

Please Log in to join the conversation.

More
1 year 5 months ago - 1 year 5 months ago #8462 by Nello
Replied by Nello on topic release 01.26.98 su SD
sono identici,
in pratica sono configurati cosi:
1) immagine che poi viene decompressa utilizzando tutto lo spazio sulla SD.
2) immagine che occupa 4/8 giga (lasciando lo spazio dopo libero (da formattare)

non ricordo quale sia l'uno o l'altro.
Fammi poi sapere se funziona tutto.
Nello Menchini

PS. ovviamente ci saranno delle usr/passw e link da cambiare (sono i miei)
Last edit: 1 year 5 months ago by Nello.

Please Log in to join the conversation.

More
1 year 5 months ago #8463 by danypowersport
Non ho avuto modo di indagare a fondo, cercherò di farlo domani, tuttavia ho preso le due immagini e le ho caricate su due SD diverse.
Risultato identico: entrambe, sul mio raspberry PI3 mod. B+, NON funzionano. Il sistema non sale, sullo schermo HDMI vedo il classico rettangolo multicolore ma nulla più.

Please Log in to join the conversation.

More
1 year 5 months ago #8464 by Nello
Replied by Nello on topic release 01.26.98 su SD
strano. piu tardi riprovo io qui in casa, sul raspberry wh funziona perfettamente.
Riprovo poi su RPi 3B+
Che io sappia sul WH una volta dato sudo apt-get updaate && upgrade.
si dovrebbe aggiornare tutto senza rogne.
vedo semmai se posso darti anche una dritta
sul come fare funzionare sul 3B+ combiando il kernel

Please Log in to join the conversation.

More
1 year 5 months ago #8465 by danypowersport
Io purtroppo il WH non ce l'ho. Ho solo due modelli di 3B+, e sto provando sull'ultimo che ho comprato (la settimana scorsa!)
Posso anche provare su quello più datato, per escludere che non sia difettoso l'hardware, però provando a mettere su una SD raspbian puro, il sistema si avvia.
Di fatto da quell'ambiente (3B+) non posso muovermi. Infatti ho provato già tutte le immagini che ci sono qui sul forum nella sezione download e non ne funziona nemmeno una: il tuo post mi è sembrato una manna dal cielo, mi spiace tantissimo che nemmeno le tue immagini mi abbiano portato ad avere il sistema funzionante.

Please Log in to join the conversation.

More
1 year 5 months ago #8466 by Nello
Replied by Nello on topic release 01.26.98 su SD
Hai modo e maniera di scaricare un raspbian, e metterlo su di 1 scheda?
una volta fatto con windows dovrai entrare nella partizione di boot e la sola che sia apribile senza problemi, troverai alcuni file chiamati:
bcm27**.dtb (gli asterischi e facilecapire a cosa si riferiscono)
copiali sulla scheda che hai preparato con il mio file.
dopo prova rimettere la scheda modificata sul raspberry avvialo e vedi che succede.

se non dovesse bastare copia anche i file:
start.elf, start_x.elf, start_db.elf, start_cd.elf

e riprova d nuovo, se ancora non va aggiungi:
fixup.dat, fixup_x.dat, fixup_db.dat, fixup_cd.dat

Questi sono i file che rendono avviabile il raspberry

Please Log in to join the conversation.

More
1 year 5 months ago #8467 by danypowersport
Posso farlo, ma non in questo momento! Proverò domani mattina e ti farò sapere non appena possibile!
Intanto grazie di tutto

Please Log in to join the conversation.

More
1 year 5 months ago #8468 by Nello
Replied by Nello on topic release 01.26.98 su SD
di nulla, figurati.
mi spiace solo che non è andata come volevamo..
fai sapere in qualche modo ci si riuscirà

Please Log in to join the conversation.

More
1 year 5 months ago - 1 year 5 months ago #8469 by danypowersport
Contrariamente a quanto pensavo, sono riuscito adesso.
Allora... la sola sostituzione dei file bcm27** non è stata sufficiente; ho dovuto anche sovrascrivere i start.*
A quel punto si è avviato il sistema.
Dopo il loading del kernel, vedo che si è avviato lo script "swpy".
Ecco l'output:

pi@swpi ~/swpi $ Traceback (most recent call last):
File "swpi.py", line 23, in <module>
import camera
File "/home/pi/swpi/camera.py", line 22, in <module>
import RPi._GPIO as GPIO
File "/usr/lib/python2.7/dist-packages/RPi/GPIO/__init__.py", line 23, in <module>
from RPi._GPIO import *
RuntimeError: This module can only be run on a Raspberry Pi!

PS ti lascio la mia mail,
Last edit: 1 year 5 months ago by danypowersport.

Please Log in to join the conversation.

More
1 year 5 months ago #8470 by Nello
Replied by Nello on topic release 01.26.98 su SD
Ok.
non sono lo sviluppatore e mi limito alle mie conoscenze.
vediamo se risolviamo i problemi.

Please Log in to join the conversation.

Time to create page: 0.743 seconds