× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file BMP280

More
10 months 4 weeks ago #8287 by cris993
BMP280 was created by cris993
Salve a tutti,
ho acquistato un sensore BMP280 per sostituire il BMP180, per poter avere più accuratezza dei dati....
Il problema? indirizzo Ic2 non è compatibile, o meglio facendo scansione mi trova il sensore in porta 66, e non 77 com il BMP180......
Se selezioni su SintWind BME... allota lo legge, senzà umidità naturalmente....
Chiedo se è possibile sostituire il numero porta per far funzionare correttamente il BMP280....
Grazie a tutti.
Cristian

Please Log in or Create an account to join the conversation.

More
10 months 4 weeks ago #8288 by tony
Replied by tony on topic BMP280
stranissimo 66 :-(
Dovrebbe essere 77 o 78.
Unica soluzione è quello di patchare il codice. Vedi il file bme280.py
TT

Please Log in or Create an account to join the conversation.

More
10 months 4 weeks ago #8289 by cris993
Replied by cris993 on topic BMP280
Ciao Tony,
devo modificare il file BMP085.py ?

Please Log in or Create an account to join the conversation.

More
10 months 3 weeks ago #8290 by cris993
Replied by cris993 on topic BMP280
Scusa Tony, ho verificato bene, il BMP280 che ho provato ha address I2C 76 (non 66).....

Please Log in or Create an account to join the conversation.

More
10 months 3 weeks ago #8291 by cris993
Replied by cris993 on topic BMP280
Risolto...... ho ordinato il sensore BMP280 Adafruit, quello ha indirizzo I2C corretto.... quello a basso costo Cinese non va bene....troppo complicato modificare SintWind non vale la pena....
Grazie ancora Tony.

Please Log in or Create an account to join the conversation.

More
10 months 2 weeks ago #8292 by amonphi
Replied by amonphi on topic BMP280
Ciao ragazzi

mi aggiungo alla discussione senza aprirne un'altra....
io ho un sensore BME280 e funziona benissimo (in contemporanea ho anche la consolle della PCE attiva momentaneamente), almeno sembra...nel senso che i valori li leggo se faccio un test da putty e ad esempio se il BME280 riporta

temp : 26.08 ℃
pressure : 970.94 hPa
hum : 41.38 %

in dashboard di swpi web riporta

temp : 26.09 ℃
pressure : 1015.21 hPa
hum : 41.28 %

Presumo che avendo sia consolle che BME attivi, (i dati li ricevo con penna usb DVB-T) i valori che leggo in dashboard siano quelli del BME giusto?

Ma come mai la pressione differisce così tanto?

Oppure non mi è chiaro qualcosa (cosa più probabile)

Intanto buona serata e grazie in anticipo a tutti

Please Log in or Create an account to join the conversation.

More
10 months 2 weeks ago #8293 by amonphi
Replied by amonphi on topic BMP280
Forse ho capito da solo,

il sensore BME280 riporta la pressione assoluta mentre in dashboard la relativa giusto?

Please Log in or Create an account to join the conversation.

More
10 months 2 weeks ago #8297 by cris993
Replied by cris993 on topic BMP280
Arrivato il nuovo sensore BMP280 Adafruit....
Collegato..... funziona... indirizzo I2C perfetto..

Problema.... di default manda letture in gradi F e pressione in kPA......

Cosa devo modificare per cambiare la scala ??? in C e hPA ??
Grazie.

Please Log in or Create an account to join the conversation.

Time to create page: 0.424 seconds