× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

lightbulb Ricezione dati con chiavetta USB DVB rtl433

More
2 years 7 months ago #7382 by seven
Noo, Valerio, infatti non lo contiene... Finora anzi mi pare non sia mai stata nemmeno considerata l'ipotesi di selezionare un singolo ID sensore, neanche all'interno del codice RFM01.
Ritengo si tratti di casi limite (per carità: sempre possibili, tuttavia remoti come probabilità...) avere la sfiga che il vicino si compri la stazione meteo identica alla propria :lol: :lol: :lol:

Per questo considero sia meno laborioso modificare da sè -in caso di necessità- il file sensor_wh1080rtlsdr.py così come esposto sopra anzichè sclerare per implementare la funzione direttamente nel pannello di controllo (le variazioni da eseguire in questo caso sarebbero moooolto numerose, credimi), anche se indubbiamente una volta fatto il lavoro renderebbe swpi ancora più fantastico. ;)

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago - 2 years 7 months ago #7384 by asy961

seven wrote: .........
Per questo considero sia meno laborioso modificare da sè -in caso di necessità- il file sensor_wh1080rtlsdr.py così come esposto sopra anzichè sclerare per implementare la funzione direttamente nel pannello di controllo (le variazioni da eseguire in questo caso sarebbero moooolto numerose, credimi), anche se indubbiamente una volta fatto il lavoro renderebbe swpi ancora più fantastico. ;)



Lo penso anch'io Nicola....
è un pò una mia fissa cercare eventuali anomalie e provare a risolverle ;)

EDIT:
un pò come questo 'piccolo' problemino ....


Valerio

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Last edit: 2 years 7 months ago by asy961.

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7419 by hoshi_90
Ciao a tutti e complimenti per il lavoro sull'implementazione dei driver rtl443
eliminando il rognoso RFM01!
Ho voluto provarlo, ma ho un problema con l'avvio del tutto, vuol dire:
1. montato l'immagine 845 su una SD fresca
2. fatto l'update di SWPI attraverso Webconfig su ver. 1.23.96
3. fatto le impostazioni di "swpi.cfg" attraverso Webconfig settando su RTL-SDR

La chiavetta DVB-T usata è questa: www.amazon.it/gp/product/B013Q97J8W/ref=...01_s00?ie=UTF8&psc=1

SWPI parte, ma non trova la chiavetta DVB-T e arresta...
cosa possto fare? O cosa ho sbagliato/dimenticato?
Devo dire che non sono proprio un drago di linux, ho soltanto qualche conoscenza di base

immagine allegata contiene lo screenshot dell'errore
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7421 by asy961
Ciao hoshi_90

leggiti bene questo argomento dall'inizio

e se non risolvi leggiti anche questo

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7422 by hoshi_90
Grazie asy961 della veloce risposta, ma prima di scrivere qui mi sn letto e riletto tutti i post relativi alla chiavetta rtl-sdr sul forum e ho provato varie volte, già perché nn chiedo volentieri aiuto, solo se proprio nn riesco a farlo dasolo...

la cosa più comoda sarebbe un'immagine ver.845 con tutto già installato, ma il link download non funziona... www.vololiberomontecucco.it/vlmc/index.p...usb-rtl-sdr-per-swpi

A installare manualmente mi esce sempre lo stesso errore quando immetto il comando "cmake" mi esce

pi@swpi ~/swpi/rtl-sdr/build $ cmake ../ -DINSTALL_UDEV_RULES=ON -DDETACH_KERNEL_DRIVER=ON
-bash: cmake: command not found
pi@swpi ~/swpi/rtl-sdr/build $

Cosa stò sbagliando?

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago - 2 years 7 months ago #7423 by asy961
@hoshi_90

sembra un problema di librerie

leggi bene questo post

e i successivi 6/7 post a seguire...almeno fino a questo

facci sapere

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Last edit: 2 years 7 months ago by asy961.
The following user(s) said Thank You: hoshi_90

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7424 by hoshi_90
Ho appena provato a seguire le indicazioni del tuo link, ma quando provo a installare qualcosa mi dice che il sistema è di sola lettura..

pi@swpi ~ $ sudo apt-get -y install libusb-1.0-0-dev cmake
W: Blocco disabilitato per il file di blocco in sola lettura /var/lib/dpkg/lock
E: Impossibile scrivere in /var/cache/apt/
E: L'elenco dei pacchetti o il file di stato non può essere letto o aperto.

anche con "sudo apt-update/upgrade" stessa cosa
Come posso togliere la sola lettura? c'é un comando come in swpi ver.3 tipo "rw-ro" per togliege/mettere la sola lettura?
Ho cercato un po nel forum ma nn ho trovato nulla..

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7425 by asy961
prima devi mettere il sistema in scrittura con rw

quando hai finito esegui un sudo reboot

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
The following user(s) said Thank You: hoshi_90

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7429 by hoshi_90
Mi è uscito ancora qualche errore, ma intanto funziona!
Mille grazie asy961 dell'aiuto! :)

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7483 by hoshi_90
Buon giorno a tutti, dopo aver risolto un paio di settimane fà il funzionamento con la chiavetta RTL-SDR ho notato ricceve valori di temperatura sballati (oltre i 200°C) questo accade all'incirca ogni 2 ore per 3-4 minuti, poi funziona normalmente...
Qualcuno che usa la chiavetta RTL-SDR ha riscontrato il mio stesso o simile problema?

Nn sò se centra, ma i sensori esterni funzionano con normali pile alkaline e senza sensore pioggia (rimosso sensore pioggia e panellino solare per poter usare pile non riccaricabili)

qui il link Wunderground per vederlo sul grafico:
www.wunderground.com/personal-weather-st...=ITRENTIN118#history

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7484 by seven
Ciao!
Che tipo di stazione meteo possiedi?
Nik

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7485 by hoshi_90
Possiedo una PCE-FWS 20 versione con panellino solare il quale ho rimosso assieme al sensore pioggia per metterci le alkaline normali..

-Funziona su di un RaspB B+ ataccato 24/7 in rete attraverso ethernet
-Ricevitore è la chiavetta RTL-SDR lincata un paio di post prima
-Viene alimentato con 5v 2.1A
-sensori e riccevitore sono a 3m linea d'aria (con finestra in mezzo)

È funzionato per 2 anni e mezzo circa con alternativamente ataccato la stazione PCE o il modulo RFM01 senza mai avere questo problema...
Il ricevitore RFM01 ogni tanto diceva "BAD DATA RECEIVED" che lo rendeva poco affidabile..
La stazione PCE invece nn ha mai avuto problemi di ricezzione, neanche adesso, ma siblocca ogni paio di giorni...

Questo errore dei picchi di temperatura me li fa da quando ho la chiavetta RTL-SDR e quasi sul minuto ogni 2 ore (per 3-4 minuti, cioè 5-6 pacchetti riccevuti ogni 48 secondi).
Ho letto da qualche parte che il sensore temperatura ricceve ogni 2 ore l'ora attraverso segnale radio, così ho provato ad accendere e spegnere la funzione della sincronizzazione dell'ora attraverso la chiavetta RTL-SDR perché mi pareva nn funzionasse (acceso per 24h avendo disattivato il NTP da internet. nessuna sincronizzazione dell'ora)

Un idea di cosa può essere?
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7486 by asy961
@hoshi_90

puoi postare la configurazione completa (omettendo le password) ?

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7487 by hoshi_90
Ecco qui il file swpi.cfg:
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #7488 by seven
Si dai ora è chiaro: è il famoso trasmettitore ad 87 bit ;)

In poche parole il trasmettitore dei tuoi sensori usa un protocollo leggermente diverso da quello che ho usato per 'confezionare' il driver rtl-sdr.
Con Asy abbiamo già risolto il problema, ma non ho ancora sottoposto un merge a Tony.

La soluzione è scaricare rtl_433 da GitHub, modificare un file aggiungendo qualche comando e ricompilarlo. L'intera operazione è descritta in questo post
Last edit: 2 years 6 months ago by seven.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #7489 by asy961
@Hoshi_90

la soluzione indicata da Seven credo sia giusta in quanto nella configurazione non emergono errori....

mi sono accorto che non hai il sensore di pressione.....
è una scelta o una mancanza??

se vuoi puoi montare un sensorino cinese che costa veramente poco e funziona niente male.....

lo trovi qui ed è un clone del Bosch BME280

per il montaggio puoi seguire questa discussione





@Nicola

non ci crederai ma ultimamente ho testato la chiavetta con un gruppo sensori PCE montato a 500 metri di distanza in aria libera e riceveva che un piacere B) B) B)
incredibile !!!

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah
Last edit: 2 years 6 months ago by asy961.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7490 by hoshi_90
Grazie seven e asy961 dell'aiuto!
Proverò le soluzioni da voi proposte.

@asy961
sensore pressione è una mancanza, dato che usando la stazione-schermo PCE usava il sensore integrato..

Ho letto il tread del sensore BME280 un paio di giorni fà e stavo giocando con l'idea di montarne uno.. però prima vorrei far funzionare il resto dei sensori con la chiavetta RTL-SDR in maniera da nn dover smanettare ogni paio di gg sulla stazione (fuori stagione ci si mette 1 ora a piedi fin qui)..

Giocavo anche con l'idea di eliminare i sensori radio e metterci il BME280 con sensoriPCE ataccati via cavo (attraverso MCP3002) ma allora perdo il sensore pioggia giusto?

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7491 by asy961

hoshi_90 wrote: ....... ma allora perdo il sensore pioggia giusto?



esatto,
l'unico modo per mantenere tutti i sensori è la ricezione via radio (PCE, RFM01, RTL-SDR) non ricordo nessuno che abbia implementato il sensore pioggia sulla GPIO (ma potrei anche sbagliarmi), a meno che il dato della pioggia non sia per te rilevante, dipende dalla funzione della tua stazione.

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #7492 by hoshi_90
Ancora nn funziona..
Ieri venerdi ho seguito le istruzzioni per il driver a 87bit e sembrava tutto ok..
Stamattina ho controllato il log su Wunderground e nn ha risolto il problema..

Cosi ho deciso di riinstallare la modifica, facendo attenzione a eventuali anomalie in fase di CMAKE,MAKE,SUDO MAKE INSTALL

Al 2. passo (MAKE) mi è uscito un errore, ma nn so cosa significa :unsure:
Ho allegato uno screenshot

La cartella "mod" nella string
pi@swpi~/swpi/mod/src/build $
è la cartella in cui ho scompattato l'interno della cartella rtl_433 da github e sustituito il file modificato per gli 87bit.

@asy961
Il sensore pioggia nn mi è tanto importante, ma avendolo vorrei anche usarlo.. sennò avrei già da tempo messo il filo invece dell'antenna, risparmiandomi tanti casini con la stazione PCE e il modulo RFM01 ;)
Sarbbe un casino integrarlo attraverso GPIO?
Attachments:
Last edit: 2 years 6 months ago by hoshi_90.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7493 by asy961
installa come da istruzioni e non modificare percorsi.....

per il sensore pioggia non saprei...
bisognerebbe creare un driver adeguato che legga i dati da una porta libera sulla GPIO...
ma io non sono a quel livello....

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #7494 by seven
@asy961: Caspita Valerio, mi sa che è il record mondiale! :lol: :lol: :lol:
Io ero arrivato a circa 300 metri ma usavo una antenna direttiva TV, tu stai usando il semplice antennino in dotazione alla chiavetta USB?


@hoshi_90: Dai che ci sei quasi: la cartella 'build' devi crearla nella cartella principale in cui scompatti rtl_433, che alla fine dovrà presentarsi come in figura allegata.






A quel punto entra in /build con cd build, e poi segui la sequenza di comandi descritti nel post già citato.


P.S.: Opps, l'allegato mi è venuto enorme, ma almeno così è leggibile :P :P :P

P.S.2: Ho modificato il vecchio post con le istruzioni allegando l'immagine, in modo da rendere più chiaro il passaggio ad eventuali altri utenti interessati.
Attachments:
Last edit: 2 years 6 months ago by seven.
The following user(s) said Thank You: hoshi_90

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7497 by asy961

seven wrote: @asy961: Caspita Valerio, mi sa che è il record mondiale! :lol: :lol: :lol:
Io ero arrivato a circa 300 metri ma usavo una antenna direttiva TV, tu stai usando il semplice antennino in dotazione alla chiavetta USB?



Si Nicola....condizioni ottimali a 1600m slm....sensori a vista senza ostacoli in mezzo...chiavetta con antenna originale inserita nel portatile per fare prove.....ricezione regolare ogni 48s.... B) B) B)
questa chiavettta è proprio incrediblie

Stazione Meteo: Raspberry PI B, Sensori Vento PCE, BME280, Camera PI, Web Cam HD, Huawei K3765, Pannello Fotovoltaico 50W - 1 Batteria 12V-40Ah

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7505 by seven
Fantastico, davvero! Grazie per l'ottimo report Valerio! :cheer: :cheer:

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #7506 by Ciaschini
ciao a tutti ragazzi, ho anch'io acquistato un sensore 87 bit, ora sono in attesa di ricevere la chiavetta, nel frattempo ho problemi con il sensore rfm01 che riceve 87 bit e scarta la lettura.
a questo punto aspetto la chiavetta per mettermi al lavoro ;)
Last edit: 2 years 6 months ago by Ciaschini.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7507 by hoshi_90
Funzionaaa!! :woohoo:

Mille grazie asy961 e seven dell'aiuto e pazienza!

Ho avuto un frainteso dalle istruzzioni dove dice "nella cartella sorgente"
pensavo fosse intesa la cartella "src" (sources) :unsure:
L'italiano nn è mia madrelingua :whistle: ...

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7509 by seven

hoshi_90 wrote: Ho avuto un frainteso dalle istruzzioni dove dice "nella cartella sorgente"
pensavo fosse intesa la cartella "src" (sources)


Guarda, me la sentivo :lol: E' per quello che ho postato l'immagine, così da eliminare ogni dubbio :lol: :lol: :lol:
Ottimo hoshi_90, è un piacere!

Ciaschini ora tocca a te, ti aspettiamo :cheer:

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7515 by Ciaschini
Installato la chiavetta, seguito le instruzioni, anche io ho un sensore nuovo che lavora a 87 bit quindi ho anche seguito la modifica per gli 87 bit e....



...lavora alla grande!! :lol: grazie di tutto ragazzi :cheer: :cheer:

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7516 by seven
Grande Ciaschini!! :cheer: :cheer: :cheer: ;)

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #7517 by Ciaschini
ciao e buon natale a tutti!

ho fatto varie prove con la chiavetta e funziona molto bene, ma c'è un problema che mi fa diventare matto, ogni volta che riavvio, tutti gli estremi max e min vengono azzerati, ho controllato nel file meteo.txt e dopo il reboot risultano "null"

sapreste aiutarmi? :)


PS: il log sembra apposto, l'unica cosa che non mi torna, appena avviato, prima che sincronizzi l'orario, risulta sempre la data del 24 dicembre (data in cui ho installato la chiavetta), poi viene sincronizzata alla data attuale, FORSE in quel frangente swpi lo vede come un cambio di giorno e resetta i dati giornalieri? infatti il primo giorno al riavvio non c'erano problemi, mentre il problema si è presentato il giorno dopo

Warning: Spoiler! [ Click to expand ]
Last edit: 2 years 6 months ago by Ciaschini.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #7525 by seven
Uhm... Ho qualche dubbio sul fatto che dipenda dal driver della chiavetta...
Come sai la Raspberry non ha (di serie) il RealTimeClock, l'orologio di bordo presente nei normali PC che mantiene l'ora grazie ad una batteria tampone quando il PC è spento.
Quindi appena accesa la Rasp non 'sa' né che giorno né che ora sia, per questo appena rebootata interroga un server NTP (Network Time Protocol) che le fornisce gentilmente data ed ora (vedi la seguente riga nel log):

dom 25 dic 2016, 09.16.22, CET
[25/12/2016-09:16:22] System time adjusted from NPT server : europe.pool.ntp.org


E' SWPI che gestisce l'ambaradan (non il driver rtl-sdr), quindi ritengo si tratti di un comportamento 'normale' che si verifica a seguito di ogni reboot indipendentemente dal driver in uso...

Buon Natale e buone feste a te ed a tutto il forum!
Last edit: 2 years 5 months ago by seven.

Please Log in or Create an account to join the conversation.

Time to create page: 1.108 seconds