× Benvenuti sul nostro forum su Sint Wind PI!

Postate qui domande o segnalate problemi / bug che riscontrate,

file Webcam

More
6 years 1 month ago - 6 years 1 month ago #284 by tony
Webcam was created by tony
Grazie alle segnalazioni e test di Roberto ho aggiunto un nuovo driver per le webcam che effettivamente funziona molto bene e che, anche sulle mie webcam da 5€, da buoni risultati . Si tratta di fswebcam che ora è l'opzione di defaul per catturare da webcam. Restano a disposizione anche le altre due vecchie opzioni che erano ffmeg e uvcapture



Se avete una vecchia immagine di SWPI scaricata dal sito dovrete anche installare fswebcam con il comando ( le versioni swpi_xxx.img con xxx > 400 hanno già tutto preinstallato ):

sudo apt-get install fswebcam
Last edit: 6 years 1 month ago by tony.

Please Log in or Create an account to join the conversation.

More
6 years 1 month ago #285 by alegrechi
Replied by alegrechi on topic Webcam
Visto che adesso c'è un topic dedicato...

stavo pensando di aggiungere alla mia configurazione una fotocamera con scatto remoto o una buona webcam.

Le canon che supportano lo scatto remoto ho visto non sono molte e se si trovano (non facilmente) non costano poco (40-50€ minimo).

Ci sono delle webcam con buona risoluzione e buon prezzo che mi potete consigliare?

Sensori PCE-FWS20 + DVB-T RTL-433 + BMP085 online su meteostrada.grechi.it (Strada in Casentino - Arezzo - 406 m s.l.m.)

Please Log in or Create an account to join the conversation.

More
6 years 1 month ago - 6 years 1 month ago #286 by tony
Replied by tony on topic Webcam
Credo ci siano ancora poche esperienze con le webcam. Io ho un paio di webcam da 5€ che al massimo acquisiscono a 320x240. Comunque con fswebcam vengono delle immaginine decenti. Aspettiamo anche altri test con webcam HD

TT
Last edit: 6 years 1 month ago by tony.

Please Log in or Create an account to join the conversation.

More
6 years 1 month ago #292 by roberto2011
Replied by roberto2011 on topic Webcam
io ho provato una kraun kr.5m
www.kraun.it/pages/products/datasheet.sh...de=KR.5M&language=it

costa veramente poco ed arriva 640x480

un esempio lo trovi qui
www.fleanet.it/sint/slideshow.php

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
The following user(s) said Thank You: tony

Please Log in or Create an account to join the conversation.

More
6 years 1 month ago #331 by Luca_
Replied by Luca_ on topic Webcam
Un saluto a tutti e un ringraziamento particolare a Tony per il progetto Sint Wind PI che, a giudicare dalla partecipazione (e dal numero di visite) al forum sta veramente riscuotendo notevoli consensi.
Vengo al punto: dopo aver installato con successo il driver fswebcam, la web cam (una semplicissima Trust che avevo ferma a casa) viene regolarmente riconosciuta dal SO, ma -sicuramente per mia inesperienza- non riesco a visualizzare l'immagine sul sito (altervista) ed ottengo il seguente messaggio di errore:

System time adjusted from WH1080
Dir: NW - Spd: 0.0 - Gst: 1.08 - T: 15.0 - P: 1040.7 - U: 63 - R: 35 - CB: 1317
Webcam 1 Captured : ok : ./img/webcam1_09042013-184245.jpg
Processing image :./img/webcam1_09042013-184245.jpg
Processed image :./img/webcam1_09042013-184245.jpg
Checking internet connetion ...
Internet ok
Uploading data ...
Rereading config file ..
Disk space left = 1512550400
Sleeping 600 seconds

Exception 550 Impossibile cambiare la directory in nomesito.altervista.org/swpi: No such file or directory
Error sending file to server : current1.jpg
Deleted file : ./img/webcam1_09042013-184245.jpg

Sent file to server : meteo.txt
Deleted file : ./meteo.txt
Dir: NW - Spd: 1.08 - Gst: 5.04 - T: 15.0 - P: 1040.6 - U: 64 - R: 35 - CB: 1288
nella root del sito, all'interno della cartella a nome /swpi, ne ho creata una a nome /img.
Penso che sbaglio il puntamento, ma con quale modo devo indicare in quale cartella fare l'upload dell'immagine? Nell'interfaccia web non sono riuscito a trovare tale form.
Grazie per l'aiuto che potrete fornirmi.
Luca

Please Log in or Create an account to join the conversation.

More
6 years 1 month ago - 6 years 1 month ago #333 by tony
Replied by tony on topic Webcam
Ciao e benvenuto,

Mi sembra solo il solito problema con altervista che non vuole, a differenza di Aruba, il path del sito ...

Credo devi solo mettere al posto di : "nomesito.altervista.org/swpi" -->
"/swpi"

Controlla però anche sugli altri thread perché non ne sono sicuro ( non ho altervista ) ..

Potresti fare anche la prova con filezilla impostando la cartella iniziale per capire l'impostazione corretta.

[edit]
Il parametro da inserire è nella sezione FTP.
Last edit: 6 years 1 month ago by tony.

Please Log in or Create an account to join the conversation.

More
6 years 1 month ago - 6 years 1 month ago #334 by Luca_
Replied by Luca_ on topic Webcam
Grazieee!
Era proprio l'indicazione errata del percorso.
Aggiungo, a solo titolo informativo, che il "difetto" si è manifestato al momento dell'implementazione del sito con la webcam, in effetti la dashboard era visualizzabile in maniera corretta anche con il parametro "nomesito.altervista.org/swpi".
Cmq bene cosi, mi rimetto allo "smanettamento". Uscito dalla fase di test aggiungerò senz'altro le mie coordinate per la mappatura delle stazioni che utilizzano il SO da te scritto per la stazione meteo della PCE
Grazie ancora
Last edit: 6 years 1 month ago by Luca_.
The following user(s) said Thank You: tony

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #1245 by tetox
Replied by tetox on topic Webcam
Salve ragazzi...
E' da un bel po' che giochicchio felicemente con il swpi e non avevo mai provato una webcam su usb (utilizzo solo canon con gphoto),
ieri mi hanno attaccato sulla postazione remota di Camerano una Microsoft live cam , stamattina da remoto sto' cercando di tirar fuoti qualche immagine ...purtroppo nulla ,nel senso che dal log vedo ..ERROR in capturing webcam image on : /dev/video0 solamente questo ...allora ho provato il comando diretto
ffmpeg -f video4linux2 -s 320x240 -i /dev/video0 out.mpg
e funziona perfettamente !!!a questo punto chiedo ..oltre ad abilitare sul web.config /dev/video0, settato la risoluzione a 320x240,cos'altro vorra'??
poi, visto che con il comando diretto funziona, come posso catturare un solo frames ?? (ho provato anche -frames 1 ma mi fa' sempre il filmatino )
Grazie
Stefano

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #1255 by tony
Replied by tony on topic Webcam
Se funziona il comando singolo deve funzionare ( a meno di un bug ) anche swpi

il comando è semplicemnte :
snapCommand = "ffmpeg -loglevel quiet -t 1  -f video4linux2 -vframes 1 -s " + self.captureresolution + " -i " + self.device + " " + filename

controlla la tua configurazione

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #1267 by tetox
Replied by tetox on topic Webcam
Ciao Tony...
Come sempre il SintWind ha ragione lui !!!!
mi ostinavo a voler utilizzare come driver " fswebcam " (visto che era l'ultimo inserito !!) utilizzato il driver " ffmpeg " tutto e' OK !!perfetto , ..pazienza , sara' servito a rendersi conto che alla MicrosoftLiveCam NON piace il fswebcam .
Grazie Tony..alla prossima ..svista !!
Stefano

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago - 5 years 8 months ago #1268 by tetox
Replied by tetox on topic Webcam
.Pardon!!messaggio doppio!!
Last edit: 5 years 8 months ago by tetox.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #1554 by Andreano
Replied by Andreano on topic Webcam
Salve, vorrei segnalare che anche la fotocamera TRUST 710 LCD POWERC@M ZOOM viene riconosciuta correttamente.
Saluti a tutti. Raffaele.
The following user(s) said Thank You: tony

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #1555 by tony
Replied by tony on topic Webcam
Grazie dell'info :-)

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1660 by zippo68
Replied by zippo68 on topic Webcam
Funziona bene anche la Microsoft Lifecam Studio HD , con fswebcam .
Ciao

First step :
Sensori Meteo WH1080+RFM01 868Mhz + Raspberry "Sint Wind Pi" online dal 23 Aprile 2013 al 22 Agosto .
Second step :
Davis Vantage pro2 + weatherlink .

Work in progress : Webcam ip e Vantage pro2 +Sint Wnd Pi
The following user(s) said Thank You: tony

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1683 by alegrechi
Replied by alegrechi on topic Webcam
Ho notato che se si inviano tutte le immagini sul server queste vengono salvate in un'unica cartella. Al crescere del numero dei file ciò può essere molto pesante e sovraccaricare il server.
Credo bisognerebbe rivedere il codice e suddividere le immagini in sottocartelle anno/mese/giorno !

Sensori PCE-FWS20 + DVB-T RTL-433 + BMP085 online su meteostrada.grechi.it (Strada in Casentino - Arezzo - 406 m s.l.m.)
The following user(s) said Thank You: zippo68

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1684 by roberto2011
Replied by roberto2011 on topic Webcam
Soluzione moltoooo brutta ma funzionale almeno per me :)
ordina.asp è uno script in asp classic
index.php è una galleria in php in base alle cartelle
galleria

Sensori Davis +BME280 + Raspberry b+ webCam serrasanta.fleanet.it (Eremo di Serrasanta - Gualdo Tadino - 1.340 m s.l.m.)
Attachments:
The following user(s) said Thank You: alegrechi, zippo68

Please Log in or Create an account to join the conversation.

  • Centauri
  • Centauri's Avatar
  • Visitor
  • Visitor
5 years 8 months ago - 5 years 8 months ago #1697 by Centauri
Replied by Centauri on topic Webcam
Ciao a tutti,
spero sia il topic giusto. ;)
Ho installato da poco una webcam Creative (il modello non lo ricordo) parecchio anzianotta sul Raspberry con SintPI ultima versione: 01.20.20
La cosa strana è che le immaggini vengono composte in maniera disordinata, alcune volte l'immagine è a posto, il più delle volte è tutta scombinata.
Ho già provato sia con i driver fswebcam sia con ffmpeg, ma nulla da fare.
Avete idea se secondo voi possa essere un problema di secure digital danneggiata oppure si tratti di webcam danneggiata o non compatibile

Non è un problema di invio corrotto verso il server ftp, perchè le ultime prove le ho fatte verificando le immagini presenti in /home/pi/swpi/img/

Allego qualche immagine consecutiva (vengono scattate ogni 3 minuti)
Prima di cambiare cam, chiedevo se qualcuno ha qualche idea o suggerimento.
Dimenticavo, nel fiel di log non ci sono errore relativi alla immagine e al suo processo.
============
[02/09/2013-19:01:31] Webcam 1 Captured : ok : ./img/webcam1_02092013-190127.jpg
[02/09/2013-19:01:31] Processing image :./img/webcam1_02092013-190127.jpg
[02/09/2013-19:01:31] Processed image :./img/webcam1_02092013-190127.jpg
[02/09/2013-19:01:32] Checking internet connetion ...
============
Saluti Stefano
Attachments:
Last edit: 5 years 8 months ago by Centauri.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1698 by tony
Replied by tony on topic Webcam
Difficile rispondere,

Sembrerebbe un problema di compatibilità dei driver del raspberry. Fossi in te cercherei su intenet il modello esatto e delle info sullqa compatibilità con raspberry o anche debian o ubuntu

TT

Please Log in or Create an account to join the conversation.

  • Centauri
  • Centauri's Avatar
  • Visitor
  • Visitor
5 years 8 months ago #1705 by Centauri
Replied by Centauri on topic Webcam
Grazie Topny, in effetti non ho mai provato quella cam con Linux, giusto per approfondire. Era solo per capire quale fosse il problema, dato che non sempre si comporta nello stesso modo. Installerò altre webcam e vi terrò aggiornati nel caso ne trovi una altra non elecata che funzioni senza problemi.
Grazie comunque ;)

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1722 by thehdstream
Replied by thehdstream on topic Webcam
Salve, io ho un problema. la webcam viene letta però quando swpi va per catturare ottengo l'errore "Unable to find a compatible palette format.". A Cosa è dovuto? come posso risolvere?

Grazie in Anticipo :)

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1723 by tony
Replied by tony on topic Webcam
Che driver usi per la cattura ? . Ne hai provati altri ?

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1724 by thehdstream
Replied by thehdstream on topic Webcam
gli ho provati tutti e tre. ho testato due webcam senza successo

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #1725 by tony
Replied by tony on topic Webcam
Allora sembrerebbe un problema di compatibilità dei driver linux con quel topo di camera . Cercherei in rete ....

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #7328 by Pietro
Replied by Pietro on topic Webcam
Ciao,
oggi ho provato ad installare una canon 400D che sembra scattare all'intervallo stabilito. Leggendo sul forum sono riuscito a capire come inviare il file al sito. In realtà il sito per ora non mi interessa, mi interessa di più l'app sullo smartphone sul quale non vedo nulla.
Ho dimenticato qualcosa?
Nell'app la mia stazione è la 26 Torino(TO)


[02/10/2016-16:05:02] System time adjusted from NPT server : time.windows.com
[02/10/2016-16:05:02] Deleted file : /dev/shm/meteo.txt
[02/10/2016-16:05:02] Sending file to server : meteo.txt OK Deleted
[02/10/2016-16:05:31] Calculating Meteo data and statistics
[02/10/2016-16:05:32] Logging data to Database
[02/10/2016-16:05:32] Dir: SSW - Spd: 5.04 - Gst: 6.12 - Tout: 21.7 - Tin: 26.9 - Hout: 62.0 - Hin: 56.0 - P: 1012 - Rtot: 2421.3 - RDay: 0.0 - R1h: 0.0 - R24h: 2372.3 - CB: 1185
[02/10/2016-16:05:46] Using Dayligth settings,,,,,,,,,,
[02/10/2016-16:05:46] 1 Cameras found
[02/10/2016-16:05:46] Camera 1 : Canon EOS 400D (PTP mode) Port : usb:001,005 USB : 001 005
[02/10/2016-16:05:46] Capturing from Camera : 1 = Canon EOS 400D (PTP mode)
[02/10/2016-16:05:52] Downloading 'IMG_4509.JPG' from folder '/store_00000001/DCIM/101CANON'...
[02/10/2016-16:05:52] Deleting 'IMG_4509.JPG' from folder '/store_00000001/DCIM/101CANON'...
[02/10/2016-16:05:52] Captured : ./img/camera1_02102016-160546.jpg
[02/10/2016-16:05:52] Processing image :./img/camera1_02102016-160546.jpg
[02/10/2016-16:05:53] Processed image :./img/camera1_02102016-160546.jpg
[02/10/2016-16:05:53] Checking internet connetion ...
[02/10/2016-16:05:53] Internet ok
[02/10/2016-16:05:53] Sending :camera1.jpg
[02/10/2016-16:05:53] Logging data ...
[02/10/2016-16:05:53] Data sent to server : OK
[02/10/2016-16:05:53] Logging data to Wunderground ...
[02/10/2016-16:05:54] Log to Wunderground : success
[02/10/2016-16:05:54] Uploading data ...
[02/10/2016-16:05:54] Logging to CWOP server ...
[02/10/2016-16:05:54] Sending file to server : camera1.jpg OK
[02/10/2016-16:05:55] Deleted file : /dev/shm/meteo.txt
[02/10/2016-16:05:55] Sending file to server : meteo.txt OK Deleted
[02/10/2016-16:05:57] EW3586 Ok
[02/10/2016-16:05:57] Logging data to PWS ...
[02/10/2016-16:05:58] Log to PWS : Data Logged and posted in METAR mirror.
[02/10/2016-16:05:58] Rereading config file ..
[02/10/2016-16:05:58] Disk space left = 4195 Mb
[02/10/2016-16:05:58] Deleted file : ./img/camera1_02102016-160546.jpg
Sun Oct 2 16:05:59 CEST 2016
[02/10/2016-16:05:59] System time adjusted from NPT server : time.windows.com
[02/10/2016-16:05:59] Using Dayligth settings,,,,,,,,,,
[02/10/2016-16:05:59] 1 Cameras found
[02/10/2016-16:05:59] Camera 1 : Canon EOS 400D (PTP mode) Port : usb:001,005 USB : 001 005
[02/10/2016-16:05:59] Capturing from Camera : 1 = Canon EOS 400D (PTP mode)
[02/10/2016-16:06:01] Log to Wunderground : success
[02/10/2016-16:06:02] Deleted file : /dev/shm/meteo.txt
[02/10/2016-16:06:02] Sending file to server : meteo.txt OK Deleted
[02/10/2016-16:06:05] Downloading 'IMG_4510.JPG' from folder '/store_00000001/DCIM/101CANON'...
[02/10/2016-16:06:05] Deleting 'IMG_4510.JPG' from folder '/store_00000001/DCIM/101CANON'...
[02/10/2016-16:06:05] Captured : ./img/camera1_02102016-160559.jpg
[02/10/2016-16:06:05] Processing image :./img/camera1_02102016-160559.jpg
[02/10/2016-16:06:06] Processed image :./img/camera1_02102016-160559.jpg
[02/10/2016-16:06:06] Checking internet connetion ...
[02/10/2016-16:06:06] Internet ok
[02/10/2016-16:06:06] Sending :camera1.jpg
[02/10/2016-16:06:06] Logging data ...
[02/10/2016-16:06:06] Data sent to server : OK
[02/10/2016-16:06:06] Logging data to Wunderground ...
[02/10/2016-16:06:06] Log to Wunderground : success
[02/10/2016-16:06:06] Uploading data ...
[02/10/2016-16:06:06] Logging to CWOP server ...
[02/10/2016-16:06:07] Sending file to server : camera1.jpg OK
[02/10/2016-16:06:07] Deleted file : /dev/shm/meteo.txt
[02/10/2016-16:06:07] Sending file to server : meteo.txt OK Deleted
[02/10/2016-16:06:10] EW3586 Ok
[02/10/2016-16:06:10] Logging data to PWS ...
[02/10/2016-16:06:10] Log to PWS : Data Logged and posted in METAR mirror.
[02/10/2016-16:06:10] Rereading config file ..
[02/10/2016-16:06:10] Disk space left = 4195 Mb
[02/10/2016-16:06:10] Sleeping 48 seconds
Sun Oct 2 16:06:12 CEST 2016
[02/10/2016-16:06:12] System time adjusted from NPT server : time.windows.com
[02/10/2016-16:06:30] Calculating Meteo data and statistics
[02/10/2016-16:06:30] Logging data to Database
[02/10/2016-16:06:30] Dir: E - Spd: 3.6 - Gst: 6.12 - Tout: 21.9 - Tin: 26.9 - Hout: 60.0 - Hin: 56.0 - P: 1012 - Rtot: 2421.3 - RDay: 0.0 - R1h: 0.0 - R24h: 2364.3 - CB: 1248
[02/10/2016-16:06:58] Deleted file : ./img/camera1_02102016-160559.jpg
[02/10/2016-16:06:59] Using Dayligth settings,,,,,,,,,,
[02/10/2016-16:06:59] 1 Cameras found
[02/10/2016-16:06:59] Camera 1 : Canon EOS 400D (PTP mode) Port : usb:001,005 USB : 001 005
[02/10/2016-16:06:59] Capturing from Camera : 1 = Canon EOS 400D (PTP mode)
[02/10/2016-16:07:00] Log to Wunderground : success
[02/10/2016-16:07:02] Deleted file : /dev/shm/meteo.txt
[02/10/2016-16:07:02] Sending file to server : meteo.txt OK Deleted
[02/10/2016-16:07:05] Downloading 'IMG_4511.JPG' from folder '/store_00000001/DCIM/101CANON'...
[02/10/2016-16:07:05] Deleting 'IMG_4511.JPG' from folder '/store_00000001/DCIM/101CANON'...
[02/10/2016-16:07:05] Captured : ./img/camera1_02102016-160659.jpg
[02/10/2016-16:07:05] Processing image :./img/camera1_02102016-160659.jpg
[02/10/2016-16:07:06] Processed image :./img/camera1_02102016-160659.jpg
[02/10/2016-16:07:06] Checking internet connetion ...
[02/10/2016-16:07:06] Internet ok
[02/10/2016-16:07:06] Sending :camera1.jpg
[02/10/2016-16:07:06] Logging data ...
[02/10/2016-16:07:06] Data sent to server : OK
[02/10/2016-16:07:06] Logging data to Wunderground ...
[02/10/2016-16:07:07] Log to Wunderground : success
[02/10/2016-16:07:07] Uploading data ...
[02/10/2016-16:07:07] Logging to CWOP server ...
[02/10/2016-16:07:07] Sending file to server : camera1.jpg OK
[02/10/2016-16:07:08] Deleted file : /dev/shm/meteo.txt
[02/10/2016-16:07:08] Sending file to server : meteo.txt OK Deleted
[02/10/2016-16:07:10] EW3586 Ok
[02/10/2016-16:07:10] Logging data to PWS ...
[02/10/2016-16:07:11] Log to PWS : Data Logged and posted in METAR mirror.
[02/10/2016-16:07:11] Rereading config file ..
[02/10/2016-16:07:11] Disk space left = 4195 Mb
[02/10/2016-16:07:11] Sleeping 48 seconds
Sun Oct 2 16:07:11 CEST 2016

Please Log in or Create an account to join the conversation.

Time to create page: 0.802 seconds